Youtube 10-Second Black Screen

Hey, new to PiHole here and really loving it. One problem though -- there's about a 10ish-second delay at the beginning of every Youtube video, but only in Chrome. I think it has to do with the way Chrome renders pages, but I'm not sure.

When I click on a video and the video page loads up, the actual video portion is black except for the controls (which don't do anything because there's no video to play). Then, about 10 seconds later, a little grey box with a frowning file icon will appear where the page ad should be and the video will start to play. It seems like Chrome is trying to get a response from whatever ad is being pi-holed before loading the video.

On Microsoft Edge, there is no such issue. The video loads and plays instantly and in the page ad's place there's an error message about loading (which there should be).

Is there any way to fix this? Is this even a common issue or something specific to my setup? I've tried disabling all browser extensions in Chrome, but that does not fix the issue.

EDIT: In addition to not experiencing this issue on Microsoft Edge, I also do not encounter the black screen on the Youtube app on my phone. I do not see any ads, on-page or in-video, on Youtube.

I've also been having the same issue on Chrome. As a temporary fix, I'm using uBlock Origin to block out Youtube ads in their entity.

i ve had this issue once too. not sure what it could be.

Can you please try blacklisting these domains and see if it helps? Wait a while though as YouTube has been known to cache some ads.

I think you missed the URL from that hyperlink. I am also having the same issue.

the "hyperlink" is not referred

I think this was supposed to be the linked page: How do I block ads on YouTube?

I've seen that page, and I've tried the white/blacklist recommendations, but the delay is still there.

What platform and browser are you using?

I'm using Chrome on Windows 10.

I just noticed that the delay only happens when there's an ad that's supposed to play at the beginning of a video.

I am still having a problem after adding those additional addresses to my blacklist.

Likewise here --- it doesn't seem that this blacklist blocks even 50% of Youtube ads.

Just out of curiosity, @Decompiled and @aspecialvisit, what upstream DNS providers are you using?

Google --- and --- are you using something different?

Using the YouTube blacklist domains and OpenDNS as my upstream, I rarely, if ever see a YouTube ad. I'm just looking for clues outside of Pi-hole since some people seem to block them but others don't.

I'll try using OpenDNS and report back. Agreed that this is confusing, since it's clear that some people are having no trouble blocking youtube ads.

OK. And please be sure to wait a while before reporting the findings as there may be cached ads along the way (on Pi-hole, on your browser, via your OS, and/or via your upstream DNS).

It might be a bit too soon to celebrate, but; I'm not seeing ads any longer. Unfortunately, I didn't troubleshoot correctly --- I made two changes at the same time.

  1. Changed pihole to OpenDNS
  2. Cleared 100% of my browser cache

I have a couple other PCs in the house whose browser caches have not been cleared, so I'll see what sorts of results I get on them. In the meantime, Youtube ads do seem to be blocked. I'll report back about the browser cache on other devices, as well.

Interesting. Let's see @Decompiled can also get it to work by switching to OpenDNS.