Pi-Hole blockiert keine Werbung

Hallo,

ich habe heute Pi-Hole auf einem Raspberry Pi installiert und den DNS zum Testen nur auf meinem PC umgestellt. Leider bekomme ich trotzdem noch Werbung wie ohne AdBlocker.
Ich nehme an das es eher ein kleiner Fehler sein wir aber leider komme ich nicht drauf.

Was kann der Grund sein oder was kann ich testen damit das Problem eingegrenzt werden kann?

IP des Raspberry: 192.168.0.200
Debug Token: t73y3hq3ts
ipconfig /flushdns habe ich probiert.

Danke im Voraus!!!

Your debug log shows that Pi-Hole is working properly. The most likely problem is that the PC has a second DNS it is using to bypass Pi-Hole. What are the outputs of the following commands run from the PC:

nslookup pi.hole

nslookup cnn.com 8.8.8.8

nslookup pi.hole:

Server: pihole
Address: 192.168.0.200
Name: pi.hole
Address: 192.168.0.200

nslookup cnn.com 8.8.8.8:

Server: google-public-dns-a.google.com
Address: 8.8.8.8

Nicht autorisierende Antwort:
Name: cnn.com
Addresses: 2a04:4e42:400::323
2a04:4e42:200::323
2a04:4e42:600::323
2a04:4e42::323
151.101.193.67
151.101.129.67
151.101.1.67
151.101.65.67

Thanks for your fast reply!!

Ich befasse mich zwar auch erst seit kurzem mit Pi-Hole
aber es sieht wohl so aus als ob du noch nen IPv6 DNS als zweiten DNS Server eingetragen hast. Kann das sein?

Was f√ľr ein Internetanschluss bzw. Anbieter hast du?
Zufällig DS-Lite oder so?

Folgende Fragen könnten das Problem vllt. eingrenzen.

  1. Was hast du in deinem Internetrouter/Modem als DNS Server f√ľrs Internet selbst eingetragen?
    Irgendwelche "eigenen" Server oder automatisch die vom Internetanbieter?
  2. Was hast du in deinem Internetrouter/Modem als DNS Server f√ľr eigene LAN Netzwerk eingetragen?
  3. Falls du einen DS-Lite Anschluss hast z.B.: Unitymedia, welchen Router hast du?
    Ne Fritzbox? oder was genau?

So sieht es √ľbrigens bei mir mit DS-Lite Anschluss aus:

nslookup cnn.com 8.8.8.8
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	cnn.com
Address: 151.101.1.67
Name:	cnn.com
Address: 151.101.129.67
Name:	cnn.com
Address: 151.101.193.67
Name:	cnn.com
Address: 151.101.65.67

VG

Am PC selbst sehe ich keinen eingetragenen IPv6 DNS.

Anbieter ist A1, bin von √Ėsterreich.

  1. Im Internetrouter sind die A1 eigenen DNS Server eingetragen. Die habe ich nicht geändert. (194.48.139.254,194.48.128.199)

  2. Meinst du welchen DNS der DHCP verteilt? Das habe ich leider bei dem Router nicht ändern können :frowning_face:. Deshalb habe ich es mal manuell nur bei meinem PC eingetragen.

  3. Router habe ich einen Huawei HA 35-22 von A1 selbst. Hätte heute mal geschaut ob ich den Router auf SU um stellen kann und einen eigenen Router dahinter verwende. Leider ist das bei einem Hybrid Modem schwer möglich. Damit könnte ich mir auch selbst beim DHCP den DNS umstellen. Aber leider sperrt A1 fast alle Einstellmöglichkeiten.

Das Sprengt meine Kenntnisse bez√ľglich Pi-Hole. Sorry

Wenn du aber keine √∂ffentliche IPv6 Adresse von A1 bekommst bzw. einen reinen IPv4 Anschluss hast k√∂nntest du h√∂chstens noch Testen bzw. nachschauen ob du den DHCP Server auf dem Huawei deaktivieren kannst und dann alles √ľber Pi-Hole laufen l√§sst.

Also Huawei DHCP aus und DHCP Server von Pi-Hole nutzen.
Unter Pi-Hole stellst du dann unter DNS bei Customs die IP Adresse von dem Huawei ein sowie bei "Use Conditional Forwarding" die IP und den Hostnamen vom Huawei ein.

Zum Test dann in deinem PC eine statische IP Eintragen und als DNS Server die IP vom Pi-Hole. Falls es dann klappt brauchst du nur noch den DHCP Server auf dem Pi-Hole einrichten. Zumindest wäre das meine Vorgehensweise.

Aber vielleicht findet sich ja hier auch User der sich besser mit dem Huawei auskennt oder selbst √ľber den Anbieter A1 online ist.

VG

Is the output correct or something wrong with it?

Hallo Gundi,
es gibt viele Gr√ľnde weshalb dein Pi nichts blockt.
Ich weiß nicht wie deine PC-Kenntnisse sind und was du alles genau eingestellt hast.

Was du auf jeden Fall machen musst:
-in deinem Router DHCP Server aktivieren und dort die Adresse deines Pi Hole, bei DNS Server eintragen
-die Netzwerkeinstellungen deines Zugangsger√§ts √ľberpr√ľfen und ggf. dort bei DNS Server ebenfalls die IP deines PI Hole eintragen
-dann bei deinem PI ->settings->DHCP->DHCP Server aktivieren->Bei Router(gateway) die IP deines Routers eintragen-> dann am besten alles Neustarten

Im "Neuzustand" ist PI Hole recht "nackt" und blockt kaum etwas.
Um schnell zu Testen ob dein PI blockt, einfach auf Blacklist-> ^(.+.)??(facebook|.fb.+).(com|net)$ kopieren&einf√ľgen -> regex klicken-> kurz warten und dann versuchen Facebook aufzurufen. FB sollte nicht mehr erreichbar sein, kann bei bedarf wieder entfernt werden.

es gibt Seiten auf denen du Listen mit Adressen herunterladen bzw. deiner PI hinzuf√ľgen kannst.
In meinen Augen sind Regex Filter Sinnvoller, da man dort sehr viel effektiver arbeiten kann.
Ich hatte mal 4,5mio Adressen auf zig Listen.
Jetzt nur noch ein paar tausend Regex Filter.

Ich bin leider kein Experte was Linux angeht, aber ich hoffe es hilft :wink:

Hallo,

PC-Kenntnisse sind vorhanden.
Habe jetzt mal ^(.+.)??(facebook|. fb.+).(com|net)$ eingetragen.
Facebook kann man nun nicht mehr aufrufen. Scheint so als w√ľrde alles funktionieren.
Habe aber auch gelesen das er im Neuzustand auch schon super funktionieren soll. Leider wird bei mir bei Youtube √ľberhaupt nichts blockiert.

Ich habe momentan das AdBlock Plugin wo man genauso sieht welche Listen dieses Plugin verwendet. Ich habe die zus√§tzlich zu den vordefinierten Listen hinzugef√ľgt.
Leider wird trotzdem noch nichts bei Youtube blockiert.

Ich habe das ganze vor 2 Wochen auch schon mal versucht und einige Listen hinzugef√ľgt.
Bei Youtube war es dann so das die kleine Werbung (die unten in der Mitte angezeigt wird) nicht mehr angezeigt wurde aber der Rahmen trotzdem noch vorhanden war. Ist das normal ?
Mach ein Plugin mehr als die Werbelinks zu sperren ?
Sollte ich ein gleiches Ergebnis wie mit dem Plugin erreichen?

Ich habe jetzt Liste hinzugef√ľgt. Habe 2.6 Millionen Domains Blockiert.
Werbung bei Youtube kommt trotzdem noch wie wenn gar nichts blockiert wird.

Youtube muss wohl auch nen special Fall sein :frowning:
Am besten schaust du mal hier nach:

https://discourse.pi-hole.net/t/how-do-i-block-ads-on-youtube/253

https://discourse.pi-hole.net/t/youtube-10-second-black-screen/495

VG

Wie Mad-M4x schon gesagt hat, YT ist ein spezieller Fall.
Immerhin funktioniert dein PI wie es soll :wink:
Ich habe gestern einige Zeit experimentiert und es scheint nicht ganz einfach Werbung zu eliminieren.
Nur mit PI und verschiedenen Script/Ad-Blockern, war es nicht möglich Werbung auf YT zu blocken.
Es gibt wohl unzählige Server und eben auch Scripts die sich nicht so ohne weiteres umgehen lassen.

Zum surfen benutze ich persönlich eh ein VPN und der filtert interessanterweise die Werbung raus.
Ich habe mein PI hauptsächlich zum Schutz der Geräte, die kein VPN nutzen können bzw. wegen der Privatsphäre. So kann ich wenigstens alle Datensammler weitestgehend aussperren, wie mein Samsung Smart TV. Die schlimmste Datenschleuder die ich je erlebt habe, enorm was der versucht zu senden.

Versuche auch lieber den Fokus auf Privatsphäre zu richten, also alles was dich verfolgt blocken.
Denn viele Seiten machen es immer schwerer die Werbung zu blocken, was einerseits verständlich ist.
F√ľr mich ist Werbung ein notwendiges √úbel, denn sonst w√§re es leider nicht umsonst bzw. nicht verf√ľgbar.
Es gibt Seiten, da lasse ich Werbung sogar zu, eben nur Privatsphäre ist wichtig.

Mit den richtigen Add-ons f√ľr Firefox/Chrome, l√§sst sich da viel machen.
->>Privavcy Badger, unterbindet tracking
->>Cookie Autodelete, wichtig um keine Daten anzuhäufen
->>Random User Agent, wechselt die Identit√§t des Browsers automatisch, erschwert Erkennung vom Benutzer √ľber Seiten hinweg. Denn auch daran kann man gut verfolgt werden.
->>NoScript, blockiert Scripts u.a. auch Werbung

Ich hab in meinem Router einfach die zweite dns adresse also die alternative entfernt die vom pi als einzige stehen lassen und die Werbung war weg. hatte das Problem das sobald ich das pi herunterfahre und oder ausstecke die Werbung NUR auf wetter.de angezeigt bekam.

Im Router trägst du bei den DNS Feldern die IP4/IP6 Adressen des Pi-Hole ein.
Bei PI-Hole bei Setting/DNS trägst du die DNS Adressen deines Providers ein (194.48.139.254,194.48.128.199).

Das sollte funzen.

P.S.
Niemand braucht 2,6 Mio geblockte Server. Damit kastriert man sich viele Funktionen im PC.
Wenn der Pi-Hole Werbung nicht blockt, ist meist ein IPv6 DNS schuld, der unkonfiguriert ist.

Ich kenne derzeit nur die Telekom Speedport Router ein, die nicht mit Pi-Hole funzen, da sie √ľber das IPv6 DNS die Telefonie routen. Dazu gibt es einige Diskussionen. Telekom-Mist mit Eigenleben halt.