New PiHole setup not blocking on clients

Just setup Rpi3 with Jessie (lite) and I've changed two clients DNS addresses to the PiHole and it's not blocking any sites' ads. One is a note 3 (only IPv4 is set because I don't think my note 3 has IPv6 settings) and a iphone 5c (both IPv4 and IPv6 are setup). I've also installed resolvconf after the installation as I found that wasn't installed by default. On the dash it shows that its blocking ads for both but the ads still show up on the devices (Youtube, engadget etc.). I did pihole -d but don't know exactly what to post for debugging.

What does your Query Log say? Does that make any sense, i.e. is it connected to what you visit on your devices? If so, are there any ads that are marked as "Pi-holed" in the Query Log but still make it through to your device?

Query log shows sites being pi-holed and others being allowed so it really looks like its working on the Rpi end. Also im blocking about 20% of sites accessed and have tried several sites with no luck. Biggest indicator was youtube ads still working. Also i have about 974,000 domains blocked with that mega list on reddit.

A random token should have been generated after the debug process is complete.

::: Would you like to upload the log? [y/N] y
::: Your debug token is : 5b4c6hs2v4
::: Please contact the Pi-hole team with your token for assistance.

We use this unique token to find the log after it is uploaded to our server. Then we can take a look to see where any problems might be.

It sounds like Pi-hole is probably working...send us the token from pihole -d and we can take a look for sure.

Token: bxunkz695m

Also please excuse the site visited. Only one i could think of quick enough in 60 seconds.

We don't judge anyone, we're just here to help people get Pi-hole working. And as far as your install goes, it appears to be blocking correctly.

I did see some errors referring to the new settings page; have you adjusted anything there?

YouTube and other video ads are hard for our type of blocker to handle because of how they're sent to the user.

Good point, I just re-read your OP and realized I looked over that the first time. Take a look at these two posts on blocking YouTube as it seems Pi-hole is blocking properly via your log.

Ok so i've switched to openDNS and restarted from the admin control panel as per the post mentioned. I'm skipping youtube since it is difficult to block but the other sites i tried before are still showing ads. Let me know if there is a good site to check with the chrome app on android. Also i dont think i've changed any settings besides installing resolvconf and now changing the dns server from google to opendns. Let me know which setting is showing a problem and ill check it out.

Also i just went to in incognito to check where it forwards me and instead of openDNS it just goes to my ISP dns. Same thing happened when i had google set as dns.

This was a false alarm and is not connected with your problem.

Sounds like the clients that you are trying to blocvk the adds on are still leaking their DNS requests through to your ISP. I would recommend setting your routers DNS to youir pihole and having the PiHole do the rest. Failing this, if your ISP's router does not allow forwarding DNS requests to a custom server, Follow the advice from step 3 HERE:-

Linus did cover this section on a youtube video, but in basic terms, if your ISP provided router/AP does not allow setting custom DNS servers, disable the DHCP option on the router and enable the same setting on the pihole. This will enable PiHole to act as a DNS resolver for all your divices on your network without having to manually change settings on a device by device basis.

I've done this myself, and it's as simple as changing a couple of settings.

Sould be easy enough!

P.S, There is a second helpfull article HERE:- How do I use Pi-hole's built in DHCP server (and why would I want to)? on how to enable the DHCP server on the PiHole and disabling it on your router. In simpler terms, your PiHole becomes your DHCP server and DNS resolver, NOT your router.