Verzweiflung pur - Lange Verzögerungen & Ladezeiten oder gar keine Funktionen

Hallo,

ich bin kimi.
Nutze den pihole auf einem raspi4 / FB7490 / Glasfaseranschluss.
-auch hängt dr raspi direkt am router-

Ich habe wohl einen Fehler gemacht, in dem ich viel gegoogelt habe und immer wieder etwas “umgestellt” habe in der FB und ggf wohl pihole settings (webbrowser).

Jetzt habe ich folgendes hart frustrierendes Phänomen:

Ich habe oftmals ultra lange Ladezeiten, dann geht es irgendwann schnell oder gar nicht.
Das merke ich vorallem an mobilen Endgeräten im Wlan.

Ich weiß nicht ob es an dieser Stelle sinnvoll ist, meine komplette Config in Screenshots zu posten - oder das sich nicht einfach jmd von den Profis kurz aufschaltet und sich das mal anschaut.

Bin echt soweit am verzweifeln, dass ich kurz davor bin den pi hole abzuklemmen.

Kann mir bitte jmd helfen?
Vielen vielen Dank im Voraus
kimi

1 Like

Hallo kimi !

Neben der Schwierigkeit, dass wir uns dafür erst einmal auf ein Tool zum Draufschalten einig werden müssten: Der Sinn des Forums ist ja unter anderem, dass Leute mit ähnlichen Problemen hier Lösungsansätze nachschlagen können - wenn ich bei Dir was konfiguriere, haben die anderen aber nichts davon. Ich wäre zudem auch vorsichtig damit, Fremden den Fernzugriff auf meinen Rechner zu erlauben. Ich bin übrigens auch nur ein User hier.

Zu Deinem Problem:
Das Posten von Screenshots ist erst einmal nicht sinnvoll, solange wir Dein Problem nicht besser beschrieben haben, denn:

Es gibt eine Vielzahl von potentiellen Ursachen für schwankende Geschwindigkeiten im WLAN.

Hier nur einige:

  • Alle mobilen Endgeräte im WLAN müssen sich prinzipiell die Bandbreite teilen- je mehr Geräte angebunden und gleichzeitig aktiv sind, desto geringer fällt auch die für ein Gerät verfügbare Netzgeschwindigkeit aus.
  • Auch benachbarte WLAN-Netze können Deine Bandbreite beeinträchtigen, wenn sie auf demselben Kanal wie Dein Router unterwegs sind.
  • Daneben spielt natürlich auch Dein momentaner Standort und die Entfernung zum Router eine Rolle.
  • Einzelne WLAN-Funkkanäle können außerdem z.B. durch Wetter-Radar zu einer kurzfristigen Abschaltung gezwungen werden, was Deinen Router zu einem Kanalwechsel zwingt.
  • Wenn Du Repeater in Deinem Netz installiert hast, kann es außerdem sein, dass Dein Mobilgerät in Grenzbereichen bei nur mittelprächtigem Empfang vom Repeater zum Router und wieder zurück wechselt, in der Hoffnung, eine stabilere Verbindung hinzubekommen.
  • Der von Dir gewählte oder von Deinem ISP vorgegebene Upstream-DNS-Server könnte kurzfristig überlastet oder ausgefallen sein.
  • Es könnte natürlich auch Apps auf Deinem Smartphone geben, die verzweifelt versuchen, ihre jetzt geblockten Trackingserver zu kontaktieren und erst nach hunderten Versuchen aufgeben.

Lange Ladezeiten sind also nicht zwingend durch Pi-hole verursacht - oft werden tracking- und werbelastige Webseiten dank Pi-hole-Filterung sogar schneller im Browser geöffnet, da weniger heruntergeladen werden muss.

Können wir das Problem irgendwie eingrenzen?
Was lässt Dich vermuten, dass Pi-hole bei Dir diese langen Ladezeiten verursacht?
Treten die ultra langen Ladezeiten mit bestimmten Anwendungen auf? Mit welchen?
In welchen Situationen kommt es zum Wechsel zwischen schnell/langsam?

Hi und vielen Dank für Dein Reply.

Der Vorschlag das Problem via Teamviewer und Co zu lösen ist wohl meiner Verzweiflung geschuldet.
Ich bin nahezu ratlos

Ich kann wohl mit ziemlicher Sicherheit sagen, dass es an den Einstellungen der FB oder piholes hängt.

Verfüge aktuell über 400 / 200 Mbit fullduplex mit einem dazugehörigen AVM Wlan Mesh.
Denke das die Infrastruktur hier reicht.
Bandbreitenhungrige Anwendungen werden zumindest in der Zeit wo die Verzögerungen auftreten nicht gefahren.

Ich denke es kann nur ein DNS Ping Pong sein. Aktuell treten die Delays bei ver. Anwendungen auf.
Surfen / Instagram / Twitter / Smarthome App(die ich im Wlan nur schwer erreichen kann)

Also dann doch Screenshots senden?

Grüße

Was lässt Dich das glauben?
Hast Du keine Probleme, wenn Du den Pi-hole deaktivierst?

Hmm, bei Mesh könnte es sein, dass es eine Weile braucht, bis die neuen Einstellungen der Fritzbox auch in den anderen APs ankommen. Eventuell muss man die APs auch manuell konfigurieren, da bin ich eindeutig überfragt. Das hängt von den Geräten ab.

Hatte ich vor Pihole nicht.

Wenn ich jetzt deaktivieren soll. Müsste ich wissen, welche Settings ich rückgängig machen muss, so dass alles reibungslos ohne pihole klappt.

Ein einfacher shutdown des Raspis reicht hier ja leider nicht.

Bevor ich den Rückbau aber vornehme, würde ich gern alles andere ausschließen.

Ok, die Probleme treten also erst nach dem Aufsetzen von Pi-hole auf.
Vorher gab’s die langen Ladezeiten mit den Smartphones bei Dir nicht.

Wenn ich ein Pi-hole-Offizieller wäre, würde ich Dich jetzt bitten, ein Debug-Log zu erstellen und in den Tricorder hochzuladen. Leider können auch nur die darauf zugreifen :crying_cat_face:

Das geht über die Admin-Oberfläche unter Tools|Generate debug log.

Über das Log bekommt man einen ganz guten Einblick, wie Pi-hole auf dem RPi bei Dir konfiguriert ist und ein paar Hinweise, wo’s vielleicht hakt.

Du könntest den Inhalt des Logs aber auch kopieren und hier posten, womit Du allerdings ggf. ein paar Deiner internen Netzwerkeinstellungen öffentlich machst. Alternativ könntest Du versuchen, mir das Log per PM zuzuschicken, oder auf das Einschalten eines Moderators warten.

Ggf. siehst Du aber auch selbst schon offensichtliche Fehler/Schwierigkeiten in dem Log. Auf manche wird im Log explizit hingewiesen.

Alternativ können wir versuchen, Dein grundlegendes Setup mal abzuklopfen.
Wie hast Du Pi-hole denn eingerichtet:
Nur als DNS-Server oder als DHCP- und DNS-Server?

Hey. Wie Check ich denn das?

Und dann lesen - ab und an sind da Häkchen für ok oder x für irgendwas falsch.

Edit: Oder meinst Du DNS vs DHCP ?
Das siehst Du direkt unter Settings|DHCP - wenn der Haken gesetzt ist, arbeitet Pi-hole auch als DHCP-Server.

DHCP Server ist nicht enabled

Gut, dann ist Pi-hole nur als DNS-Server bei Dir im Einsatz.

Hast Du Pi-hole in der Fritzbox als lokalen DNS-Server oder als Upstream-DNS-Server eingestellt?

er sollte als lokaler dns server eingestellt sein.

einmal unter Internet/Zugangsdaten/DNS-Server

2xmal(bevorzugt und alternativ) die IP vom pihole bei ipv4 und ipv6

//

Heimnetz/Netzwerk/Netzwerkeinstellung:
Bei IPV4 Adressen als lokaler DNS
Bei IPV6 Adressen als lokaler DNS
dort noch weiter: ULA immer zuweisen + keinen ULA manuellen Präfix + DNSv6-Server auch über Router Advertisement bekanntgeben (RFC 5006) = die ipv6 des piholes
DHCPV6 aktiviert + Nur DNS - Server zuweisen aktiviert.

Dann hast Du Pi-hole als lokalen (Heimnetz|Netzwerk|Netzwerkeinstellungen|IPv4-Adressen| Lokaler DNS-Server) UND als Upstream-DNS-Server (Internet|Zugangsdaten|DNS-Server) Deiner Fritzbox eingestellt.

Das ist erst einmal nicht zu beanstanden, dadurch ist auch das Gastnetz der Fritzbox mit gefiltert. Du solltest dann aber in der Fritzbox Deinen Pi-hole beim Rebind-Schutz ausnehmen, wenn Du das noch nicht getan hast.

Den Upstream in der FB bräuchte es nicht zwingend, wenn Du nur Dein normales Heimnetz filtern willst. Ich verwende den bei mir auch nicht.

Meine Konfiguration sieht so aus (edit: bitte auch die schwarzen Dreiecke klicken):

Pi-hole als lokalen DNS-Server einer FritzBox (nur IPv4) einrichten

In meinem Setup lasse ich die Upstream-DNS-Server der Fritzbox unangetastet.
Diese finden sich unter Internet|Zugangsdaten|DNS-Server:

Die Fritzbox bleibt DHCP-Server, mein Heimnetzwerk wird über den Eintrag als lokaler DNS-Server durch Pi-hole gefiltert. Das macht man unter Heimnetz|Netzwerk|Netzwerkeinstellungen|IPv4-Adressen: Lokaler DNS-Server:

Für den Pi-hole ist kein DHCP aktiv, und ich habe im Admin-Panel unter Settings|DNS die Fritzbox als Upstream-DNS-Server eingetragen:

Zu beachten ist, dass das FritzBox-Gastnetz mit dieser Konfiguration nicht über Pi-hole gefiltert wird.


Wenn wie bei Dir der Provider IPv6 unterstützt und/oder Du lokal IPv6 verwendest, müssen wir das auch noch ergänzen.
Dazu machen wir folgendes:

Pi-hole eine stabile IPv6-Adresse zuteilen

Wenn eine Zwangstrennung durch den Provider erfolgt, erhält Deine Fritzbox eine neue IPv4-Adresse, aber ggf. auch einen neuen IPV6-Präfix. Anders als bei IPv4, ändern sich dadurch auch die IPv6-Adressen in Deinem lokalen Netz. Pi-hole sollte aber unter einer stabilen IPv6-Adresse erreichbar sein.
Hierzu geben wir über die Fritzbox unter Heimnetz|Netzwerk|Netzwerkeinstellungen|IPv6-Adressen eine feste ULA vor:
Variante-1-FB-IPv6-ULA
Anschliessend sorgen wir durch einen Reboot der Pi-hole-Maschine dafür, dass Pi-hole sich eine neue IPv6-Adresse mit diesem ULA besorgt.

An der Pi-hole-Kommandozeile lesen wir die IPv6-Adresse aus

pi@raspberrypi:~ $ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.28  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fd00::1234:5678:9abc:def0  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::9876:5432:10fe:dcba  prefixlen 64  scopeid 0x20<link>
        ether a1:b2:c3:d4:e5:f6  txqueuelen 1000  (Ethernet)

Es ist normal, dass es mehrere IPv6-Adressen für ein Interface geben kann.
Wir suchen die mit dem eben in der Fritzbox vergebenen Präfix fd00.
Diese müssen wir für Pi-hole konfigurieren:
Über sudo nano /etc/pihole/local.list ändern bzw. einfügen

192.168.178.28 pi.hole
fd00::1234:5678:9abc:def0 pi.hole

Eventuell stehen da auch noch andere Namen für die IP-Adressen Deines Pi; dort dann auch die IPv6-Adresse anpassen.

Dann mit sudo nano /etc/pihole/setupVars.conf ändern bzw. einfügen:

IPV6_ADDRESS=fd00::1234:5678:9abc:def0

Danach starten wir den Pi-hole-DNS-Server neu:
sudo pihole restartdns

In Pi-holes Admin-Oberfläche sollte jetzt unter Settings|System die fd00:-IPv6-Adresse zu sehen sein.


Pi-hole als lokalen DNS-Server einer FritzBox (IPv6) einrichten

Die neue IPv6-Adresse machen wir jetzt noch der Fritzbox bekannt, indem wir sie unter Heimnetz|Netzwerk|Netzwerkeinstellungen|IPv6-Adressen eintragen:

Sicherheitshalber erhöhen wir dort auch noch die Router-Präferenz für die Fritzbox:
Variante-1-FB-IPv6-pref


Ich würde vorschlagen:

  • kontrollier nochmal Deine IPv6-Adresse - es ist wichtig, dass hier durchgängig die Adresse mit dem stabilen ULA-Präfix verwendet wird.
  • versuch’s mit der Ausnahme im Rebind-Schutz (Deinen Pi-hole (und nur den, keine externen DNS-Server!) unter Heimnetz|Netzwerk|Netzwerkeinstellungen|DNS-Rebind-Schutz eintragen

Falls das nicht klappt, orientier Dich an meinem Setup.

Hi.
also hab in dem Rebind Ausnahmen Fenster jetzt die IPV4 und IPV6 des piholes untereinander eingegeben und gespeichert

kontrollier nochmal Deine IPv6-Adresse - es ist wichtig, dass hier durchgängig die Adresse mit dem stabilen ULA-Präfix verwendet wird.
Was genau meinst Du damit?
ULA ist aktiviert bei mir, aber hier ist kein Haken gesetzt:

Unique Local Address Ihrer FRITZ!Box: fd00::e228:ZENSIERT
ULA-Präfix manuell festlegen

Als Notiz: habe jetzt nur die 2 (4+6) ip beim Rebindschutz hinzugefügt.

EDIT: mit Blick auf die FB hat mein Raspi diese IPV6 Adressen: 2a00:6020:23f1:8000:3059:2d88:2357:XXXX
fe80::9d5a:167c:dd5d:XXX
fd00::b6a6:a285:b615:XXX
ipv4: 192.168.0.81

ABER in den pihole options steht:

|Pi-hole IPv4 address:|192.168.0.81/24
|Pi-hole IPv6 address: 2003:d5:2720:c00:67a2:6f71:fa1c:XXX

Sprich die IPV6 in der FB des raspis ist nicht die gleiche als im pihole Menu - ist das so korrekt?

Laut Fritzbox-Beschreibung sollten da Hostnamen drinstehen, keine IP-Adressen, also z.B pi.hole

Die von der Fritzbox an den Pi-hole zugewiesene ULA-IPv6-Adresse sollte wie von mir beschreiben durchgängig sowohl in den Konfig-Dateien im Pi-hole als auch in der Fritzbox eingestellt sein.

Wichtig ist vor allem, dass genau die fett markierte fd00:-Adresse als lokaler IPv6-DNS-Server in der FB eingetragen ist.
Wie Du dafür sorgst, dass das auch im Pi-hole Admin-Panel korrekt angezeigt wird, habe ich weiter
oben unter Pi-hole eine stabile IPv6-Adresse zuteilen ausführlich beschrieben.

Thema Rebind:
Tragen Sie dazu den vollständigen Hostnamen (Domainname inklusive Subdomain) in die Liste ein.
Wo finde ich den passenden Hostnamen, den ICH da eintragen muss?

Habe aktuell ipv4 + 6 aus den pihole options - will jetzt nichts beschwören, aber iwie scheinnt es gerade “gut zu laufen”

Thema ULA Präfix:
Sorry, verstehe ich nicht, kannst Du mir explizit sagen, was ich da eintragen soll?

Schonmal vielen Dank soweit, hab hier durch Dich echt wieder Hoffnung!

Dein ULA-Präfix ist ok - das zeigt die fette Zeile:

In der Fritzbox muss genau diese fette fd00::b6a6:a285:b615:XXX-Adresse als lokaler IPv6-DNS-Server gesetzt sein.
Wenn die auch im Pi-hole in der Admin-Oberfläche korrekt angezeigt werden soll, musst Du die oben beschriebenen zwei Dateien auf dem Pi-hole anpassen.

Frage: Hast Du in meinem Post oben schon mal auf die scharzen Pfeile vor den Abnschnittsüberschriften geklickt?

Hi. Nein die Pfeile habe ich tatsächlich erst eben bemerkt. Danke.

Ich kümmer mich umgehend im Diensteide sowie die ULA Geschichte morgen früh.

Muss früh raus und somit hau ich nicht jetzt hin.
Dir schon mal 1000 dank und hoffentlich bis morgen.
Gn8 kimi

Danke für’s Abmelden, auch gute Nacht :wink:

Ich werde morgen wahrscheinlich nicht so richtig viel Zeit haben, schaue aber in den nächsten Tagen definitiv nochmal hier bei Dir vorbei.

Ich glaube aber, Du bist schon auf einem ganz guten Weg zu einem funktionierenden Setup.