Whitelist and black list Failure

Please follow the below template, it will help us to help you!

Please ensure that you are running the latest version of the beta code.
Run pihole -up to update to the latest, then verify that the problem still exists before reporting it.

Problem with Beta 5.0:

whitelist and black list Failure ?
Help needed,

Thanks for this amazing software.

Debug Token:
https://tricorder.pi-hole.net/grhhjnbomy

1 Like

It seems to be the same problem I had here. It occured after switching branches, in my case from new/CNAME_inspection_details back to release/v5.0. The only solution for me so far is to stay on branch new/CNAME_inspection_details for web and ftl.

@murtyolcay Please try force-refreshing your browser’s cache (typically achieved by [Ctrl]+[F5]).

Thank you for quick response,
I did force- refresh and clear the cache and also i have tried other browser with thw same result.

You can try this solution.

Just check if the package php-intl is missing and install it if not.

Ok Thanks for that, now it seems it is working.

Hi, I have got the same problem - I did everything like adviced… php-intl is installed - still does not work -need some help - great software anyway :slight_smile:

My token: 368zlc6rsr

It this really the exact same problem? Sorry, I haven’t seen your post early enough and your debug token expired meanwhile. Could you please do another pihole -d run for us?

It looks like the same problem - the new token is: 4l64qtvpo5

Also in my case the Whitelist and black list Failure is still there.
Debug token: n8tx4smti5

@tjamaa @1xox Please check you followed

@DL6er, Thanks for all the support! When running “apt-get install php-intl” the php7.4 version was installed, while the extension_dir in http://pi.hole/phpinfo.php points to the 7.3 version where indeed the intl.so file is missing. I don’t know how to get the 7.3 version installed. (Sorry, trying to find my way in the linux world…)

php-intl is installed.php-intl

@1xox Same here!

Does the config update when you restart lighttpd?

Is everyone seeing this new issue running DietPi?

@DanSchaper Restart of lighttpd has no effect

Can we check if a particular PHP extension is available and only offer the IDN feature to those having a correctly configured OS that installs the right extensions?.. DietPi seems to be missing this correct configuration right now.

edit Yes: https://www.php.net/manual/en/function.extension-loaded.php

1 Like

Is this DietPi? I’m seeing some problems with the lighttpd configuration not using our configs.

*** [ DIAGNOSING ]: Dashboard and block page
[✗] Block page X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 403 Forbidden
Content-Type: text/html
Content-Length: 345
Date: Sun, 16 Feb 2020 11:40:42 GMT
Server: lighttpd/1.4.45


[✗] Web interface X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Set-Cookie: PHPSESSID=pju1smqqhmqk7ort69iel0kiu2; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-type: text/html; charset=UTF-8
Date: Sun, 16 Feb 2020 11:40:44 GMT
Server: lighttpd/1.4.45

Is there a package php7.3-intl available for you?