Pihole Whitelist and Blacklist Empty After Update

Problem with Beta 5.0:

After updating to Beta 5.0 the Whitelist and Blacklist are both empty. Not sure if it's connected but the Groups Link also throws an error

whitelist
blacklist
no-group

Debug Token:

https://tricorder.pi-hole.net/sdvyhfhbot

The PiHole is still blocking things from my old list, but it is also blocking things I was not blocking before. I tried looking at other threads and tried some suggestions in this thread

(Whitelist and black list Failure)

[ pihole checkout web fix/check_idn]

and got this message back

intl

This branch no longer exists. It was merged into the beta 5.0.

Ok how do I go about fixing this, I currently can't whitelist anything that's being blocked, for some reason it's now blocking all of Netflix and Youtube, and both of these were working this afternoon.

pihole checkout web release/v5.0

pi@raspberrypi : ~ $ pihole checkout web release/v5.0

Please note that changing branches severely alters your Pi-hole subsystems

Features that work on the master branch, may not on a development branch

This feature is NOT supported unless a Pi-hole developer explicitly asks!

Have you read and understood this? [y/N] y

[✓] Fetching branches from https://github.com/pi-hole/AdminLTE.git

[i] 20 branches available for Web Admin

[✓] Switching to branch: 'release/v5.0' from 'refs/heads/release/v5.0'

Already up to date.

Looks good. May want to pihole -up to catch the latest beta fixes.

Now, for the cause of the issue:

[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
[80] is in use by apache2 (https://discourse.pi-hole.net/t/hardware-software-requirements/273#ports)
*** [ DIAGNOSING ]: Dashboard and block page
[✗] Block page X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Thu, 30 Apr 2020 00:21:52 GMT
Server: Apache/2.4.38 (Raspbian)
Last-Modified: Fri, 20 Mar 2020 22:21:42 GMT
ETag: "29cd-5a150b5c51006"
Accept-Ranges: bytes
Content-Length: 10701
Vary: Accept-Encoding
Content-Type: text/html


[✗] Web interface X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Thu, 30 Apr 2020 00:21:52 GMT
Server: Apache/2.4.38 (Raspbian)
Set-Cookie: PHPSESSID=vr2akrm0dj2rnq5tn0rnf6lql0; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Type: text/html; charset=UTF-8
1 Like

And is this right? You have over 1600 manual domain wildcard and regex entries??

   1686     3        1  0             (^|\.)airfind\.com$                                                                                   2020-04-29 23:58:07  2020-04-29 23:58:07  Migrated from /etc/pihole/regex.list 

The 1600 number could be correct, most of the domains I block like this use a randomly generated subdomain prefix to get around various ad blocking methods, by using this regex format I can preemptively block any new variations they try.

I'm guessing this

Blockquote[80] is in use by apache2 (Hardware/Software Requirements)

Is another webserver that's conflicting, it's probably from something I was trying to do add functionality to my VPN that I wasn't able to get running. I'm unsure how to remove it, a nudge in the right direction would be appreciated.

I was able to fix this by removing the Apache Web server

sudo apt-get purge apache2

and then

pihole checkout core release/v5.0

pihole checkout web release/v5.0

After you made these changes, is your problem resolved? All the black and whitelists have reappeared?

A post was split to a new topic: Looking for RegEx