Database Error after update

Please ensure that you are running the latest version of the beta code.

  Current Pi-hole version is v4.3.2-393-g37a44c0
  Current AdminLTE version is v4.3.2-384-g2860ce3
  Current FTL version is vDev-3639b33

Problem with Beta 5.0:
This morning I switched Pihole Beta 5.0 back from branche CNAME_details to release v5.0 to have the new merged version. Since then I’m unable to open white- and blacklist and domains in the group management due to a databse (ajax) error. See scrshots pse:



Debug Token:
0eiozll9ir

Edit: Temp solved by switching back to new/CNAME_inspection_details but it’s strange anyway.
pihole -v is now

Pi-hole version is v4.3.2-393-g37a44c0 (Latest: v4.3.2)
AdminLTE version is v4.3.2-384-g249dfc7 (Latest: v4.3.2)
FTL version is vDev-d648572 (Latest: v4.3.1)

Please go back to release/v5.0 and clear the cache of your browser. Alternatively, do a force refresh (Ctrl + F5) on the page before trying to edit anything.

Unfortunally no chance. Gone back to release/v5.0 explicitly for core, web an ftl, done pihole -up then and pihole -g too, cleared cache in FF and IE before(!) visiting the admin interface… The results are the same with both browsers.

After gone back to new/CNAME_inspection_details for web and ftl again it’s already working . :slight_smile:
Destiny.

Really strange, could you try updating again (we’ve changed other stuff, nothing related, but who knowns…)? If it is still not working, could you please check your /var/log/lighttpd/error.log for the related SQL error?

Now I have a problem: The CNAME-branche is gone. :grinning:
At backswitching to release/v5.0 i noticed some updates for the web, but the error keeps as it was. I’ve enabled error logging for lighthttpd and got this with a single click at Blacklist (hope this essence i enough - too much lines for here):

2020-02-10 09:46:06: (gw_backend.c.2440) handling it in mod_gw
2020-02-10 09:46:06: (mod_fastcgi.c.421) FastCGI-stderr: PHP message: PHP Fatal error: Uncaught Error: Call to undefined function idn_to_utf8() in /var/www/html/admin/scripts/pi-hole/php/get.php:33
2020-02-10 09:46:06: (mod_fastcgi.c.421) FastCGI-stderr: Stack trace:
2020-02-10 09:46:06: (mod_fastcgi.c.421) FastCGI-stderr: #0 /var/www/html/admin/scripts/pi-hole/php/get.php(71): getTableContent(1)
2020-02-10 09:46:06: (mod_fastcgi.c.421) FastCGI-stderr: #1 {main}
2020-02-10 09:46:06: (mod_fastcgi.c.421) FastCGI-stderr: thrown in /var/www/html/admin/scripts/pi-hole/php/get.php on line 33

The the click at Domains in Group Management which produces the third scrshot above results in an output this way (also redeuced to the lines that seems to tell about the problem):

2020-02-10 09:55:14: (gw_backend.c.2440) handling it in mod_gw
2020-02-10 09:55:14: (mod_fastcgi.c.421) FastCGI-stderr: PHP message: PHP Fatal error: Uncaught Error: Call to undefined function idn_to_utf8() in /var/www/html/admin/scripts/pi-hole/php/groups.php:349
2020-02-10 09:55:14: (mod_fastcgi.c.421) FastCGI-stderr: Stack trace:
2020-02-10 09:55:14: (mod_fastcgi.c.421) FastCGI-stderr: #0 {main}
2020-02-10 09:55:14: (mod_fastcgi.c.421) FastCGI-stderr: thrown in /var/www/html/admin/scripts/pi-hole/php/groups.php on line 349

The Whitelist-click:

2020-02-10 10:10:21: (gw_backend.c.2440) handling it in mod_gw
2020-02-10 10:10:21: (mod_fastcgi.c.421) FastCGI-stderr: PHP message: PHP Fatal error: Uncaught Error: Call to undefined function idn_to_utf8() in /var/www/html/admin/scripts/pi-hole/php/get.php:33
2020-02-10 10:10:21: (mod_fastcgi.c.421) FastCGI-stderr: Stack trace:
2020-02-10 10:10:21: (mod_fastcgi.c.421) FastCGI-stderr: #0 /var/www/html/admin/scripts/pi-hole/php/get.php(65): getTableContent(0)
2020-02-10 10:10:21: (mod_fastcgi.c.421) FastCGI-stderr: #1 {main}
2020-02-10 10:10:21: (mod_fastcgi.c.421) FastCGI-stderr: thrown in /var/www/html/admin/scripts/pi-hole/php/get.php on line 33

I hope this will help.

Oh yes, this is a new requirement added by

Did you also check out the current release/v5.0 branch for Pi-hole core (pihole checkout core release/v5.0)?

The error should be fixed when installing php-intl which should have been automatically installed by the beta branch due to

1 Like

Yes, core was still running from release/v5.0. Now I’ve installed php-intl via apt-get - it was not on the system - and that was the solution! Thanks for the help!

1 Like

Just checked and on my Debian, php-intl wasn’t installed automatically by switching to the beta branch. But I have php7.3-intl installed. Is the latter sufficient?

If you don’t see such errors like above it probably doesn’t matter. When I installed php-intl on the RPi4B with Dietpi Buster 6.28.0, the php7.3-intl was automatically installed too. I thought this is because of dependencies and so I let it run.

same here i had to install php-intl

1 Like

The install process tries to install the php7-intl or php5-intl package. Looks like it needs the php-intl base as well. Better option is to use php-intl instead of the versioned one as the base will pull in the proper dependencies.