Rate limit due to openthread queries

Situation:

Ever since my apple devices updated to iOS 15 and macOS 12, I have seen a spike in network traffic. Did my research here and on other forums and could relate the openthread.thread.home.arpa traffic to my Apple TV that is broadcasting thread requests. This seems to be normal behaviour and has been confirmed here.

I do notice some behaviour that is unexpected. Whenever there is a spike in query's, my router seems to get a rate limit:

Client 192.168.1.1 has been rate-limited (current config allows up to 1000 queries in 60 seconds)

Every time this happens, pi-hole seems to be not functioning for a while and I see a dip in queries. This also seems to mean that ads are not blocked, and my blacklist (which I use to help me focus on my work) is not working.

Is there something I can do in this case?

Debug Token:

https://tricorder.pi-hole.net/GfpAPxr1/

Getting more warnings now too:

Blockquote Warning in dnsmasq core:
Maximum number of concurrent DNS queries reached (max: 150)

As I am a newbie I will read documentation too as suggested

I'm seeing this as well, although it hasn't got to the point of hitting any rate limiting level.

I created a CNAME record this morning that points to the device it's looking for. It's too early for me to tell if that helped the problem but I will report back when I get enough data.

Thanks for your reply @sawsanders, happy to read that I am not the only one!

As of now I have had 288650 thread query's originating from one source.

Do you have a source where I can read more about how CNAME records work in pi-hole?

I can't find anything in the online documentation but there is a description on the pi-hole's settings page here: http://pi.hole/admin/cname_records.php

@robbertnoordhoek
So just to follow up, it looks like creating a CNAME pointer to the actual device stopped the openthread requests. However, now the target local domain is being requested twice as often.

Not sure if it really helped.

i too have this issue, i believe its the thread network trying to communicate with other thread devices i.e homepod to eve lswitch. PiHole looks to be blocking this and i cant work out how to allow it.

As far as I know I only have one thread device, the Apple TV, so I don't know how to point all these requests to the right location. I do feel a bit clueless because my pi-hole keeps going from a working state to a non-working state; when my pi-hole limits my router, internet traffic seems to bypass the pi-hole because my router will pick the next DNS server in line as it is supposed to. Again I am not as techsavy as other people here so this is just an assumption.

Any admins here have a clue what to do?