Only 2 Clients Appear on the Admin Console

Please follow the below template, it will help us to help you!

Expected Behaviour:

I expect to see 10+ clients on the admin console when I log in to it.

Actual Behaviour:

Only two clients appear, localhost and one other IP. DNS is configured correctly and those devices have all their ads blocked. Pi-Hole is running on Ubuntu 16.04 that acts as my router and DHCP server.

Debug Token:


How are you configuring your devices to use Pi-hole?

I have isc-dhcp-server running on the router. All the clients have static IP addresses assigned by the router with the correct DNS IP address. I have also run pihole -r and done the full reinstall.

When I run tail -f /var/log/pihole.log I can see all of my devices querying the DNS server.

Perhaps your devices need to renew their leases before the pick up the new settings. This would explain why some devices show but others do not...

I have actually tried that too. I have added new devices checked the DNS settings for each device and can confirm they are all pointing to the correct IP address. I did just notice the 2 that do appear are not updating and the query log on the interface does not show any data.

What if you manually configure your devices to use Pi-hole as their DNS server?

I have tried that and used a VPN with Pi-hole as the DNS. I didn't notice it before but none of the statisitcs have changed at all. It continues to say 1.7% Perfcent Blocked and hasn't changed at all. It seems to be this way with all of the statistics.

I would take the VPN out of the equation for now if you can and just manually configure your devices and then tail the log to see if it's working or not.

I manually configured my laptop to use pihole and can see that IP along with all my other devices when I run tail -f /var/log/pihole.log.

So Pi-hole is working, you just don't see all the clients on your dashboard? Can you post a screenshot?

Here are some screenshots of the dashboard and query pages. I also included a tail -f /var/log/pihole.log showing several other clients.

Hello, I am having the same problem with the pi-hole stats and dashboard only showing 1 client and 2 queries?
System : Rasp Pi 3 running Stretch latest updates applied
I reinstalled pi-hole which sorted the problem but it returned.
Now I have done a pi-hole repair and debug TOKEN : 8moqx22v0n

Did you notice this behavior after updating? Have you flushed your cache?

There were some errors in @daw9000's log but nothing of consequence. Can you both clear your cache and let me know if it works?

I have flushed my cache by restarting dns service but it is still the same. One thing I have noticed is if I reboot my pi then the stats are ok for a little while (minutes possibly less) .

also I have flushed my browser cache, temporary internet files, cookies etc etc

This is more what I was referring to. Does the interface report correctly in a different browser?

I have found the cause of my problem, my system starts a python script to display stats on an oled screen - taken from LadaAda.. when I prevent this from running my stats are OK and everything works. Before the raspbian updates this worked fine but there must be an issue somewhere now..

1 Like

@FredsFred what about you?

Sorry too quick for my own good, the problem has recurred so the python script does not seem to be the culprit. Everything was working OK while I had the pi-hole dashboard running in my browser. I closed the browser down went for a coffee, started browser and dashboard again and lo and behold same problem!!
What I have noticed is that it is always the same top domain.
Hostname: pi3 (Raspberry Pi 3, Model B)
Uptime: 00:43:33 (UV, TT)
Task Load: 0.65 1.21 1.16 (Active: 8 of 92 tasks)
CPU usage: 13% (4x 1.2 GHz @ 318k)
RAM usage: 38% (Used: 355 MB of 927 MB)
HDD usage: 13% (Used: 7 GB of 58 GB)
LAN addr: (Gateway:
Pi-hole: Active (Blocking: 121693 sites)
Ads Today: 0% (Total: 0 of 2)
Local Qrys: 100% (4 DNS servers)
Top Advert:
Top Domain:
Top Client: localhost

I think it is the NTP service that is somehow causing this problem, maybe you can see @FredsFred if it is the same for you?

here is my syslog - looks like NTP is run then some cleanups on pi-hole. Does this look OK?

2018 (1): Starting
Mar 23 13:25:18 pi3 ntpd[18707]: Command line: ntpd -q
Mar 23 13:25:18 pi3 ntpd[18707]: must be run as root, not uid 1000
Mar 23 13:26:17 pi3 systemd[1]: Starting Cleanup of Temporary Directories...
Mar 23 13:26:17 pi3 systemd[1]: Started Cleanup of Temporary Directories.
Mar 23 13:30:01 pi3 CRON[31719]: (root) CMD ( PATH="$PATH:/usr/local/bin/" pihole updatechecker local)
Mar 23 13:39:01 pi3 CRON[25008]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
Mar 23 13:39:17 pi3 systemd[1]: Starting Clean php session files...
Mar 23 13:39:17 pi3 systemd[1]: Started Clean php session files.
Mar 23 13:40:01 pi3 CRON[28052]: (root) CMD ( PATH="$PATH:/usr/local/bin/" pihole updatechecker local)
Mar 23 13:50:01 pi3 CRON[26204]: (root) CMD ( PATH="$PATH:/usr/local/bin/" pihole updatechecker local)
Mar 23 14:00:01 pi3 CRON[23872]: (root) CMD ( PATH="$PATH:/usr/local/bin/" pihole updatechecker local)

I cleaned out the cache on pihole and on my devices and have no change. I set this router up in November and installed pihole then and the admin console worked. I only got around to installing at the beginning of March and I ran an update then.

I took a look at my syslog running grep ntp /var/log/syslog and could not see anything related to NTP in the log.