Only 2 Clients Appear on the Admin Console

I don't think it has anything to do with NTP. Here's what we know:

  1. Pi-hole is working for all clients
  2. pihole -t shows activity from all clients
  3. The Web interface only shows two clients

So Pi-hole is working, but the issue seems to be with the Web interface, so I still feel like it's cache. Do you have a different device to try to access the interface from?

I have tried multiple browsers on different machines and it is the same for all. A reboot of the system and everything works fine, then something triggers the web interface to fail. PiHole keeps working but web interface shows 2 clients and 0 ads blocked.
So logically I think some CRON or other scheduled job is causing this. I will see if I can shed anymore light on monday

I too have tried it from multiple devices with the same effect,

@daw9000 and @FredsFred please run pihole -d for a new debug token.

Here isy new debug token



I'm stumped. I can't determine why only two clients would show up. Which two devices are they?

I have reconfigured my rtc and hwclock (removed fake-hwclock) after doing some research on how to install rtc on pi. After doing this I now get no initial grace period on bootup where everything shows correctly, stranger still I only get 1 client (localhost) and 2 queries on debian timeservers.
I also uninstalled pi-hole and reinstalled with no joy. Very odd..

So localhost is one of the clients and you don't have any other?

My localhost and one of my phones. It may be worth mentioning I am running UniFi controller on there as well.

I would say I have at least 10 devices using it has a DNS server but the queries seem to be from when I originally set up the router and since the upgrade nothing is updating on the interface.

Did you clear cache on the device you are accessing the Web interface from?

I have tried that and tried accessing it from every different device I have that has a web interface. I've cleaned the cache on the pihole and the devices trying to access the interface. The admin console still shows the same statistics 1.7% Blocked, 2018 Total queries etc. on all devices that have tried to access the console. The only thing that seems to be updating is the CPU and Memory indicator.

I don't know. You can try the nuclear option (this will wipe out any customizations you have in the Web interface); it fixed an similar issue for someone else.

I'm not a huge fan of it, but it may get you up and running since we don't really know what the problem is.

sudo rm -rf /var/www/html/admin
sudo git clone /var/www/html/admin

Just ran through that with no change either.

The only thing I can think of that would be messing with it is UniFI controller or the update I ran in March but I figured a repair would fix that.

@FredsFred I solved this for my system by doing a clean reinstall. I uninstalled pi-hole removed dnsmasq and lighttpd. I then went through deleting all folders and files related to pi-hole , php, dnsmasq and lighttpd including logs (important as just purging did not work for me). Then reinstall pi-hole. I appreciate this may not be practical for you as other systems may rely on these dependencies.
Hopefully you will find a good solution.
In my case my best guess is that I had a bad timestamp from badly configured hwclock or corrupted file after log was flushed. These being the only two items of interest on debug logs I found.

1 Like

@FredsFred are you in a position to try the same solution?

That worked! After completely cleaning everything out the admin interface is now updating correctly!

Thanks for the help guys!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.