Issues with British Telecom Smart Hub 2

Hello folks, yesterday I installed pi hole in a raspberry pi Zero W and everything worked perfectly when I was using manual IP address but got several issues when using DHCP.

In the end there are some configurations that needs to be performed on the SmartHub 2 from BT for the Pi Hole to work properly, however I believe this can be useful on several other routers too.

1 - Deactivate the DHCP Server on BT Smart Hub 2
BT Smart Hub does not accept you changing the DNS servers hence you have to manually deactivate the DHCP on the router.
In order to do that, open the web page for the configuration of your router (usually and click on Advanced Settings and My Network (the password the hub is going to ask is written on behind it).
Then you click on IPv4 configuration and deactivate the DHCP Server (remember to click on save on top of the screen). I believe I rebooted the router after doing this as well.

2 - Activate the DHCP on Pi-hole
I think this tutorial will explain everything

From this moment onwards in theory everything should be working, but in my case I had a problem which was the primary DNS was pointing to a IPV6 address which was not pi-hole and the add blocking was not working. (I'm not a network expert and by the time I took CCNA training the IPv6 was just in the books).

I made sure that the setting Enable IPv6 support (SLAAC + RA) was turned off during the Pi-hole DHCP setup and released the IP and renewed again as well as testing on mobile phones.
The primary DNS was a IPV6 address.

Deactivate the IPV6 DHCP on Smart Hub 2
To be really honest I'm not comfortable with IPv6 since there is 15 years I stopped working with network but after googling a bit I found something called IPv6 address allocation mode.
There are several modes and the default one on BT Hubs is stateless which means IPv6 addresses would be provided to everyone on automated basis.
I changed the setting to OFF and the issue was solved.
In order to do the change go to Advanced Settings -> IPv6 -> Configuration and turn IPv6 address allocation to Off and reboot the router again.

After this procedure I released and renewed my DHCP address by going into a command prompt and typing:
ipconfig /release
ipconfig /renew

Finally you can type ipconfig /all and see that there is only one DNS Server and your internal network devices don't have IPV6 anymore. So everything started working perfectly.

Please contribute if there are any downsides for this suggestion as for me, was the only way to make the Pi-Hole work together with the Smart Hub 2 provided by British Telecom.

Cheers and have a great day.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.