FTL Offline - Lost Connection to API

Expected Behaviour:

Pihole running and blocking ads

Actual Behaviour:

Pihole is not blocking ads, upon investigation to the web UI I see the message the FTL is offline and Lost Connection to API. This happens intermittently and appears to self heal every now and then but lately is more broken than working.

Debug Token:



[✓] Your debug token is: https://tricorder.pi-hole.net/pz9n5mt9hj



Welcome to the Pi-hole community, allantaylor8907. :slight_smile:

In addition to your pihole-FTL currently not being active, there are two major issues apparent from your debug log.

server=127.0.0.1

a) You’ve configured localhost (127.0.0.1) as one of Pi-hole’s upstream DNS servers.
This may result in a DNS loop, as your Pi-hole would query itself infinitely when chosen.
In fact, I suspect this to have already happened, as your log shows an enormous 1.1 million DNS queries from just two clients during the last 24 hours.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the br0 interface.
[✗] No IPv6 address(es) found on the br0 interface.
(...)
[✗] Gateway did not respond.

b) Your Pi-hole does not integrate properly into your network.

You could try to address both problems by running the following command from a terminal on your Pi-hole machine:

pihole -r

Choose reconfigure and pick valid upstream DNS servers when asked.

Hi! Thanks for the quick reply. The change to the upstream address being 127.0.0.1 was recent, as the docker file I am using specified that, I have reverted the change.

Regarding being unavailable on the network.
Pihole is running in a container and has its own IP exposed. I can access the UI and CLI to Pihole directly on its IP from any computer on the network. Can you clarify what may need to be done here?

new token after changing the DNS address :slight_smile:



[✓] Your debug token is: https://tricorder.pi-hole.net/0eh37a9x0t



I have tried reinstalling and reconfiguring with no success.
A few confusing points.
I am configuring based on: https://hub.docker.com/r/pihole/pihole/
Specifically:

Starting with the v4.1.1 release your Pi-hole container may encounter issues starting the DNS service unless ran with the following setting:

--dns=127.0.0.1 --dns=1.1.1.1 The second server can be any DNS IP of your choosing, but the first dns must be 127.0.0.1

But it was mentioned that localhost should not be one of the DNS servers so I am not sure what to do.

I am using bridged mode and giving pihole it own IP. I can reach the IP on the network and the router gives it out fine. I see requests hitting pihole for a few minutes before it completely falls over so I think the networking error is a false flag:

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the br0 interface.

[✗] No IPv6 address(es) found on the br0 interface.

[i] Default IPv4 gateway: 192.168.55.1
   * Pinging 192.168.55.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)


[✓] Your debug token is: https://tricorder.pi-hole.net/5718lra6zk



Sorry for the misunderstanding.
Your original post didn’t mention you are running a dockered Pi-hole.

You should not reconfigure a Pi-hole docker image, ever - it is intended ready for use.

That does not invalidate my earlier advice on not using 127.0.0.1 as Pi-hole’s upstream DNS server, as this would create a DNS loop. Your current debug log shows you are still closing that loop.

Pi-hole’s upstream DNS servers can be customised by setting Docker environment variables for Pi-hole, DNS1: <IP address 1> and DNS2: <IP address 2>.

Alternatively, you can change upstream DNS servers via Pi-hole’s Settings | DNS pane as well.
Note those changes will only survive Docker container restarts if /etc/dndsmaq.d/ has been exported as volume (which it should be by default with the official image).

In contrast, the --dns Docker option you are referring to does configure DNS resolution for your Docker container, and should be set as described.

No worries! thats my fault for leaving out important information.

I think I closed the loop and was confused and overanalyzed after reading the readme.md for the container.

Can you confirm if I closed that loop please?



[✓] Your debug token is: https://tricorder.pi-hole.net/yupxgf6s0n



No, the contrary - but that’s what you want, as you certainly don’t want a DNS loop :wink:

You are now using the following four upstream DNS servers:

    PIHOLE_DNS_1=1.1.1.1
    PIHOLE_DNS_2=1.0.0.1
    PIHOLE_DNS_3=1.1.1.1#53
    PIHOLE_DNS_4=1.0.0.1#53

127.0.0.1 has vanished, so that’s all good.
DNS 3 and 4 are redundant, as they are identical to 1 and 2, and could be
considered for removal.

Thanks

:sweat_smile: on closing the loop

Just wanted to circle back. I am seeing the same behavior with FTL Offline again.



[✓] Your debug token is: https://tricorder.pi-hole.net/ezzlcad9q4


Your Pi-hole assumes it is residing at

IPV4_ADDRESS=192.168.55.169

Yet there are no IP addresses bound to its network interface, and thus no connectivity:

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the br0 interface.
[✗] No IPv6 address(es) found on the br0 interface.
(...)
[i] Default IPv4 gateway: 192.168.55.1
[✗] Gateway did not respond.

It would seem that Pi-hole did not receive an IP address while starting.

Since an IP address wouldn’t simply vanish:
Did you restart your Pi-hole Docker container and/or the Docker host OS ?