FritzBox 7580 und piHole

Hallo, hab von PiHole gelesen und da ich noch ein raspi über hatte habe ich mir das mal installiert (hat auch alles easy geklappt). Dann hab ich in der FritzBox 7580 unter Internet/ Zugangsdaten/ DNS Server die ip vom Raspi bei Bevorzugter und bei Altanativ 8.8.8.8 eingegeben. Aber nun lassen sich kaum noch seiten öffnen wenn ich sie über google aufrufen möchte. zb hab ich nach einen Artikel gesucht bei google und der war dann bei notebooksbilliger.de oder zb telekom. hab ich irgendwas falsch eingestellt oder muss ich was ändern?

guck mal in der pi-Hole Admin Console unter Query Log ob die Seite geblockt wird wenn ja klick auf Whitelist

ja kann die seite bzw die seiten dann frei geben ja, aber das sind ja normale seiten wie viele seiten soll man denn dann freigeben wenn schon telekom und notebookbilliger nicht geht

Geht Notebooksbilliger auch nicht bei direktem Aufruf?
Wenn du bei Google danach suchst, erscheint als erster Link eine Anzeige.
Die werden standardmäßig von PiHole geblockt.
Wenn du das zulassen willst, reicht in der Regel www.googleadservices.com auf die Whitelist zu setzen.
Dann lässt Pihole alle direkten Anzeigen auf der Google-Seite durch.
Wo noch Probleme auftreten ist Spiegel-Online und Heise, fallst du dort unterwegs bist.
spiegel-de.spiegel.de und prophet.heise.de auf die WL und auch das geht wieder.
Gruß
Alex

Ja habe ich schon gemacht. Nu hab ich ein neues Problem, ich habe nichts verändert im System und bin gerade nach Hause gekommen und er blockt irgendwie gar nichts mehr. Habe mal den kompletten log gelöscht aber wenn ich neue Seiten im Internet aufrufe blockt er nix

Hat der PiHole-Rechner noch die gleiche IP-Adresse?
Schau mal hier, wie man eine FritzBox optimal einstellt:

Ich gebe dem PiHole-Rechner immer eine feste IP indem ich das DHCP auf dem Rechner ausschalte.
Dann auf dem Rechner eine IP kleiner 192…20 festlegen, die Box verteilt nämlich standardmäßig Adressen erst ab …20. Anschließend die Einstellungen aus der Anleitung vornehmen. So habe ich sichergestellt, das PiHole immer die gleiche Adresse hat.

Hier noch eine andere Anleitung, in der nochmal erklärt wird, wie du die ULA ausliest:

hatte ich alles gemacht, ich setzte das system nochmal neu auf und dann mal gucken

Auf welcher Basis bist Du denn unterwegs? Das aktuelle Debian Buster wird z.B. noch nicht unterstützt soweit ich weiß. Das aktuelle Raspbian-Buster somit auch nicht, falls du mit einem Raspberry arbeitest. Eventuell hilft ein älteres Linux-System?

achso ja gut zu wissen hatte das buster aber es lief am anfang alles

Da gibts wohl noch Probleme:


Hier gibt es die alten Raspbians:
http://downloads.raspberrypi.org/raspbian/images/raspbian-2019-04-09/

na klasse, auf mein smarthome system habe ich auch buster installiert. weiß jemand ob ich später einfach wieder ein update machen kann oder muss ich mein auf mein raspi “smarthome” auch alles neu aufsetzten? gehört hier zwar nicht hin aber nur mal so ne frage?

Also pihole läuft auch mit Buster, da ga es ein Patch.
Falls dieser noch nicht im Installations Script eingearbeitet ist, einfach nach der Installation ein Update von Pihole machen.

ein update von raspbian ist derzeit nicht möglich wenn du das meinst.
falls du sudo apt-get update meinst

Ich meine das Pihole mit Buster jetzt läuft weil es ein Patch von Pihole gibt. 4.3.1

und wie updatet man pihole?

Pihole -up

also sudo apt-get Pihole -up

sorry bin nicht so vertraut damit

Also ich bin mit ssh auf die Raspberry Console gegangen und hab dann Pihole -up eingegeben, dann wurde das Update gemacht.

okay probier ich gleich mal danke