DHCP Server Trouble


#1

I am running PiHole on Ubuntu 16.04 through Ethernet to a Verizon FiOS router (G1100).

I started off and tried to apply the DNS rules to the router via: How do I configure my devices to use Pi-hole as their DNS server?

For me method 1 and method 2 both failed with this router. I am not entirely sure why, but in both cases did not block any content that was booted up on the clients.

Today I tried to set it up as the DHCP Server, disabled the DHCP server on my router, and then proceeded to attempt to connect a client with absolutely no luck. How do I use Pi-hole's built in DHCP server (and why would I want to)?

Looking for suggestions as to what the next step would be here? I am new to all of this, so please forgive any newb tendencies.


#2

Please send us the token generated by

pihole -d

or do it through the Web interface:


#3

Token is: i3rnlenmh3


#4

From your debug log, there is nothing wrong with your Pi-Hole installation. It is resolving DNS queries as it should.

The problem likely lies in your router or client configuration.

After you assigned the Pi-Hole as DNS on the router, did the router restart or did you restart it? Did you flush the DNS caches on the clients and renew their leases (this is required to get the clients the new DNS server location).


#5

After implementing it into the router, I was able to restart the router. Upon doing so, I was unable to connect from any client on my network at that point. I restarted the devices in an attempt as well to solve that, but had no luck there.

Is there something else I should try?


#6

Restarting devices doesn’t always clear the DNS cache. What clients are you running on the network (operating system, device type, etc.). Clearing the DNS cache is different on each type of device.


#7

There’s about 25 different devices that range from computers, phones, tablets, and then smart devices as well…


#8

OK. I assume some of the computers are Windows?

In the command terminal in windows (run in the start menu), you would run the following commands:

ipconfig /release
ipconfig /flushdns
ipconfig /renew
ipconfig /all

The last command will show you the DNS in use to verify that it is now using the Pi-Hole.

IOS devices put in airplane mode for a few seconds (5-10) then turn airplane mode off.

Smart devices generally turn off for about 30 seconds, then power back up.


#9

Macs not Windows, actually.

I will give it another go though… And write back with any luck I have.


#10

Mac - system preferences > network > select the active internet interface (wifi or ethernet) > advanced > TCP/IP > renew lease.

You can verify the DNS server(s) in use in the DNS tab to the right of the TCP/IP tab.

This terminal command will flush the DNS cache on a Mac - sudo killall -HUP mDNSResponder


#11

And, if you aren’t using IPv6, turn it off on your router and set your Mac IPv6 to link-local.


#12

Did all of the above, and it still doesn’t seem to be functioning… Currently I cannot even get to pi-hole.net nor to https://pi-hole.net/pages-to-test-ad-blocking-performance/, additionally, all other connections do not show the correct DNS. (Showing just the router as DNS)

But the main one is no additional traffic on the dashboard @jfb


#13

I’ll add to that that additionally, it seems like I am able to use only about 80% of the website and things I try to do. Having difficulties on my iPhone, Mac, and other devices getting to a variety of websites, downloading photos, etc.


#14

On the Mac, are you seeing the IP of the Pi-Hole for DNS (and nothing else)? If not, manually assign the DNS on the Mac to Pi-Hole and see if your Mac traffic is filtered.

The problem likely lies in your router. There is likely a DNS setting somewhere in the menus that is providing a bypass around Pi-Hole.


#15

Essentially, as soon as I set it that way (Which is to say, manual DNS address to my pi-hole DNS at 192.168.1.### and then fetch a new DHCP lease on my Mac, it essentially breaks a number of items including the ability to access http://pi-hole.net/ which just stops loading entirely on both Chrome and Safari. As soon as I remove the pi-hole DNS it starts to work again.

It also does not appear to be blocking any content when set as a DNS.

Looking at the query log in the admin console, nothing except the localhost of the Pi-Hole is listed at all, suggesting that no other devices are going through it.


#16


#17

You can verify that the Pi-Hole is working (as your debug log indicates it should be). ssh into the Pi, then run a dig command for a domain not likely to be blocked and one known to be blocked. If the first returns a valid IP (or 0.0.0.0) and the second returns 0.0.0.0, you have verified the Pi-Hole and Pi work.

dig cnn.com

dig flurry.com

Let’s try to get a single client working on it. On the Mac, what are you seeing in your DNS tab on network settings? In the example below, both of the IP’s are Pi-Holes, manually set.


#18

@jfb,

Ran the dig command on those two. CNN returned a list of IPs:

ccn.com. 24 IN A 151.101.65.67
cnn.com. 24 IN A 151.101.129.67
cnn.com. 24 IN A 151.101.193.67
cnn.com. 24 IN A 151.101.1.67

and Flurry.com returns:

flurry.com. 2 IN A 0.0.0.0

Here are the DNS settings, I am unable to remove the search domain that is set.


#19

The Pi-Hole is working properly. The problem appears to be in your router, which is likely providing another DNS service.

What do you see on this screen:


#21

See attached
@jfb