Why do some sites take forever to load when using Pi-hole?


Updated my post, thanks.


Note that within the FTLDNS beta testing branches, there is a new option available that allows NXDOMAIN blocking. This should solve all these problems if you’re willing to try it out.


Thank you for the hint. Where I can find the

README of the FTLDNS branch



I think we’ll be writing a blog post about this, too. Would be cool if someone in here could already confirm that it is a solution for this problem.


Just wanted to give some feedback on the new FTLDNS branch which I’m now running as my main DNS.

After changing to BLOCKINGMODE=NXDOMAIN (it took me a while to locate the readme for this, which if anyone else needs is here: https://github.com/pi-hole/FTL/blob/FTLDNS/README.md ) I’m finding that unexplained delays in page loading have gone and that everything is now loading really quickly. For me personally the NXDOMAIN solution seems preferable to the previous pihole IP solution.

Well done to the developers!


I inserted the BLOCKINGMODE=NXDOMAIN into my /etc/pihole/pihole-FTL.conf and restarted the FTL-Service. But there is no change to recognize. A ping to a blocked DNS-name still resolved to the local IP.


Yes - I ran into that problem initially, but then pihole -up found an update which fixed it for me.


I tried, but updates doesn’t work

  [i] Checking for updates...
  [i] Pi-hole Core:	up to date
  [i] Web Interface:	up to date
curl: (22) The requested URL returned error: 404 Not Found
  [i] FTL:		update available

  [i] Downloading and Installing FTL...curl: (22) The requested URL returned error: 404 Not Found
  [✗] Downloading and Installing FTL
      Error: URL not found
  [✗] FTL Engine not installed.
  [i] Restarting services...


I can’t advise on that, but for me (checked just now):

    pi@RPi3-DNS:~ $ pihole -up
      [i] Checking for updates...
      [i] Pi-hole Core:     up to date
      [i] Web Interface:    up to date
      [i] FTL:              up to date

      [✓] Everything is up to date!

so maybe something else is broken…


You’re probably on a branch that no longer exists. Try running pihole checkout ftl FTLDNS to get back on a main branch. Then try the pihole -up again to make sure you have the latest.


I’m on the ftlbranch and want to stay here. I wouldn’t change back to the main branch.

Current Pi-hole version is v3.3-130-g2e6a937
Current AdminLTE version is v3.2.1-179-g3fd9b4d
Current FTL version is vDev-0f40cd1


@DanSchaper Right know I understand Error updating latest beta ftldns with regex

I did it, all is fine now.

Thank you