Speedport W 724V


#1

I’ve been trying repeatedly to setup Pi-hole network-wide, but I keep running into the same stuff. I watched people with the same Router that I own, did everything they did, just to find someone else’s guide and start all over again. I’ve tried all 3 methods listed in this guide: How do I configure my devices to use Pi-hole as their DNS server?

Router

  • DHCP on
  • local IPv6 address (ULA)
  • Fixed DNS server address (primary DNS towards Pi, secondary towards 8 8 8 8 (Google))
  • Sometimes I can’t reach my Router’s web page, it’s random

Pi-hole

  • doubles clients when I change the Router settings
  • http://pi.hole is sometimes not available, it’s random
  • DHCP off
  • Google (ECS)
  • Doesn’t block domains that I manually blacklist

I can’t give you more details, for now, I’m too mad and frustrated. Just know that I disabled the adapter that pointed towards the Pi’s IP, because that’s apparently unnecessary. The video I watched from the guy with the same Router is this: https://www.youtube.com/watch?v=rn1z-xBe720
You will probably not understand him, because he speaks German. Nevertheless, I’m gonna vent and destroy something IRL

Expected Behaviour:

[Replace this text with what you think should be happening]

Actual Behaviour:

[replace this text with what is actually happening]

Debug Token:

[https://tricorder.pi-hole.net/776w1v4ehd]


#2

Don’t use primary/secondary DNS or a backup DNS. That’s why things randomly work, sometimes you are using the Pi-hole and sometimes you are using Google.


#3

Do you see any reason why Pi-hole is not working in the logs? I just saw a problem with IPv6, but the problem persists, if I turn it off.


#4

The logs look fine. You’re telling your clients to use Pi-hole and Google. They query for pi.hole and when it actually hits Pi-hole it works, when it goes to Google it doesn’t. That’s the randomness to the situation.


#5

Your debug log shows that Pi-Hole is working normally and is correctly processing all DNS queries it has received - in the last 24 hours this is the activity

   [2019-02-28 13:44:16.134 749] Imported 3632 queries from the long-term database
   [2019-02-28 13:44:16.134 749]  -> Total DNS queries: 3632
   [2019-02-28 13:44:16.134 749]  -> Cached DNS queries: 583
   [2019-02-28 13:44:16.134 749]  -> Forwarded DNS queries: 2624
   [2019-02-28 13:44:16.134 749]  -> Exactly blocked DNS queries: 411
   [2019-02-28 13:44:16.134 749]  -> Unknown DNS queries: 14
   [2019-02-28 13:44:16.134 749]  -> Unique domains: 424
   [2019-02-28 13:44:16.134 749]  -> Unique clients: 3
   [2019-02-28 13:44:16.134 749]  -> Known forward destinations: 4

As noted by @dschaper, your problem is not with Pi-Hole, but with the fact that some of your DNS requests are bypassing Pi-hole.

Get rid of the 8.8.8.8 DNS in the router and all your DNS traffic will go through the Pi-Hole.


#6

Thank you for your help. I just had to point my adapter towards the Pi again, because I lost the connection, as soon as I made these changes to my router. According to Windows I still had internet access through, I just wasn’t able to reach any website.
This is a new log while being semi-offline:
https://tricorder.pi-hole.net/o1l1xebb76

Now I’m connected again connected again through the adapter. I would like to turn that off though. Pi-hole works on my phone now I think


#7

Actually never mind. I thought Pi-hole worked on my phone, but I was able to access a page I blacklisted.


#8

What adapter is this?


#9


That’s the static Ip of the Pi


#10

That client is manually mapped to the Pi-Hole. What is the result if you check “Obtain the DNS server address automatically” and apply that setting? That will show the DNS that is being provided by the router during the DHCP handshake.


#11

That will unfortunately get me semi-offline again where I can’t reach any website


#12

What is causing this? When you get the DNS automatically, what DNS are shown in the Windows box withipconfig/all?


#13

I don’t know. That’s what keeps bugging me…
>>ipconfig/all


#14

Your router is passing itself and an IPv6 DNS to the client, and not the Pi-Hole DNS address. If you aren’t using IPv6 on your network, I would disable that on the router and clients. That has frequently been a source of DNS bypass around Pi-Hole.


#15

Alright what I did is I used pihole -r to uncheck IPv6, then I went to my router settings and turned off IPv6 (ULA). Is that what you meant? Or do I need to do something else?

New debug log: https://tricorder.pi-hole.net/tqtj1or5ye
New Gist: ipconfig/all


#16

I think the problem lies in your router. Your Pi-Hole is working properly, and when clients send their DNS traffic to Pi-Hole it processes the traffic correctly.

I can’t help you with your router since I don’t have that model. I downloaded the manual and it doesn’t seem to be very configurable. Until you sort the router out, if you manually assign your clients to use Pi-hole as DNS then you should have good results with your Pi-Hole.


#17


I’m not saying you’re wrong, it’s probably the router… and @DL6ER has the same router. I don’t know how his setup works though. I appreciate the help :+1:


#18

Small correction: DL6ER had the same router, I had to change the provider when I moved because Deutsche Telekom isn’t offering stable Internet where I’m living now (rural area).

Long time ago, I cascaded a DD-WRT in between the Speedport and my network to be more flexible (and powerful) regarding firewall rules (like discard all DNS queries that do not come though the Pi-hole), so I might simply have missed the time when it didn’t work anymore.


#19

What would you do in my situation? If there is no other workaround, I would consider buying a new router. The Edgerouter X seems to be good, but I’m not sure whether or not my ISP (congstar) supports it. I might change my ISP anyway because I’m unsatisfied with my speeds. If I use Unitymedia for example, I’d have to use a TV cable :thinking:


#20

The same as I did: Put another router into the loop that is open for the modifications you want and not locked down to the bare minimum your ISP wants you to see.

I’m now living in Bavaria and here Vodafone (ex Kabel Deutschland) is providing the most reliable service over cable. I have the smallest package they offer (50 MBit/s) and am satisfied so far. I have a cable router without WiFi + my old DD-WRT router directly behind it. There is no reason to switch to cable TV if you’re using DVB-T or -S.