Pihole problem

Hello there!I ve just installed pihole to my raspi to block ads on my lan.The thing is that I want to block ads only on some devices (mobile,smart tv,tablet).So I don’t want to use it on my modem-router as default DNS.In a tutorial I saw that you can modify the connection through every device you want.So eg my wifi2.4 connection,modify the DNS from my tablet.If I understood correctly it says to use raspi’s iner ip as DNS.so lets say 192.168.1.300.
The thing is that when I do this,I get no internet access on my tablet.Should I somehow add the modem DNS to the raspi?should I do something else?Any help will be so much appreciated…
EDIT:when on pc I change my DNS settings (lets say to the wifi connection) I get no difference…I still have Internet,but no Ad is filtered…I may doing something wrong…but i have no idea what is that…

@bananasplit Welcome to the Pi-hole Community!
I assume that this IP address is just for an example … correct? As .300 would not be a valid address.

You basically have a couple of choices here:

  1. Do not enter the IP address of the Pi-hole on your router, but instead, enter it on each of the devices that you want to use the Pi-hole with, OR

  2. Try out the v5.0 beta of Pi-hole as it will allow you to select which network clients you wan to use for Pi-hole through the web interface.

Use Pi-Hole as DHCP server and use dnsmasq configuration lines to exclude clients.

Or, use the new Pi-Hole 5.0 beta which has this feature included

thank you so so much for the answers!!I m considering the 5 version since I had no success with entering the raspberry address to each device…(am I doing it wrong??)
I m unable to find the documentation though,but I will try harder…

Sorry,it was an example,yes!!
EDIT:Am I missing something here??I decided to try block the whole lan ads.So I tried the described method on the tutorial,and changed my router’s DNS to the inner IP of my raspberry.I reloaded both the PC and the router.And I tried many sites.Youtube,and also sites like this to test it.It was always displaying ads.It didn’t work.Any ideas??I feel silly but I can’t find a solution…
EDIT 2:I suppose I found one of my mistakes.I can’t change DNS on the DLS section of my router.I can change only on LAN section.Maybe it’s a problem,right?

@bananasplit

Let’s test to see if Pi-hole is working at all. On any of your network clients, open a Terminal (or Command Prompt if using Windows), and then, enter the following command: nslookup pi.hole

Please post the results. The address in the results should be the IP address of your Pi-hole.

Next, open Terminal or Command Prompt, ssh into your Pi-hole, and then, enter: cat /etc/pihole/setupVars.conf
Post the results.

Finally, while still in the Terminal, enter: echo “>stats” | nc localhost 4711
Post the results.

I just tried nslookup pi.hole and the results are not encouraging…pihole
Another problem.
I already made the IP as static.As shown here:


But every time the router restarts the address changes…One time to 192.168.1.41,or to .17
I have no idea why this happens…Is my router so crappy?

@bananasplit Ok, something is definitely wrong here. What is the make & model of your router?

What were the results of the other two commands that I provided you?

WEBPASSWORD=3d68e513aa574ec4a21e8a1fd8b4a028e3a5210165ffe5d415f387b153d61e51
DHCP_START=192.168.1.201
DHCP_END=192.168.1.251
DHCP_ROUTER=192.168.1.254
DHCP_LEASETIME=24
PIHOLE_DOMAIN=lan
DHCP_IPv6=false
DHCP_rapid_commit=false
DHCP_ACTIVE=false
BLOCKING_ENABLED=true
PIHOLE_INTERFACE=eth0
IPV4_ADDRESS=192.168.1.17/24
IPV6_ADDRESS=
PIHOLE_DNS_1=8.8.8.8
PIHOLE_DNS_2=8.8.4.4
QUERY_LOGGING=false
INSTALL_WEB_SERVER=true
INSTALL_WEB_INTERFACE=true
LIGHTTPD_ENABLED=true

and echo “>stats” | nc localhost 4711 don;t return anything.
My router is tg589 v3.
Any ideas,maybe in the settings of the Pi??

@bananasplit

Do you have both your Technicolor router and the Pi-hole performing as DHCP servers? I also noticed that you have query logging disabled. Is this what you want for your Pi-hole configuration?

I have disable the logging because they said it is destroying the sd card…about the dhcp I have it enabled only to the router and not on the pi-hole…I thought that it would make 2 different lans who would not communicate…

Who is “they”?

1 Like

@bananasplit
Ok, at this point, I would suggest that you ssh into your Pi-hole and enter: pihole -r, and then, choose the repair option.

If the Pi-hole is still not working for you, then try pihole -d and upload the token so that the Developers can see what the issue may be.

hello once again!
I did the pihole -r.I repaired it.But I discovered that once again the pihole ip is different from the actual raspberry pi.Every time the router restarts it gives another IP.Could I somehow disable DHCP on my router and use just the DHCP of the mirouter (which I have) OR the raspberry?maybe it could solve the problem?

I would disable DHCP on your router, and enable it on your Pi-hole.

Ok!I ve disabled the DHCP on my router.And enabled it on pi hole.Again,nslookup pi.hole returns nothing.
I also made the inner IP of the pi.hole as the DNS on my windows (to check it).Should I try something else??here are my dhcp settings and dns settings (on the router) just to check I m not making a silly mistake…sorry for keep asking but it drives my crazy…If we can’t find a solution I ll leave it…

I suggest disabling IPv6 DHCP on your router as well. If this still does not work, as I suggested earlier, ssh into your Pi-hole and enter: pihole -d to run the diagnostics. Be sure to send the resultant token so that the Pi-hole developers can review the results and provide you with further assistance. I really can’t help you at that level.

I ve just send them an email!!thanks so so much for your help!!

I ve tried to send the developers an e-mail at adblock@pi-hole.net.It returned not delivered…I also tried a personal e-mail with no response yet…I wish someone sees it so I could get in contact with them…

Please posrpr the token generated by

pihole -d

or do it through the Web interface: