Pi-hole not working on one device, rest is working fine.

Expected Behaviour:

Expected Behavior is, Pi-Hole should work on all device connected to the wifi router.

Actual Behaviour:

Actual Behaviour: All the devices that connected are working as expected but one mobile device is some how bypassing the Pi-hole setup.

Device Lists, that are working:
A Laptop
2 Oneplus Mobile device
an iPad.

Not Working:
OnePlus 7T Pro.

Debug Token:


How can we correct this entry (IPV4_ADDRESS=), its from my old router.

*** [ DIAGNOSING ]: Setup variables

Run pihole -r reconfigure.

How do you distribute pihole's IP to the clients? DHCP or do you configure them manually?
If by DHCP: you have to dis/reconnect the clients from your network once to pickup the (new?) DHCP settings.

IPs are distributed via router's DHCP.

One more thing,

When I was using my Old router, pihole query logs were showing IP addresses of individual devices. Now it shows (router's IP) only for all the queries.

Any reason why its behaving like that. And how can I change it to show assigned device's IP.

Note: using router's DHCP
Router : Netgear R7000

1 Like

As you describe it, your router is distributing it's own IP as DNS server via DHCP to the clients.
From a quick search, you can't change the IP distributed as local DNS server to something else (you would want to distribute Pihole's IP).


Your'r only option seems to be to disable DHCP on your router and use Pihole as DHCP server if you want to see each individual client in the query log.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.