LAN DNS server for local names on Netgear R7000


#1

Please follow the below template, it will help us to help you!

Expected Behavior:

Pi-hole can resolve and separate client traffic

Actual Behavior:

I have a Netgear Nighthawk R7000 acting as my router and DHCP server, with a hardwired RPi running PiHole. I have set the router to use the RPi as the primary DNS server (I’m using the Netgear genie software). Everything works great, except…
The Query log only lists my router, which makes some sense (as all traffic is sent from it). I lived with this for a while, then decided I wanted to know what traffic was coming from each device on the network.

My first attempt at this was to set the set my devices with static IPs (and tell the Nighthawk to give each device the same IP), and manually set the DNS server in each device. Then I edited my /etc/hosts on the RPi file to know which name went with which IP. This worked for the devices that allowed me to do it; some IoT devices didn’t have easy ways to make this happen, however. While PiHole did display client names for the devices I could set this up with, I didn’t feel that this was the best way to accomplish the goal.

My next attempt was to follow the "HOWTO: Using pi-hole as LAN DNS server"


I opted for the ‘domain-less life’ in the Additional thoughts section, and created the /etc/pihole/lan.list (in my RPi) as
10.0.0.10 Phone1
10.0.0.11 Phone2
10.0.0.12 Tablet
10.0.0.13 Device1
etc…
I UNchecked “never forward non-FQDNs” and “Never forward reverse lookups for private IP ranges” in PiHole, set my devices back to DHCP (but kept the same static IP settings in the Nighthawk), made sure that the device were getting same IPs assigned, and force-reloaded dnsmasq. This doesn’t seem to have worked as the Query list shows the router as the only client again.

I’m looking for advice on getting the “HOWTO: Using pi-hole as LAN DNS server” working with the Nighthawk…? Should I go with a domain name? Where in the Nighthawk do I put this information, and (more importantly) how can I get the Nighthawk to look to the RPi for local names (again, using the Netgear genie software)?

Debug Token:

I’m not sure that anything is actually going wrong here. I just want to make it work ‘better’…


Www.googleadservices.com 8,894k denied requests (while asleep?)
#2

Disable the DHCP server on the router and enable it on the Pi-hole. If you don’t want to do that, check for an option on the router to disable dnsmasq.