Netgear R7000 Changing settings fails

Netgear R7000/AC1900 (; and Raspberry Pi ( running Pi-hole.
Pi-hole running DNS and DHCP
Unable to apply changes to the Lan Setup page on Netgear while DNS of the router is pointing to Ph-hole. When trying to disable DHCP on the router, I get an “IP conflict” error when trying to apply the change (or any changes on the Lan Setup page.)
Unable to communicate with Pi-hole if DHCP is disabled on the router (even with DHCP enabled on Pi-hole)


  1. On the Internet Setting page, temporarily remove Pi-hole’s IP address from the Internet Settings page on the router, apply change.
  2. On the LAN Setup page, keep DHCP enabled on the router, however configure the range of IP addresses to a single IP address, i.e., From to
  3. To prevent the router from assigning IP addresses, I reserved the static IP address (or whatever subnet you’re using) to a fake/made-up MAC address (only using Hex characters of course), with the name, Null. (I gave it this name, but you can use any name you like.)
  4. Apply the change, and then,
  5. On the Internet Setting page, add Pi-hole’s IP address back to the DNS settings on the Internet Setup page.
1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.