Pi-hole DNS not resolving

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi-hole resolves DNS queries made by clients

Actual Behaviour:

DNS requests made to the pi-hole are not resolving

Debug Token:

a38rbm4607

0 Likes

#2

Your debug log shows that your Pi-Hole is working properly. The problem appears to be in the configuration of your router and/or clients to use the Pi-Hole.

I would start with manually assigning the Pi-Hole as DNS on a single client, and get that client working on Pi-Hole. Then work on the router assignment to get the entire network on Pi-Hole.

0 Likes

#3

I have my router DNS set to be the pi-hole. When I set the DNS to the pi-hole nothing loads, but when I set it back to Cloudflare DNS everything is fine again.

0 Likes

#4

Since the debug log is showing that the Pi can properly resolve queries, this is an indicator of a router problem. By manually assigning a client to Pi-Hole, you can verify that Pi-Hole is working and see the client queries populate the Pi-Hole log.

Let’s do some basic troubleshooting. From a client, run the following commands and post the output:

nslookup pi-hole.net

nslookup pi-hole.net 192.168.1.94

nslookup flurry.com 192.168.1.94

From the Pi terminal run these commands and post the output:

dig pi-hole.net

dig flurry.com

0 Likes

#5

I set the Windows 10 machine I ran these on to use the pi-hole.

nslookup pi-hole.net

Server: raspberrypi
Address: 192.168.1.94

Non-authoritative answer:
Name: pi-hole.net
Addresses: 2604:a880:400:d0::1071:1
206.189.252.21

nslookup pi-hole.net 192.168.1.94

Server: raspberrypi
Address: 192.168.1.94

Non-authoritative answer:
Name: pi-hole.net
Addresses: 2604:a880:400:d0::1071:1
206.189.252.21

nslookup flurry.com 192.168.1.94

Server: raspberrypi
Address: 192.168.1.94

Name: flurry.com
Addresses: ::
0.0.0.0

dig pi-hole.net

; <<>> DiG 9.10.3-P4-Raspbian <<>> pi-hole.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29692
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pi-hole.net. IN A

;; ANSWER SECTION:
pi-hole.net. 185 IN A 206.189.252.21

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Feb 18 04:11:59 GMT 2019
;; MSG SIZE rcvd: 56

dig flurry.com

; <<>> DiG 9.10.3-P4-Raspbian <<>> flurry.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31186
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;flurry.com. IN A

;; ANSWER SECTION:
flurry.com. 2 IN A 0.0.0.0

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Feb 18 04:12:17 GMT 2019
;; MSG SIZE rcvd: 55

0 Likes

DNS not resolving, static IP, DHCP disabled, nslookup works
#6

What these replies tell us:

nslookup pi-hole.net - returned the correct IP, the DNS server was the Pi-Hole at IP 94. This client is using Pi-Hole as DNS server

nslookup pi-hole.net 192.168.1.94 - this lookup forced the DNS to go to the Pi-Hole, and is the same reply as the nslookup above, confirming that the Pi-Hole is working and is the default DNS for that client.

nslookup flurry.com 192.168.1.94 returned the NULL IP as expected - this is a known ad-serving domain and was blocked by Pi-Hole.

The two digs returned the correct answers, indicating that Pi-Hole is working.

Everything we have tested so far, plus your debug log, indicates that DNS requests made to the Pi-Hole are resolving.

The problem lies in your router, by all indications.

0 Likes

#7

This works

This doesn’t

0 Likes

#8

This is a router problem. Check all the router settings for items like rebind protection, etc. You can try listing the Pi-Hole DNS twice, etc.

In the meantime, since your Pi-Hole is working, manually assign clients to use Pi-Hole as DNS while you sort out your router.

0 Likes

#9

I think the router has rebind protection turned on without an option to disable it (or something else is wrong). Anyway, I setup the pi-hole as a DHCP server and it’s working now. Thanks for all the help!

0 Likes

closed #10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes