Pi hole and DDWRT with VAP

Hi, I have a router with DDWRT and a raspberry pi with latest Pi hole. In my home I have all my devices on the same Wifi except some IoT devices that are on a separate VAP. I did this using this guide: How do I configure my devices to use Pi-hole as their DNS server?

Then I had some issues setting up my pi as my dns requests didn’t seem to reach it properly. I then found a solution in this thread to forward DHCP from ddwrt router to the pi itselft: Pi-hole and ddwrt settings and this seems to work perfectly fine except now my vap doesn’t work anymore. How can I configure it when I use the Pi to forward requests?

I have also tried adding dhcp-option=6,192.168.1.149 to the dns settings on ddwrt and that causes the same issues, that my regular wifi works but not my vap.

This seems more like a DDWRT problem rather than a Pi-hole issue.

You could try changing Pi-hole’s DNS settings for its Interface listening behaviour to “Listen on all interfaces, permit all origins”, but heed the advice on that page:

should not be used on devices which are directly connected to the Internet

This might or might not solve your problem.
Even if it does, it would definitely be preferable to have your DDWRT router configure access to Pi-hole correctly.

As this is not Pi-hole specific, you might have better luck looking for a solution in the DDWRT forums.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.