Pi hole 5 Probleme in Kombination mit fritzbox 7490

Liebe pi hole Gemeine,

zuallererst hallo.
Ich habe Fragen an euch welche ich nicht alleine in den Griff bekomme.
Es fing alles mit einem NAS an welchen ich die Tage in Betrieb nehmen wollte. Mit einer zweiten fritzbox musste das Netzwerk mit lan Anschlüssen erweitert werden. Nachdem sich die erste fritzbox als mesh client eingestellt hatte ging gar nichts mehr und Ich musste meine fritzbox neu aufsetzen und auch den pi hole neu einbinden. Da habe ich dann gleich das Update auf V5 gemacht. Dann hatte ich erst das Problem das gar nichts mehr geblockt wurde und jetzt blockt er wieder. Aber es ist zb der App Store nicht mehr erreichbar. Und das lustige ist, das ich per webinterface des pi hole zwar temporär deaktivieren kann aber es sich nichts tut, App Store ist trotzdem nicht erreichbar und Werbung wird weiter geblockt. Auch das setzen auf die whitelist in web queries bringt nichts mehr. Irgendwas passt nicht. Per Fritz VPN Komme ich von extern per VPN on demand in mein Netzwerk und bin auch mobil geschützt. Als ich den pi hole updatete kam ein DNS Fehler. Ich Suche den Screenshot raus und hänge ihn noch an.
Jetzt die Frage, was braucht ihr von mir an Infos um weiter zu kommen?
Screen Shot 2020-05-13 at 12.24.40


Besten Dank und viele Grüße

Hallo @Beamformer, willkommen in der Pihole Community.

Dein Text ist etwas.... ähh.. unübersichtlich. Vielleicht kannst du eine Liste mit Problemen erstellen, damit wir die einzeln auseinander nehmen können? Weiterhin schreibst du, dass du mehrer Dinge gleichzeitg im Netzwerk geändert hast: 2. Fritzbox, Pihole Update,.... kannst du mal schematisch aufzeichnen, wie dein Netzwerk jetzt aussieht?

Continuing the discussion from Pi hole 5 Probleme in Kombination mit fritzbox 7490:

Hallo yubiuser, vielen Dank für Deine Rückmeldung,

sehr gerne sage ich wie es jetzt bei mir aussieht.
Ich betreibe eine FritzBox 7490 als Router, hier hängt am USB Anschluß der PiHole per LAN dran und das lief bzw. läuft "soweit" auch. Des Weiteren geht nun ein Lan Kabel zu eine AirportExtreme um weitere Lan Anschlüsse zu erhalten. Hier hängen mein (neuer noch nicht eingerichteter) NAS und eine Dreambox dran.


Eigentlich wollte ich dem PiHole wieder (also wie vor dem Unglück) die 44er IP geben, aber irgendwie sieht meine FritzBox das anders :frowning:
Und jetzt lässt sich der PiHole (über das Webinterface) zwar deaktivieren (und zählt auch die Sekunden runter) aber die Werbung bleibt trotzdem weg und auch der Appstore ist für mich nicht mehr zugänglich, egal ob lokal oder per VPN. v6 möchte ich übrigens nicht und bin im v4 Netz. Ich hoffe ich habe das verständlich erklären können?!
Den PiHole habe ich übrigens an der FritzBox eingetragen wie er die letzten Jahre problemlos lief.

Besten Dank und viele gesunde Grüße

Diese Adliste ist veraltet und existiert nicht mehr. Deshalb wird sie in Pihole v5 auch nicht mehr als Standardliste "mitgeliefert".


Der Pihole sollte eine feste (statische) IP Adresse bekommen, die außerhalb des DHCP Bereichs liegt (also außerhalb 192.168.178.20-200). Wenn es wieder .44 sein soll, würde ich den DHCP Bereich einfach erst bei .50 beginnen lassen. Anschließend im Pihole pihole -r ausführen und die neue statische Adresse eintragen. Anschließend in der FB die .44 wieder als DNS-Server festlegen.


Darum würde ich mich erst kümmern, wenn das andere läuft.


Hast du mal geschaut, ob vielleicht eine Domain, die der Appstore nutzt einfach von einer Adlist geblockt wird?

Vielen Dank,
dann ist der DNS Fehler normal? Kam halt als ich PiHole neu aufsetzte (pihole -r).
Die statische Adresse passt ja (leider jetzt die 28) aber diese ist fest, sonst würde es ja per VPN nicht gehen und die 44 habe ich eingetragen bei Phiole -r. Bestätigt mir PiHole auch (zweites Bild). also außerhalb vom DHCP Bereich habe ich noch nie etwas vergeben. Ok, DHCP ist geändert, danke.
PiHole frisch aufgesetzt -allerdings muss ich jetzt echt lachen, jetzt "holt" er sich die 51er IP Adresse und nicht wie ich will die 44 - egal, warum auch immer. Anbei ein paar Screenshots der Installation.

Screen Shot 2020-05-17 at 14.57.41 Screen Shot 2020-05-17 at 14.58.14 !
Also das query log sieht relativ grün aus
Wie könnte ich die Domain finden?

Danke

Screen Shot 2020-05-17 at 14.57.55

Screen Shot 2020-05-17 at 15.04.22

Wenn dein Pihole die IP .51 bekommen hat, dann wird diese noch von der FB über DHCP bezogen (ist ja schließlich innerhalb .50-200). Mit pihole -r kann man die Adresse nicht für das Gerät einstellen, sondern "nur" für die Software Pihole.
Deshalb:

Auf welcher Hardware läuft denn Pihole? Ist es ein Raspberry Pi?
Schau mal hier, Variante 2 beschreibt, wie man eine feste (statische) IP vergibt.
https://www.elektronik-kompendium.de/sites/raspberry-pi/1912151.htm

Anschließend nochmal pihole -r ausführen und auf die (neue) statische Adresse setzen. Dann in der FB diese Adresse als DNS-Server setzen.


Welcher DNS-Fehler? Das hier:

Ja, ist normal. Das ist so, als ob du eine Webseite aufrufen willst, die nicht mehr existiert. Wird bei jedem Update der Adlisten auftauchen, solange du diese Adliste nicht vom Pihole entfernst.


Wenn es grün ist, ist es nicht geblockt wurde - dann gibt es wahrscheinlich andere Gründe, warum die Seite nicht angezeigt werden konnt.

ja genau, läuft auf einem Pi3B+ mit dietpi.
Lustigerweise habe ich das wohl bereits (vor langer Zeit) gemacht.
Screenshot 2020-05-17 at 20.57.45
In der Datei passt es.
Genau, das mit grün und rot ist mir klar.
Ok dann kann ich den Fehler ja ignorieren.
Jetzt frage ich mich halt noch warum ich den PiHole nicht deaktivieren kann bzw. warum der Appstore nicht mehr geht oder Sprachnachrichten ankommen.

Fangen wir damit an. Das habe ich hier schon mal gelesen:

Leider gab es darauf keine weiteren Infos. Es gibt noch zwei weitere Meldungen auf github (hier und hier), da treten jedes Mal aber noch weitere Probleme auf (Freez des Web Interface oder so).

Du kannst mal folgendes machen: Disablen und dann in /var/log/lighttpd/error.log schauen, ob da Fehlermeldungen auftrauchen.

Zusätzlich anschließend pihole über CLI deaktivieren und schauen, ob er dann auch deaktiviert bleibt.
pihole disable 1m

Leider war ich nicht zu Hause in den letzten Wochen (familiärer Notfall). Ab Morgen Abend bin ich wieder zu Hause und kann weitere Infos geben. Könnt ihr mich bitte wissen lassen, welche Info ihr braucht?

Hallo, vielen Dank für eure Nachrichten.
was soll das sein mit den Hoobs?
Also eben habe ich über das Webinterface 5 min deaktiviert und konnte den Appstore in dieser Zeit aufrufen. Die log Datei scheint leer zu sein - also keine Fehler.
Screen Shot 2020-05-18 at 14.09.32


So wie es aussieht bleibt der PiHole deaktiviert nach einer Minute, zumindest bekomme ich Werbung. Soll das so sein? Wie schalte ich ihn wieder ein?
Screen Shot 2020-05-18 at 14.27.30

Sollte sich (wie im Web interface auch) automatisch wieder einschalten.

D.h. im Webinterface schaltest du ihn aus und er blockiert weiter, und per CLI schaltest du ihn für 1 min aus und er geht nie wieder alleine an?

ok, wie überprüfe ich am besten ob der PiHole läuft oder nicht?
Also mein Appstore geht wieder nicht aber wenn ich die Seite welt.de anrufe sehe ich (viel) Werbung.

Z.B. indem du eine Seite aufrufst requestes, von der du weißt, dass sie geblockt werden sollte.

dig flurry.com

wenn die geblockt wird, sieht das so aus

;; ANSWER SECTION:
flurry.com.		2	IN	A	0.0.0.0

danke, da kommt ein timeout

Möglicherweise hast Du eine DNS-Schleife konfiguriert.

Stell uns doch bitte mal ein Debug Log zur Verfügung:

pihole -d

oder über die Web-Oberfläche:

Tools | Generate Debug Log

Anschliessend reicht es, das am Ende angezeigte Token hier zu posten.

kann das jetzt über die Internetseite runter geladen werden?

Mal eine Frage, seit der ganzen Problematik vor einigen Tagen habe ich mein Netzwerk erweitert, zuerst mit einer zweiten fritzbox und jetzt mit einer AirPort Extreme weil mir die lan Anschlüsse aus gingen. Jetzt steht da was von einer ip 51, die gleiche hat doch jetzt mein pi auch (weil ich die 44er nicht mehr hin bekomme).


Laut fritzbox ist die 51 (logischerweise) nur einmal vergeben:

Nein, denn die Ausgabe zeigt, dass das Upload fehlgeschlagen ist, weshalb auch kein Token generiert wurde.

Und diese IP wird laut Ausgabe von Deinem Airport als DNS Server verwendet, was Pi-holes Aufgabe in Deinem Netz ist.

Was gibt das folgende Kommando auf Deiner Pi-hole-Maschine aus?

ip -4 address show