One router, dual band, Can connect to only one(either) of two, when using pihole dhcp service

Please follow the below template, it will help us to help you!

I have one router with 2GHz and 5GHz signals (wifi2G, wifi5G).

Expected Behaviour:

For a computer to be able to connect to either wifi network coming from the same router

pi works 99% perfect , except when…

Actual Behaviour:

My laptop/device can connect to the first one i chose (either wifi2G or wifi5G), but i can not then connect to the one i chose second, with error being unable to resolve IP. Same behavior with 4 devices (laptop KDE, laptop Ubuntu, iphone, samsung tablet). I can get around this by generating a clone MAC address for one of the two networks, when doing so i am able to connect to either as i chose.

{there is no problem connecting to the ethernet connection coming from the same router as this is handled but the eth0 MAC address}.

This problem is true when i am using pihole’s dhcp service. When i am using the router’s dhcp service this is not a problem (netgear D7800).

Debug Token:

78yr06lbbh

And finally, Awesome product! Thank you for providing such a great service to the community

Many routers will let you combine the 2.4 GHz and 5 GHz networks into a common SSID. That is the option that should work for you.

Sometimes you can do this by giving each frequency the same SSID and password, other routers have a setting to join them.

Thank you for your reply jfb

I can give the the same ssid and password, however that is a workaround and not a solution. For several reasons, i would like to keep those two bands separate.

It should be possible and allowed. It feels more like bug if anything.

How would this be a bug? The linking of the two frequencies is done at the router, not at the Pi-Hole. Pi-Hole connects to a network and the router does the rest.

Is your problem resolved by using the ethernet connection for the Pi? That’s a more reliable solution than wireless, so if it works with ethernet, use that.

Maybe i have not make this clear.

The pi is connected to the router with ethernet and the pi works 99% awesome. the problem lies as below…

The problem lies when i use my laptop (or any device) to connect to the internet first via wifi2G(or wifi5G) and then to wifi5G(or wifi2G). Laptop will connect fine and get an ip with my first attempt and browse an ad-free internet. But if i subsequently decide to connect my laptop to the other wifi band then pi does not resolve an ip and laptop can not connect to the internet.

{I keep the two bands on separate SSIDs to manage my traffic to appropriate bands manually}

When i turn off the dhcp pi service, and use the router dhcp service this problem goes away (i.e when router is managing the dhcp

I believe this is a router issue, not a Pi-Hole issue. The different wireless frequencies are invisible to the Pi, which is connected via ethernet, and the wireless behavior is controlled solely by the router.

What make/model router are you using?

I am using netgear D7800

True both frequencies are visible to the router, since i can connect to the first one i chose, either 2G or 5G. And ofcourse i can connect without a problem to another wifi signal coming from a another discrete router. So the problem lies with that the wifi2G and wifi5G coming from the same router.

I am thinking it is a pi problem because:

  1. this problem occurs only when i use the pi’s dhcp service (not when using the router’s dhcp service)
  2. when i use two different mac address (one real and one fake) one for each frequency, then my laptop connects to both fine

I’m not seeing how the Pi can manage any behavior between two router frequencies. I think the reason the router DHCP works for you is that it manages the traffic between the frequencies (being aware of the frequencies), while the Pi does not (it does not have the frequency information).

For your segregation purposes, instead of using different frequencies could you set up two VLANs?

Shouldn’t two different ssid signals (even from the same router) be handled as two different entities by the pi (as it does when they originate from two discrete routers) ?

Since i can connect to signals from two different routers, then when pi gets two different SSIDs from the same router it seems to not know what to do.

The Pi is processing only the information transmitted over its ethernet connection to the router. Depending on the Pi model, it may not even be able to connect to the 5 GHz band using wifi.

Managing the bands on the router is not in the scope of what a Pi DHCP server can do.

I am not asking for the pi to manage any bands and the pi is connected to the router via ethenret

But… the pi can not handle my laptop connecting to two SSIDS coming from the same router, while it has no problem when my laptop connects to two SSIDs from two different routers. When i change the MAC address of my laptop then my laptop can connect to two SSIDs coming from the same router.

There is something about the pi when a device is trying to connect to two SSIDs coming from the same router, that is clear.

…and again, this is a problem ONLY when i turn on pi dhcp service

The Pi is unaware of how your laptop is connected to your router. The Pi sees only a stream of DNS requests coming to it over the ethernet connection. How they get there is unknown to the Pi.

However, when the pi is also running a dhcp server then the problem begins. At that point the pi is handling laptop’s MAC address, Router SSID, and then provides an IP

The Pi sees a DHCP request coming to it over ethernet, and doesn’t see the SSID or any of the router wireless configuration. The flow path for the DHCP request is the same as for a DNS request.

OK, thank you for that, i was not aware how that is managed.

be that as it may,

I still do not understand why then this simple thing is not working…

All the network routing is done by the router. Pi-Hole is a semi-dumb client that processes requests sent to it by the router. No devices communicate directly with the Pi-Hole, other than the router.

Apparently more people are having the same issue

It is not an uncommon issue - it happens with some routers. Note that the solution in the referenced thread was to combine the bands into a single SSID.

true. However, it is again a workaround and not a solution

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.