DHCP + dual band sadness

I know that this has been discussed in the past but I would love to, at the very least, ask a few questions on the topic. I'll start with my observations/questions and link an old topic at the end.

My network setup: I have a Netgear RAX45 with the PiHole running on Rasbian Buster Lite on a Vilros Raspberry Pi Zero W. I run the router in dual-band mode because, thanks to our increased needs due to all the WFH/school craziness, I wanted to give the laptops, etc, access to the 5GHz fanciness and keep the rest of the house's connections on the 2.4GHz. In fact, I wanted to ensure that my kids were on the 5GHz so I separated out the WAPs between the two bands as opposed to hoping Netgear's "Smart Connect" would do the work (I noticed when I looked at the admin panel ... it would just leave the devices connected to whatever band they were on).

Now, since Netgear decided to not include any parental monitoring in the firmware for this router, I've been setting up the PiHole to manage blocking things like Roblox during school hours in addition to the normal ad duties, and that's all fine and dandy. But, I wanted to get device-level ip reporting, so I set up DHCP (and that's when I came here with the FTL issues, because before I got to that point I was trying to use conditional forwarding and static IPs to do the duty and ... it didn't work. Shout out to @jfb!). (nb: I did do all the necessary things, including switching off DHCP on the router, so the pihole is the only DHCP server on the network.) It worked well, until I realized that my Ring Chime was offline, and in trying to fix it, I noticed: if I get a lease from the pihole on one band and then try to switch to the other, I can't get an ip address.

I've played around with a few things: trying to give that device a static ip address and then switch WAPs (and I'm ensure that the MAC addy is consistent between them, since Android, where I was doing my original testing, can using "private mode" and provide a fake one), for example. It doesn't work; in the end, the only thing that DOES is using the router as the DHCP server, which then means ... no per-ip reporting.

I am not sure what the DHCP implementation is on the pihole but I believe that there's likely really an issue here. On the router, there's only one place to define the DNS and DHCP servers across the bands, so I've essentially exhausted that; I just think that somehow pihole's DHCP isn't recognizing the device when it comes in from a new band. (Granted... this is all semi-informed debugging at best.)

Something else this made me wonder: say that I did change my setup to a single WAP (also every time I type WAP I laugh, thanks Cardi B) and used Netgear's Smart Connect feature against the pihole DHCP. I wonder if this issue would be obscured at that point, because when the router couldn't obtain an IP address on one band, it just switched back to the other -- meaning that it essentially is forcing a single-band experience once a device attaches to a band and obtains an IP from the pihole.

What say y'all?

Sooooo... I'm wondering if I fixed this, not actually having fixed it. I'm just going to say what I did and leave this thread here in case anybody else searches for it, but this is going to be the biggest lol if it turns out that this is actually all that anybody needs to do.

After you set DHCP in the pihole, reboot your router and the pihole both.

I think my router had some leases still set up and needed to actually be hard rebooted to release them. I'll keep testing this to see if that's the answer, but feel free to laugh as much as anybody would like to at this thread. :laughing: