Millions of PTR Queries in-addr.arpa

There are literal millions of queries. How do i solve this?query

Edit: TURN OFF Conditional Forwarding, that seemed to be my issue

The first is a Bonjour request (Apple uses this). The second is likely related.

Do you have conditional forwarding enabled? That can cause a lot of circular traffic.

I did have it enabled, I continued to look for the culprit and figured that it sounded like it was.

Edit: Queries dropped from 8000 to 200 after disabling it. I'm thinking that was the problem.

If you were using conditional forwarding to show client IP/names on your dashboard, you can use Pi-Hole DHCP and accomplish the same thing.

Any way to use Conditional Forwarding without these queries filling everything up?

I'm seeing tons of them as well, but they stop when I turn off Conditional Forwarding, but I have an ISP router what I don't think lets me turn off DHCP.

I'm just testing something here... I had set both the WAN and LAN on my router to the Pi-Hole. Turned the WAN back to normal the queries seem to have stopped??? Do I need the WAN of the router pointing at the Pi-Hole? Seems to me like it is working.

From your results, no.

Ok thanks. The thousands of queries has stopped, and Pi-Hole still seems to be working.

However, Pi-Hole doesn't seem to see the DHCP names from my router for local devices. I guess I'll call my ISP and see if they can show me how to get into the installer side of their router and turn off their DHCP... but I'm not holding my breath.

I know this is an old post but my fix was to switch my Comcast modem into "bridge" mode. I hope this works for you since your post let me figure out why I was getting so many ptr records once every hour.

Hello @Orion_13 I ended up scrapping my ISP router as well. Bridge mode typically opens up one (or more) of your LAN ports so that you can connect a router directly to the internet and skip the ISP router. As far as I know, if you connect a computer directly to the bridged router it would be fully exposed to the internet, so just make sure you have another router if your ISP's is in bridge mode.