FTL not running, lost connection to API

dnsmasq: syntax check OK

The file /var/lib/misc/dnsmasq.leases is not a Pi-hole file, and may be a vestige of the old dnsmasq that was running. I’m not sure how Pi-hole is even finding that file, but let’s take a look at all your dnsmasq configuration. What is the output of this command which will show all the non-commented entries in the /etc/dnsmasq directory:

sudo grep -v '#\|^$' -R /etc/dnsmasq.*

literally nothing but when I hit enter i get a >
and it looks like this now

Very odd. Let’s try running a repair to Pi-hole.

pihole -r and select the “repair” option.

i have tried that multiple times now

Let’s look here then. It is highly unusual for that directory to be empty. It should have at minimum a file 01-pihole.conf , as this is installed by Pi-hole.

ls -lha /etc/dnsmasq.d

it has stuff in it
total 24K
drwxr-xr-x 2 root root 4.0K Apr 20 14:11 .
drwxr-xr-x 118 root root 12K Apr 20 14:11 …
-rw-r–r-- 1 root root 1.5K Apr 20 14:11 01-pihole.conf
-rw-r–r-- 1 root root 117 Feb 12 15:51 custom-dnsmasq.conf

You ran this command exactly as written (i.e. copy / paste into the terminal)?

apparently not

also I am so sorry for the delay my internet isn’t the fastest and it takes quite some time but nevertheless

root@raspberrypi:~# sudo grep -v '#\|^$' -R /etc/dnsmasq.*
/etc/dnsmasq.conf:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.conf.dpkg-old:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.conf.old:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.conf.orig:dhcp-mac=set:client_is_a_pi,B8:27:EB:*:*:*
/etc/dnsmasq.conf.orig:dhcp-reply-delay=tag:client_is_a_pi,2
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/gravity.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/black.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/local.list
/etc/dnsmasq.d/01-pihole.conf:localise-queries
/etc/dnsmasq.d/01-pihole.conf:no-resolv
/etc/dnsmasq.d/01-pihole.conf:cache-size=10000
/etc/dnsmasq.d/01-pihole.conf:log-queries
/etc/dnsmasq.d/01-pihole.conf:log-facility=/var/log/pihole.log
/etc/dnsmasq.d/01-pihole.conf:local-ttl=2
/etc/dnsmasq.d/01-pihole.conf:log-async
/etc/dnsmasq.d/01-pihole.conf:server=8.8.8.8
/etc/dnsmasq.d/01-pihole.conf:domain-needed
/etc/dnsmasq.d/01-pihole.conf:bogus-priv
/etc/dnsmasq.d/01-pihole.conf:except-interface=nonexisting
/etc/dnsmasq.d/01-pihole.conf:server=/use-application-dns.net/
/etc/dnsmasq.d/custom-dnsmasq.conf:interface=eth0
/etc/dnsmasq.d/custom-dnsmasq.conf:bind-interfaces
/etc/dnsmasq.d/custom-dnsmasq.conf:server=8.8.8.8
/etc/dnsmasq.d/custom-dnsmasq.conf:domain-needed
/etc/dnsmasq.d/custom-dnsmasq.conf:bogus-priv
/etc/dnsmasq.d/custom-dnsmasq.conf:dhcp-range=192.168.220.50,192.168.220.150,12h

You have some files in there that are not Pi-hole files and appear to be interfering with Pi-hole. Delete or move these:

sudo rm /etc/dnsmasq.conf.orig

sudo mv /etc/dnsmasq.d/custom-dnsmasq.conf /Documents

sudo mv /var/lib/misc/dnsmasq.leases /Documents

sudo service pihole-FTL restart

you are amazing thank you

Fixed now, I assume?

That is why your post is marked the solution but lighttpd also needed a restart because that is me main dns service
or something like that

also does pi-hole network bridge

Pi-hole answers DNS queries on the network(s) to which it is attached. If you have more than one interface on the Pi-hole and select listen on all interfaces in the DNS settings, it can respond to both.

Typically, any bridging of traffic between VLANs would be done by the VLAN controller.

I can’t figure out how to add my ethernet only computer to my raspi 4 with 1 eth port but a usb to eth

That is outside the scope of Pi-hole. I would check on a Raspberry Pi forum.

see though that isn’t my point
my point is how are you intended to use pihole meaning how do you get other devices to use the ad blocking

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.