Connecting my raspberry pi with my router

The issue I am facing:

My raspberry pi is not applying to my searches and opendns is not working according to

Details about my system:

I have my raspberry pi plugged into my router with eth0 set up. I have opendns selected under upstream DNS servers and the custom fields for ipv4 and ipv6 are empty.

I tried using the ip address in the URL for my admin console as the DNS server under the DNS Server as the DHCP server in my router. I also got the pi address from looking at nearby IP addresses and tried that too. In both cases, I'm not seeing my searches showing up under the query log and open dns does not appear to be connected. My internet still works though.

This is my debug log-

I've tried this with Connect to DNS server automatically set to true and with that setting set to false. I've also tried replacing the name servers with the ip address that's in the url when I log in to my pi hole admin console. I even tried turning off my DHCP server and, in every single attempt and configuration that I tried, the pi hole did not work.

I do not see any of my internet activity in the query log. Thanks!

I'll sum up the problem:

  1. My pi hole was working
  2. I deleted the ip address in the dhcp server settings in my router and maybe the WAN DNS settings
  1. Now my pi hole doesn't work and my attempts to fix it haven't worked

I think it's probably a simple fix, and would love help figuring it out.

If you're not using Pi-hole as DHCP, then the Pi-hole's IP address needs to be added under the LAN DNS settings in your router. If your router does not allow you to set this, then disable the DHCP server on your router and enable it on Pi-hole. Once this is done, you may need to disconnect your clients from the network and reconnect them for them to get addresses from the Pi-hole DHCP server.

1 Like

Your DNS servers IP is within the DHCP range - make sure you reserve this IP so it won't assigned to any other device.

Thanks! I did that and it didn't resolve the underlying issue. Good advice in either case!!

Try a step-by-step approach:

  1. leave OpenDNS aside for a moment and select any other upstream DNS in pihole
  2. set "WAN Connect DNS Server automatically" to no and enter your Pihole's IP (so also your router will use Pihole
  3. DHCP/Enable Manual Assigments -> Assign Piholes MAC with the IP to make a reservation (maybe a disconnect/reconnet is necessary)
1 Like

OK, I tried those three steps and then rebooted my pi hole and router.

None of my web activity appears in the query log and the blocks aren't working.

Try to ping your pihole from any network device.

What is the output from any device

dig pi.hole

1 Like

For pi hole --

; <<>> DiG 9.10.6 <<>> pi.hole
;; global options: +cmd
;; connection timed out; no servers could be reached

For flurry --

; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; connection timed out; no servers could be reached

It's working!! I set the pi hole to be the dhcp server and set my router to not be the dhcp server.

In case others see this thread, anyone care to explain why it wasn't working?

I thought it was working, but I was wrong. I still have internet access but the block isn't working.

What do you think we should try next? I feel like we've tried all the combinations with the router settings.

That's strange because the two dig commands didn't find any DNS server

Can you ping pihole's IP from any network device?

1 Like

Yep! I can run ping and I get back a response of packets

dig @
dig pi.hole @

1 Like

Both of those work for me

Do you see the requests in Pihole's log?

dig @ should have returned if blocked.

1 Like is the only request from my machine that appears in the query log.

It shows up as being blocked and I see, but I can visit from the same machine.

I strongly suspect the machine doesn't use pihole as DNS server, because if you force it, it is blocked. Try to dis/reconnect the device from the network to pickup the new DHCP information.

1 Like

I restarted and ran the DNS cache reset terminal command. Still not working. :frowning: