Connecting my raspberry pi with my router


What device is it? Windows? Linux?


Restart your router.

1 Like

It's the Mac Command killall -HUP mDNSResponder;sudo killall mDNSResponderHelper;sudo dscacheutil -flushcache I'll restart my router too

I don't have a mac,

let's see which DNS server your device is using.

cat /etc/resolv.conf

grep nameserver <(scutil --dns)

1 Like

nameserver[0] :
nameserver[1] :
nameserver[0] :
nameserver[1] :

If this is the output from the Mac, the Mac is not using Pi-hole for DNS. It is using Google DNS.

The client can use Pi-hole DNS, but if your browser is configured to use a different DNS (i.e. DNS over HTTPS, a "feature" in Firefox and Chrome), then the browser traffice won't use the same DNS as the client and will bypass Pi-hole.

1 Like

Is the RT-ACRH13 your only router in the network?

I found this, saying it hijacks DNS if in AP mode...

Great! Should I replace the DNS servers shown in my wifi Mac network settings?

Screen Shot 2020-07-01 at 11.08.26 AM

That fixed it!! :tada:

Yes, replace them with your pihole's IP.

Still wonder why the MAC doesn't use the DNS provided via DHCP....

What happens if you leave it empty there?

In case someone else stumbles upon this thread.

You should check these places:

  • Router DNS Settings
  • Pi Hole DNS Settings
  • Local Computer DNS Settings

If it's wrong in any one of these places, then the whole thing won't work.

That's what I did and I set configue ipv4 to Using DHCP

Glad it worked at the end.
Enjoy pihole.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.