Configure DNS at TP-LINK VR600


#1

I have normally set up the Pi-Hole nevertheless it seems not to work.
I have changed the Primary DNS through the web Interface.
I use TP-Link Archer VR600.
Actually there is an emulator of the web interface to help you understand better the steps I did.
https://www.tp-link.com/resources/simulator/VR600_Emulator/index.htm
I went to Network-> LAN Settings-> Primary DNS (there I inserted the Pi-Hole ip address)
Is that correct? Do I need anything else since it doesnt seem to work for me.

Thanks for the help.


#2

A few things to check.

  1. Have you verified that the Pi-Hole works from it’s host device? Assume you have it installed on a Pi, then ssh into the Pi linux terminal and run a few test DNS lookups. If the Pi-Hole is working, the commands below should return a blocked IP for the first command and a valid IP for the second command.

dig flurry.com

dig flurry.com @1.1.1.1

  1. What is the IP address of your router, and the static IP that you have assigned to the Pi-Hole?

  2. Have you tested Pi-Hole by manually assigning it’s IP address as DNS server on a client? This would point that client directly to the Pi-Hole, bypassing any router DNS.

  3. What do you have for secondary DNS on your router? It should either be blank or the IP address of the Pi-Hole (entered the same as in primary DNS).

  4. Are you using IPV6? If so, what are your IPV6 DNS settings?


#3

Yeah you have a newbie here. I have just followed letter by letter the instructions in the site.

  1. I have ssh into the Pi but do not know how to run DNS lookups.
    In the status* DNS active *FTL offline
    *Load: 0 0.01 0.02
    *Memory usage: 4.4 %
    The dashboard doesn’t show anything.
  2. I havent assigned any Static IP to Pi, it was created during installation.
  3. No I havent and I m not sure how to do it.
  4. The secondary DNS is 0.0.0.0
  5. RADVD

Sorry for the probably stupid answers.


#4

The “dig” command from the Linux terminal command line does this.

The purpose of a static IP is so that the Pi-Hole will always have the same IP address, then the router and/or clients can be mapped to a DNS address that doest’t change. In your router, you would find whatever IP address is used for the Pi-Hole now, and make that static (or reserved, depending on your router).

That should work as well.

It’s probably best if you upload your debug log and post the token here. Then we can look at your configuration and see if there is an evident problem.


#5

I found that the FTL engine is not installed…
I saw that the solution is that > edit /etc/resolv.conf and change from 127.0.0.1 to let’s say google’s 8.8.8.8 run a pihole -r and repair.
but i dont understand what I should do.


#6

That is correct. The command to edit the resolve.conf file is:

sudo nano /etc/resolv.conf

Make the changes and then save and exit, then run pihole -r and select repair.


#7

i run the command
how I make the changes??? oh I feel so old… :frowning:


#8

That is an old-school text editor. Scroll up/down/sideways to get to the line you want to edit. Backspace/delete the old information out, then type in the new.

CTRL-X at the bottom to save and exit. it will ask the file name, just hit enter there (same filename).


#9

it writes just this
# Generated by dhcpcd
# /etc/resolv.conf.head can replace this line
# /etc/resolv.conf.tail can replace this line


#10

I had an error in my reply - missing space (I have corrected the original reply).

The edit command is sudo nano /etc/resolv.conf

Here is a screen shot of what you should see when you run the editor:

image


#11

no mine is empty. just the bottom text.
Shall I write it and save it?


#12

It worked. Now we are back to problem No1 how to set up the DNS.


#13

Run a debug log and upload it, then post the token. Then we can look at your configuration.

If you cannot upload the log and get a token, paste the log into a comment and we’ll hide it.


#14

Your debug token is: 6lqn4rveki


#15

Quick note : It’s better to fill in the Pi-Hole IP 2 times instead of leaving the secondary DNS IP empty if possible, because some routers then send the secondary WAN DNS server IP to all your clients… VERY annoying! :angry:

If I were @john21gr I would simply edit the Pi’s network settings with a static IP and fill that in as both Primary and Secondary DNS IP at the LAN DNS settings.
Here is a tutorial on how to setup a Static IP for the Raspberry Pi => https://www.raspberrypi.org/learning/networking-lessons/rpi-static-ip-address/


#16

I have entered the the IP to both Primary and Secondary DNS in the router.
My devices are pretty much the same and that means that Pi has the same IP all the time. Nevertheless if needed to be done I will do it. (I have made the setup numerouns times to figure out what Im doing wrong and the PI always get the same IP.


#18

Good! :slight_smile:

Please do so and also add the IP as a Reserved IP in your router later on in case something goes wrong in the future :wink:


#19

The target is to work in the first place!!! :slight_smile:


#20

Everything looks normal in your debug log and the Pi-Hole is blocking domains.

Your Pi-Hole loopback address (127.0.0.1) is listed as the third DNS server for your Pi-Hole (from your debug log). Did you set it up this way (Admin GUI > settings > DNS)?


#22

Nope I havent changed anything. I do get some data in the dashboard I will make some check and see if it works or not…
Anyhow your support was great!!!