Can't connect to web interface (I have no idea what I'm doing)

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

[Being able to connect to the web interface and see it working]

Actual Behaviour:

[Every step of the way has been a problem, and I am currently 6 hours into trying to get it to work and still no luck. I can’t upload the debug, so I copied and pasted it. I am sorry if that doesn’t help, as I can’t use the web interface to load it correctly. I got all the way to configuring my router with primary DNS server being the pi zero w, and secondary being 8.8.8.8. So far, I haven’t been able to connect to the web interface, and have had several red errors in the debugs. Every tutorial I have seen or potential fix has led to another thing that doesn’t seem to be working. I am about to give up but giving this one last shot with you guys. This is my frist time doing any of this stuff, so I have no idea what I am doing clearly.]

Debug Token:

_[
*** [ DIAGNOSING ]: Core version
[i] Core: v3.3 (How do I update Pi-hole?)
[i] Branch: master
[i] Commit: v3.3-0-g1e87850

*** [ DIAGNOSING ]: Web version
[i] Web: v3.3 (How do I update Pi-hole?)
[i] Branch: master
[i] Commit: v3.3-0-ge48aa29

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v3.0 (How do I update Pi-hole?)

*** [ DIAGNOSING ]: dnsmasq version
[i] 2.72

*** [ DIAGNOSING ]: lighttpd version
[i] 1.4.35

*** [ DIAGNOSING ]: php version
[i] 5.6.33

*** [ DIAGNOSING ]: Operating system
[✓] Raspbian GNU/Linux 8 (jessie)

*** [ DIAGNOSING ]: SELinux
[i] SELinux not detected

*** [ DIAGNOSING ]: Processor
/opt/pihole/piholeDebug.sh: line 470: $’[\E[32m✓\E[0m] \E[32marmv6l\E[0m’: comma nd not found

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the wlan0 interface:
192.168.0.7/24 matches the IP found in /etc/pihole/setupVars.conf

[✓] IPv6 address(es) bound to the wlan0 interface:
fe80::ac5d:6d92:5f2f:e231 does not match the IP found in /etc/pihole/setupVar s.conf (Use IPv6 ULA addresses for Pi-hole)

^ Please note that you may have more than one IP address listed.
As long as one of them is green, and it matches what is in /etc/pihole/setupV ars.conf, there is no need for concern.

The link to the FAQ is for an issue that sometimes occurs when the IPv6 addre ss changes, which is why we check for it.

[i] Default IPv4 gateway: 192.168.0.1

  • Pinging 192.168.0.1…
    [✓] Gateway responded.

*** [ DIAGNOSING ]: Ports in use
[22] is in use by sshd
[80] is in use by lighttpd

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a k nown ad-serving domain
shuf: /etc/pihole/gravity.list: No such file or directory
dig: ‘’ is not a legal name (unexpected end of input)
[✗] Failed to resolve via localhost (127.0.0.1)
dig: ‘’ is not a legal name (unexpected end of input)
[✗] Failed to resolve via Pi-hole (192.168.0.7)
[✓] doubleclick.com is 172.217.2.78 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Pi-hole processes
[✗] dnsmasq daemon is failed
[✓] lighttpd daemon is active
[✗] pihole-FTL daemon is unknown

*** [ DIAGNOSING ]: Setup variables
PIHOLE_INTERFACE=wlan0
IPV4_ADDRESS=192.168.0.7/24
IPV6_ADDRESS=
PIHOLE_DNS_1=4.2.2.1
PIHOLE_DNS_2=4.2.2.2
QUERY_LOGGING=true
INSTALL_WEB=true
LIGHTTPD_ENABLED=1

*** [ DIAGNOSING ]: Dashboard and block page
[✗] X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Content-type: text/html; charset=UTF-8
Date: Fri, 16 Feb 2018 00:32:25 GMT
Server: lighttpd/1.4.35

[✓] X-Pi-hole: The Pi-hole Web interface is working!

*** [ DIAGNOSING ]: Gravity list
ls: cannot access /etc/pihole/gravity.list: No such file or directory

head: cannot open ‘/etc/pihole/gravity.list’ for reading: No such file or direct ory
-----head of gravity.list------

tail: cannot open ‘/etc/pihole/gravity.list’ for reading: No such file or direct ory
-----tail of gravity.list------

*** [ DIAGNOSING ]: contents of /etc/pihole

-rw-r–r-- 1 root root 234 Feb 15 05:04 /etc/pihole/logrotate
/var/log/pihole.log {
su root root
daily
copytruncate
rotate 5
compress
delaycompress
notifempty
nomail
}
/var/log/pihole-FTL.log {
su root root
weekly
copytruncate
rotate 3
compress
delaycompress
notifempty
nomail
}

*** [ DIAGNOSING ]: contents of /etc/dnsmasq.d

-rw-r–r-- 1 root root 1509 Feb 15 05:04 /etc/dnsmasq.d/01-pihole.conf
addn-hosts=/etc/pihole/gravity.list
addn-hosts=/etc/pihole/black.list
addn-hosts=/etc/pihole/local.list
localise-queries
no-resolv
cache-size=10000
log-queries=extra
log-facility=/var/log/pihole.log
local-ttl=2
log-async
server=4.2.2.1
server=4.2.2.2
interface=wlan0

*** [ DIAGNOSING ]: contents of /etc/lighttpd

-rw-r–r-- 1 root root 3027 Feb 15 05:04 /etc/lighttpd/lighttpd.conf
server.modules = (
“mod_access”,
“mod_accesslog”,
“mod_auth”,
“mod_expire”,
“mod_compress”,
“mod_redirect”,
“mod_setenv”,
“mod_rewrite”
)
server.document-root = "/var/www/html"
server.error-handler-404 = "pihole/index.php"
server.upload-dirs = ( “/var/cache/lighttpd/uploads” )
server.errorlog = "/var/log/lighttpd/error.log"
server.pid-file = "/var/run/lighttpd.pid"
server.username = "www-data"
server.groupname = "www-data"
server.port = 80
accesslog.filename = "/var/log/lighttpd/access.log"
accesslog.format = "%{%s}t|%V|%r|%s|%b"
index-file.names = ( “index.php”, “index.html”, “index.lighttpd.ht ml” )
url.access-deny = ( “~”, “.inc”, “.md”, “.yml”, “.ini” )
static-file.exclude-extensions = ( “.php”, “.pl”, “.fcgi” )
compress.cache-dir = "/var/cache/lighttpd/compress/"
compress.filetype = ( “application/javascript”, “text/css”, “text/h tml”, “text/plain” )
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell “find /etc/lighttpd/conf-enabled -name ‘*.conf’ -a ! -name ‘let sencrypt.conf’ -printf ‘include “%p”
’ 2>/dev/null”
$HTTP[“url”] =~ “^/admin/” {

   setenv.add-response-header = (
       "X-Pi-hole" => "The Pi-hole Web interface is working!",
       "X-Frame-Options" => "DENY"
   )
   $HTTP["url"] =~ ".ttf$" {

       setenv.add-response-header = ( "Access-Control-Allow-Origin" => "*" )
   }

}
$HTTP[“url”] =~ “^/admin/.(.*)” {
url.access-deny = ("")
}
include_shell “cat external.conf 2>/dev/null”

*** [ DIAGNOSING ]: contents of /etc/cron.d

-rw-r–r-- 1 root root 1496 Feb 15 05:04 /etc/cron.d/pihole
31 4 * * 7 root PATH="$PATH:/usr/local/bin/" pihole updateGravity
00 00 * * * root PATH="$PATH:/usr/local/bin/" pihole flush once quiet
@reboot root /usr/sbin/logrotate /etc/pihole/logrotate
*/10 * * * * root PATH="$PATH:/usr/local/bin/" pihole updatechecker loc al
11 19 * * * root PATH="$PATH:/usr/local/bin/" pihole updatechecker remo te
@reboot root PATH="$PATH:/usr/local/bin/" pihole updatechecker remote rebo ot

*** [ DIAGNOSING ]: contents of /var/log/lighttpd

-rw-r–r-- 1 www-data www-data 291 Feb 16 00:21 /var/log/lighttpd/error.log
2018-02-15 05:03:54: (log.c.164) server started
2018-02-15 05:21:55: (server.c.1558) server stopped by UID = 0 PID = 1
2018-02-15 05:22:09: (log.c.164) server started
2018-02-16 00:21:33: (server.c.1558) server stopped by UID = 0 PID = 1
2018-02-16 00:21:47: (log.c.164) server started

*** [ DIAGNOSING ]: contents of /var/log

*** [ DIAGNOSING ]: Pi-hole log
-rw-r–r-- 1 dnsmasq root 0 Feb 15 05:04 /var/log/pihole.log
]_

0 Likes

#2

I have also heard something about making it a gateway, but I have no idea how to do that. I also don’t have static IPs for everything on the network. The PI zero w is static, and I am not sure if that is maybe messing things up. I also couldn’t connect to github for an FTL update that failed to load. I am currently at that step but cannot figure that out. I did this headless as well.

0 Likes

#3

[✗] Job for dnsmasq.service failed. See ‘systemctl status dnsmasq.service’ and ‘journalctl -xn’ for details.
pihole-FTL: no process found

[✗] DNS service is NOT running

Here is what it says in regard to the FTL thing.

0 Likes

#4

Are you able to update Jessie to Stretch ? Or maybe easier reinstall with Stretch ?

Or else read this:

0 Likes

#5

I initially used the stretch, but I couldn’t get to the point where I am currently at with it. I don’t believe I was able to Putty into it with stretch. However after learning some stuff I will retry it since I was most likely doing things wrong. I looked on some forums and heard that the Jessie was better for the pi zero w. My friend was successful doing his by setting everything up in a pi3 (so he didn’t have to headless), then placing it into the Pi zero W to ssh the batch onto it. I will give you an update this evening hopefully.

0 Likes

#6

The “sshd” daemon is not started default at boot with Raspbian Stretch like it does with Jessie (see point 2):

0 Likes

#7

I appreciate the help. I was trying to do headless, and just couldn’t figure it out, so I had my friend help me. I ended up putting the Mirco sd into my pi3 just so I didn’t have to buy a new keyboard, and was able to do it not headless. I ended up formatting the micro sd and using stretch. Through the pi3 I was able to switch the settings to wlan0 and make sure the ip settings were correct. Reinstalled with a fresh pihole and eventually after another few hours got it working. It turns out in the wpa_supplicant.conf file, I was missing the four command lines above the ssid info, i.e. the country=US etc. stuff. That was what was causing my problem with connecting at home. My router was also reassigning the pi the reserved ip it gave it originally. So matter what I was changing it too, I could never putty or admin in because it kept switching to default. It was an absolute cluster but it works now and I am happy. The next step is figuring out how to get correct stats on the web interface instead of showing localhost for half of them.

0 Likes

closed #8

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes