Beaglebone - ads not being blocked (I searched the forums!)


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Ads are blocked on my client devices.

Actual Behaviour:

Ads are not blocked on my client devices

Debug Token:

[✓] Your debug token is: ize4m9wiow

Hi guys, I searched through several help posts about this topic but I haven’t found a solution yet. PiHole is definitely running on my BeagleBone Black, it’s address is reserved in my router’s DHCP settings and the only DNS server defined in the router DHCP/DNS settings is the IP of the Beaglebone.

I have released and renewed the IP of my laptop, and that did not help, though the IP address remains the same.

Any ideas? Thanks!


#2

Did you check on your laptop if ipconfig /all shows the correct DNS IP?


#3

I’m on OSX, so that ipconfig command doesn’t work on my machine. I tried setting the DNS server as my Pi-hole in the WiFi preferences, but still I get ads.

I’m also have Avast anti-virus installed, but I saw no difference after disabling both the web-shield and email-shield.

I’m running a Linksys WRT1900ACS and have set one DNS entry there, pointing to the pi-hole.

=]


#4

Your debug log shows why your Pi-Hole is not working. In Version 4.0 of Pi-Hole, which you are running, dnsmasq is included in pihole-FTL, and dnsmasq does not run as a separate process. Your debug log shows the ports in use and dnsmasq is running.

*** [ DIAGNOSING ]: Ports in use
*:3000 systemd (IPv6)
*:1880 systemd (IPv6)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:8080 apache2 (IPv6)
*:8080 apache2 (IPv6)
*:8080 apache2 (IPv6)
*:80 lighttpd (IPv4)
*:80 lighttpd (IPv6)
*:53 dnsmasq (IPv4)
*:53 dnsmasq (IPv6)

The fix is to stop and disable dnsmasq and start pihole-FTL

sudo service dnsmasq stop
sudo service dnsmasq disable
sudo service pihole-FTL restart

#5

Thanks for the suggestions!

The second command doesn’t like the ‘disable’ option:

debian@beaglebone:~$ sudo service dnsmasq disable
Usage: /etc/init.d/dnsmasq {start|stop|restart|force-reload|dump-stats|status}

but substituting ‘stop’ for ‘disable’ seemed to execute fine. And now:

debian@beaglebone:~$ pihole status
[✗] DNS service is NOT running

I still get ads as far as https://blockads.fivefilters.org/index.html is concerned!

What else might I try?


#6

Run a new debug log and post the token.


#7

New log here!:

[✓] Your debug token is: 6bfbc4xw46


#8

dnsmasq is no longer on port 53, but neither is pihole-FTL.

*** [ DIAGNOSING ]: Ports in use
*:3000 systemd (IPv6)
*:1880 systemd (IPv6)
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:8080 apache2 (IPv6)
*:8080 apache2 (IPv6)
*:8080 apache2 (IPv6)
*:80 lighttpd (IPv4)
*:80 lighttpd (IPv6)

Try removing dnsmasq (so no chance it can interfere) and then restart pihole-FTL:

sudo apt remove dnsmasq

If that doesn’t resolve it, then run pihole -r and select “repair”


#9

The correct command should have been:

sudo systemctl disable dnsmasq

#10

Hi again, thanks for your continued support.

I removed dnsmasq, ran pihole repair and rebooted the machine. Pihole still says it’s not running. New debug log here:

[✓] Your debug token is: t1g9a1nhyf

For what it’s worth, I’m running the latest standard Beaglebone image.

=]


#11

One more thing: when I run repair, or after the install procedure, I have to comment a line ina config file:

dnsmasq: illegal repeated keyword at line 35 of /etc/dnsmasq.d/01-pihole.conf:

#cache-size=10000

That solved the DNS issue a while back but no longer.


#12

Check your /etc/dnsmasq.conf file. There should be only one kine pointing to the /etc/dnsmasq.d… directory.


#13

And check for alien dnsmasq config files not belonging to Pi-hole:

sudo grep -v '#\|^$' -R /etc/dnsmasq.*


#14

Here’s what I see in /etc/dnsmasq.conf:

# Include another lot of configuration options.
#conf-file=/etc/dnsmasq.more.conf
conf-dir=/etc/dnsmasq.d

# Include all the files in a directory except those ending in .bak
#conf-dir=/etc/dnsmasq.d,.bak

# Include all files in a directory which end in .conf
#conf-dir=/etc/dnsmasq.d/,*.conf

The alien check shows this:

/etc/dnsmasq.conf:conf-dir=/etc/dnsmasq.d
/etc/dnsmasq.d/SoftAp0:interface=usb0
/etc/dnsmasq.d/SoftAp0:interface=usb1
/etc/dnsmasq.d/SoftAp0:port=53
/etc/dnsmasq.d/SoftAp0:dhcp-authoritative
/etc/dnsmasq.d/SoftAp0:domain-needed
/etc/dnsmasq.d/SoftAp0:bogus-priv
/etc/dnsmasq.d/SoftAp0:expand-hosts
/etc/dnsmasq.d/SoftAp0:cache-size=2048
/etc/dnsmasq.d/SoftAp0:dhcp-range=usb0,192.168.7.1,192.168.7.1,2m
/etc/dnsmasq.d/SoftAp0:dhcp-range=usb1,192.168.6.1,192.168.6.1,2m
/etc/dnsmasq.d/SoftAp0:listen-address=127.0.0.1
/etc/dnsmasq.d/SoftAp0:listen-address=192.168.7.2
/etc/dnsmasq.d/SoftAp0:listen-address=192.168.6.2
/etc/dnsmasq.d/SoftAp0:dhcp-option=usb0,3
/etc/dnsmasq.d/SoftAp0:dhcp-option=usb0,6
/etc/dnsmasq.d/SoftAp0:dhcp-option=usb1,3
/etc/dnsmasq.d/SoftAp0:dhcp-option=usb1,6
/etc/dnsmasq.d/SoftAp0:dhcp-leasefile=/var/run/dnsmasq.leases
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/gravity.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/black.list
/etc/dnsmasq.d/01-pihole.conf:addn-hosts=/etc/pihole/local.list
/etc/dnsmasq.d/01-pihole.conf:localise-queries
/etc/dnsmasq.d/01-pihole.conf:no-resolv
/etc/dnsmasq.d/01-pihole.conf:log-queries=extra
/etc/dnsmasq.d/01-pihole.conf:log-facility=/var/log/pihole.log
/etc/dnsmasq.d/01-pihole.conf:local-ttl=2
/etc/dnsmasq.d/01-pihole.conf:log-async
/etc/dnsmasq.d/01-pihole.conf:server=8.8.8.8
/etc/dnsmasq.d/01-pihole.conf:server=8.8.4.4
/etc/dnsmasq.d/01-pihole.conf:interface=eth0

What does this mean?

=]


#15

Move that alien SoftAp0 file to your home folder:

sudo mv /etc/dnsmasq.d/SoftAp0 ~

Restart:

sudo service pihole-FTL restart

Check status:

sudo service pihole-FTL status -l

pihole status

And try do a DNS lookup:

host pi.hole localhost


#16

Hi guys,

pihole-FTL status check shows:

ebian@beaglebone:~$ sudo service pihole-FTL status -l
● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
   Active: active (exited) since Sun 2018-11-25 23:01:31 UTC; 5s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3178 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUCCESS)
  Process: 3184 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

Nov 25 23:01:30 beaglebone systemd[1]: Starting LSB: pihole-FTL daemon...
Nov 25 23:01:30 beaglebone pihole-FTL[3184]: Not running
Nov 25 23:01:30 beaglebone pihole-FTL[3184]: chown: cannot access '/etc/pihole/dhcp.lea
Nov 25 23:01:30 beaglebone su[3207]: Successful su for pihole by root
Nov 25 23:01:30 beaglebone su[3207]: + ??? root:pihole
Nov 25 23:01:30 beaglebone su[3207]: pam_unix(su:session): session opened for user piho
Nov 25 23:01:31 beaglebone pihole-FTL[3184]: FTL started!
Nov 25 23:01:31 beaglebone systemd[1]: Started LSB: pihole-FTL daemon.

pihols status check shows:

debian@beaglebone:~$ pihole status
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled

DNS lookup check shows:

ebian@beaglebone:~$ host pi.hole localhost
Using domain server:
Name: localhost
Address: ::1#53
Aliases:

pi.hole has address
pi.hole has IPv6 address <probably correct IP, IPv6 is weird to me>

I’ll go point my router back to the pihole, brb…


#17

Dont point your router WAN DNS … do this pushing Pi-hole’s IP to the clients for DNS via DHCP:


#18

backpain-1292835351

It works! Man, what an ordeal. Seems to me the problem was the SoftAP definition for dnsmasq?

Thanks a ton!


#19

That and the dnsmasq daemon still running.

Cheers!!!


#20

Ah, yep that’s what I meant - I added the pi-hole to my router’s DHCP DNS settings.