Banking.postbank.de/rai/login is not working


#1

https://banking.postbank.de/rai/login is not working and i can not find the problem. banking.postbank.de is on the whitelist. in the query log nothing with postbank is red. with vpn it is working.
any idea?


Pihole blocking whitelisted domain/none blocked domain
#2

When loading that page, DNSThingy shows the following domains trying to load. Check that www.postbank.de is not on a block list as well.

banking.postbank.de
www.postbank.de
ajax.googleapis.com

#3

i put all urls in the whitelist, but it is not working. is it working when you test the url?


#4

Yes.

The domain was found in one blocklist on my setup (you will likely be running different lists), but since it wasn’t the exact domain I was able to load the page:

$ pihole -q postbank.de
 Match found in list.42.hosts-file.net.domains:
   postbank.de.kundenkonto-postbank-6756370708-postbank.ru
   www.postbank.de.kundenkonto-postbank-6756370708-postbank.ru

#5

ok, big thxs.

on my site postbank.de is only found in the whitelist.

now i think the problem is not the pi-hole. perhaps my isp


#6

Whitelist does not cover regex.list and wildcard.

Secondly you state Postbank.de is on the whitelist… what about www.postbank.de?

@jfb maybe if a bare domain.tld is added also add the subdomain www also. The user can delete it if it is not wanted.
It seems too confusing for users that webpages can also have a subdomain.

Maybe also add a example of a URL with bold the sub-domain as the domain part as an example on the entry page of lists.


#7

What is Google doing at the entry page of your banking page. I hope the logging page is only between you and posbank.de?

If not go to an other bank that respects your privacy during banking.

Update: I have now used noscript to look at the page. I only see postbank.de and no Google domains. On the login page for banking with Postbank.de WebGL is active, I don’t like that and they use WebGL.


#8

both are on the whitelist. when i enter the on the whitelist: banking.postbank.de/rai/login

Failure! Something went wrong.
banking.postbank.de/rai/login is not a valid domain


#9

Domain is everything before the “/”, everything behind that, including the “/”, is of no interest to pihole.

The domain/subdomain sits between “…://” and “/…”


#10

hey, i’m having the same problem and i dont get how to fix it… I’ve tried this but it doesnt work:

Should i just open the list and delete the links or how to get it work?

/e: I don understand why postbank.de is blocked because of a domain called “postbank.de.kundenkonto-postbank-6756370708-postbank.ru” … postbank.de is not kundenkonto-postbank-6756370708-postbank.ru … Is it a bug?


#11

Matching the correct domain is not always easy so the results of the query you can ignore.

On which version of Pi-hole are you? If you are using 4.0 do you used regex domains? I don’t think so and then is the question have you any wildmark domains active.

If don’t now the what those are then you are most probably using the single list and then whitelisting should work.


#12

hey, thanks for your reply.
I’ve updated Pi-hole to the newest version (Pi-hole Version v4.0, Web Interface Version v4.0, FTL Version v4.0) and I haven’t used any regex domains or wildmark domains. I’ve just added some lists to the pi-hole, otherwise its pretty much default settings…

So you say i should whitelist “postbank.de.kundenkonto-postbank-6756370708-postbank.ru” ?? :>

/e: I’ve only added lists from https://firebog.net/


#13

I Don’t know how granular Pi-hole in the gravity.list and whitelist.

You could test it for yourself by indeed whitelisting that bad domain and then try to visit postbank.de and if that not helps than remove the bad domain again from whitelist.


#14

with adding

postbank.de.kundenkonto-postbank-6756370708-postbank.ru

to the whitelist all is working. thxs


#15

Question to the developers, this behavior of matching a subdomain part as domain Seems to be standard when using gravity.list hashed.

How restrictive is then the domain whitelisting and so do not also whitelists subdomains present in clever formed URL’s?


#16

gravity.list, the blacklist, and the whitelist only affect the exact domains that appear on those lists.


#17

hey,

sorry… but i dont get this… even if i whitelist the scammer URL as said by don_misu & msatter. It does not load the webpage for me. Also from what Mcat12 has written i take that the url “http://postbank.de.kundenkonto-postbank-6756370708-postbank.ru” which seems to be on the “gravity.list” should not block postbank.de … but it does block it… I’ve tested this on three devices… (PC, MAC and iphone)

I guess I’ve tried everything… restarted DNS, deleted local cache… even added this scamm URL to the whitelist but it still refuses to load the page…

here is my debug token: 3ljku23is6

for now… i just have to change DNS server if i want to do some online banking…

/e: added debug token


#18

OK try it for myself. I looked up an ".de." domain in gravity.list and there was several for amazon.de and for example amazon.de.24-konto-8nm-amazon-zum.ru
I checked with Tools - Query Lists if amazon.de is found. When I looked for a partial match I got a long list. When searched with exact match it did not found it.

So my previous assumption that it would also match the BAD domain is wrong. I am now on the development version and I have to check out if this behaviour is also present in the current 4.0 version…one moment booting an second RasberryPI… yes the behaviour is the same and so working correctly.

So why you are having this problem is a mystery to me. It works for me so there must be an other explantation for this.

If Pi-hole blocks postbank.de what it the status in the Query Log page?

If lookup the domains with nslookup what are the IP given back to you:

nslookup postbank.de
nslookup www.postbank.de
nslookup banking.postbank.de
nslookup meine.postbank.de

#19

sorry, it is not ok on my side. on my test i forgot the running vpn.

postbank.de is working but not

banking.postbank.de
meine.postbank.de


#20

postbank.de.kundenkonto-postbank-6756370708-postbank.ru != postbank.de

Did you whitelist the first domain, or the second? They are not the same domain.