Ads galore on devices after installing. Is this to be expected? Does it need to run a few days?

That would be both from the device and the router.

On you Windows Computer see if you have an IPV6 IP either by running ipconfig /all via cmd or by looking at your network properties under Settings.

Not at all.

The only problem is that it's adding an additional possible point of failure within the whole network.topology as in "another thing that can fail".

Not this one as this is an ADSL modem (old school, phone line dependent).

You would need another router that has a WAN port (where you would connect a LAN port from the Modem/Router combo).

It does take a bit of configuration though as you would have to disable the wireless in your Netgear too (or leave it on with different name and password - but if you can disable it, disable it as it will be less noise on the 2.4 and 5 ghz ).

You next cascaded device would become the primary device to serve all the network.


With a $300 device using it as a bridge ... you'd be better off selling it or returning it and using the combo i was talking about here ...

I might look into getting the SB8200. It is on the Cox certified to work list. My only concern, and it is because it is my friends concern ( i know nothing about this stuff), is that it isn't my current netgear that is the problem but that it is my ISP (CoX) causing the problem. When deHakkelaar said above

"You’ve got IPv6 support upstream and the router is configured to auto assign a bunch on the clients via IPv6 auto discovery (IPv6 address, IPv6 gateway, IPv6 DNS server(s) etc)."

He said the router is configured to auto assign stuff. I'm assuming that is the firmware doing this. And if i got a different router whatever firmware CoX puts on it will do the same thing. Inside ipconfig /all there is a line that says

Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2600:8801:2288:a000:e12b:

My friend from what i can tell thinks i can't change any of that and that i might be able to configure the Pi around it. He said he is pretty sure there is a way to get Pi to work with IPv6 its just that everyone i run into has no knowledge of configuring IPv6. He works for an IP in Sweden and said they don't even use IPv6.

I don't think IPV6 is relevant here at all once disabled. As I said, I don't use IPV6 and I don't worry about it.

While, in a Windows environment IPV6 is preferred over IPV4, if the IPV6 DNS is set automatically by the router (as self IPV6 DNS - the router IPV6 that is) then yes, everything that is queried via the IPV6 NON Pi-hole DNS, will let ads through.

It works out of the box, you just need to make sure it retains the same IPV6 IP and it's properly set-up in the Pi-hole settings.

Also if you chose to use IPV6, you need to set that IPV6 IP of Pi-hole as your IPV6 IP on the Router.

Tangled ...

But how do i disable it? Everywhere i see in my router or in that windows network window in settings it is disabled already or the only option is to set as auto or manual


Id love to just not mess with it at all

If you're missing the Advanced/Advanced Setup/IPV6 option (where you can literally disable it) then I don't know wher eit could be as I don't have that negear device.

In windows, is a lot simpler to disable it, Just go to the properties of the network adapter and remove/uncheck IPV6.


If there is no IPv6 solution for this type of modem, try enable below option:


But dont enable below one:


And let Pi-hole take over DHCP for your network:

Copy IP range and gateway from the router DHCP settings over to Pi-hole.
Release DHCP lease on the Win PC:

ipconfig /release

And renew:

ipconfig /renew

And check DNS servers assigned:

ipconfig /all

EDIT: ow is better to enable Pi-hole DHCP first before disabling the router DHCP!
EDIT2: ow and disable as many IPv6 settings on the LAN side as possible (dont touch the WAN/Internet settings) !

Wow man..... i think this worked. I went to speedtest.not and no adds popped up and my Pihole is going crazy! Before i unchecked that box the % blocked was at 3% and its already at 23.4%. So by doing this does that mean sites that are using IPv6 are not accessible? This is cool seeing the Pi blocking! Just have to confirm later it is working on my mobile as well!


1 Like

Yes. That is correct, however I wouldn't concern over that issue right now as we're still rocking them IPV4s more than we do IPV6s, and the domains that are on IPV6 are definitely on IPV4 too.

To make my point: will not load any more (unless IPV6 support is active and working).

That might be a bit more tricky as I don't think you can disable IPV6 on the phone :slight_smile:

I got this far and ran into this

Not sure what the ethernet 2 is. I have vpn nord but it is disabled. Has been a few days because i thought it was causing me a problem too so i just left it off

No worries.
Just as long as you see IP details (IP address/DHCP/DNS server) for the main "Ethernet" interface when running ipconfig /all

... after ipconfig /renew to get a new DHCP lease.

Ok cool. I did ipconfig /all and i see my IPv4 address, i see my DNS server (my Pi) and the line that says DHCP Enabled it says No. That sounds right?

C:\>ipconfig /all | findstr "Server"
   DHCP Server . . . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :


C:\>nslookup pi.hole

Name:    pi.hole

pie 2

Looks good.
Is that with everything IPv4 and IPv6 related settings on the Win PC set to auto ?
Enable IPv6 again on the win pc but set everything to auto.

EDIT: missing a DHCP server line though thats a bit strange if Pi-hole does DHCP now.

No In IPv4 i have it set to manual and i entered the Pi IP in the DSN section and filled in the gateway and ip address. I deactivated the IPv6 by right clicking network and going to properties and clicking the IPv6 tab to deactivate it.


And make sure IPv4 settings are set to auto as well.

Ps. with that last screenshot you again changed "Server" into the IP!
Cant see DHCP server that way.

ipconfig /all | findstr "Server"

took a while to respond because when i changed back to auto and engaged IPv6 the internet dumped on me. this site error kept coming up that the site was corrupted and wouldnt let me send message. Then i lost all internet so i changed back to manual in windows and turned IPv6 off again in network properties and restarted PC and router.

you want me to type server? nothing happens. Im going to feel real dumb if theres an actual server address im supposed to put there lol

Pi hole is definitely all over the PC now. blocking a ton of things. Not my mobile though

ipconfig /all | findstr "Server"

The capital S !
Small details :wink:

I dont know.
If you cant get Pi-hole to do DHCP for your network, it seems getting another router is the only solution.
But dont give up yet.
Maybe someone tags along that can help you with that type of router.

haha well this has gotten me a lot farther than i was yesterday. Pi's at 30% blocked. I can see it is recognizing my TV because there are a lot of red Samsungads,com lines buzzing up. Just not my mobile. but i will keep messing with it and like you said maybe someone with the same problem figures it out too.
Thanks for the help!

server 2

1 Like

I think your router is set to use your ISPs DNS. Might try selecting "Use These DNS Servers" and put your PIHole IP into the boxes on the right