Ads galore on devices after installing. Is this to be expected? Does it need to run a few days?

Please follow the below template, it will help us to help you!

Expected Behaviour:

[From my understanding I should be able to not see adds on devices like my samsung tv and pc as well as my mobile device. I have read adds will still appear on apps like Instagram and that YouTube is hard to get rid of them. ]

Actual Behaviour:

[ An update from my reddit post. I finally was able to clean install Pi-hole. I chose to activate DHCP in Pi-hole and deactivated it in my router(as it instructed). So far in the networks tab in pi hole console i can see all the devices. Which is farther than i have gotten before. But i still see adds all on devices. On my main PC just searching something in duckduckgo i get an ad as the first search result. As well as an add on the right column. On my mobile i get adds on every website and inside my crossword app game. I have gone in each device and changed the ip addresses to the ones associated with each device and added the Pi ip address in the DNS section of each device as well as the correct gateway address. ]

Debug Token:

https://tricorder.pi-hole.net/4rlhi06gx7

Thank you with helping

Kenny

As you’ve posted in below thread as well, did you run the checks on the clients that I mention ?
Can you post outcome here ?

Everyone sees those.
If you click on them, Pi-hole should be blocking them (most of the times).

You don’t appear to have much DNS traffic to the Pi-Hole, and it’s likely that some of your clients are not using Pi-Hole for DNS. From your debug log:

  [2020-02-23 14:44:30.011 11882] Imported 136 queries from the long-term database
   [2020-02-23 14:44:30.012 11882]  -> Total DNS queries: 136
   [2020-02-23 14:44:30.012 11882]  -> Cached DNS queries: 14
   [2020-02-23 14:44:30.012 11882]  -> Forwarded DNS queries: 116
   [2020-02-23 14:44:30.012 11882]  -> Exactly blocked DNS queries: 4
   [2020-02-23 14:44:30.012 11882]  -> Unknown DNS queries: 2
   [2020-02-23 14:44:30.012 11882]  -> Unique domains: 36
   [2020-02-23 14:44:30.012 11882]  -> Unique clients: 3
   [2020-02-23 14:44:30.012 11882]  -> Known forward destinations: 2

Wow haha maybe i just have the wrong idea of what exactly the Pi hole is supposed to be doing. But i find it completely useless if it can’t even block those basic adds on duck duck when any browser extension can do that. Seems like a pretty basic task. But it is confusing because the entire model and any one speaking about the Pihole is literally ad blocking. If Pihole can’t block that simple add you circled im confused about what exactly the point of this all is. I just turned on Ghostery i have no ads on any site ever. not even in youtube. But i might have played up this whole ad blocking in my head to an extreme or something

I ran that command from your other post, that is my pi ip. pie

I think i made that token just a bit after installing Pi so maybe there wasn’t much activity. But i know my devices are not going through the Pi because when i go on a site on my pc i’m looking over at the Pi monitor and nothings happening. If i go to cars.com on my PC there is nothing on Pi hole popping up as cars.com. Same as my mobile. I get a lot of samsung queries but i still have a samsung ad in the menu section at the bottom left of the TV.

I tried understanding that link you sent about knowing what is an add but i don’t feel like it helps at all. I don’t use chrome so i don’t have access to that extension and i don’t use tor browser that something suggested at the bottom. Watching the query box does me no good if the sites I’m going to aren’t popping up there.

Here is what i have on the Pi right now. Most of the queries are Samsung, and the majority are bitdefender

uBlock Orgin.

! 2/25/2020 https://duckduckgo.com
duckduckgo.com###ra-0 > .links_deep.links_main.result__body

This will cut it out of the page.

This is a strong indicator that not all your DNS traffic is going to Pi-Hole. Use the tools in the link I provided and load the duckduck site while you tail the Pi-Hole log. You should see requests for all domains that AdamOne Assistant shows. If not, then some of the DNS traffic is bypassing Pi-hole an is not being filtered.

@jfb beat me to it again but as I typed up below anyway:

https://docs.pi-hole.net/

Ads, and other unwanted content, most of the times come from domains other than the one you are browsing to.
So Pi-hole looks up all the domains your browser is requesting against its own blocklists configured below:

http://pi.hole/admin/settings.php?tab=blocklists

If the domain is on any of the blocklists, it returns IP 0.0.0.0 to the browser client (or any app doing DNS queries).
If the domain isn’t on the blocklists, Pi-hole forwards the “domain name to IP” query to its upstream configured DNS servers below:

http://pi.hole/admin/settings.php?tab=dns

The answer from upstream is returned to the browser client.
This is very effective for most of the ads/trackers/mallware/cryptominers etc but not all.

EDIT:
Ps. That ipconfig output looks good.
Ipconfig output is wrong.
You should run exactly (copy/paste):

ipconfig /all | findstr "Server"

So do you have another example on the PC where you suspect Pi-hole isn’t doing whats expected ?
You can copy/paste screengrab/shot directly in here.

You can see the DNS queries live coming from your client below:

http://pi.hole/admin/taillog.php

TV’s are a bit hard to diagnose as you dont know for sure how DNS is implemented.
Power cycle the TV anyway (disconnect and reconnect power).

EDIT: changed some “ipconfig”

Yes i had that window open. It is always open on my Pi monitor

http://pi.hole/admin/taillog.php

Right next to it is my PC monitor. So when i am on my PC and go to websites nothing shows in the quaries related to what im actually doing on the PC. Or my laptop, or either one of my mobiles. If i am on reddit.com there is nothing showing in the Pi that i am going to reddit.com

I can however visit websites on the actual Pi and it works. I get no ads in duckduckgo. i get no adds on speedtest.net hell it wont even let me open facebook or instagram on the Pi unless i agree to Whitelist them and put the password in. So i am assuming it is installed correctly. There is something not correct between the Pi and my Router i feel. The only thing ive ever seen in the taillog that comes from the PC is bitdefender. but as far as web browsing. Nothing.

here is that commanded you asked for. Not sure what those numbers are i can’t link them with anything in my router devices.

I’m under the impression that ALL DNS traffic is bypassing the Pi haha. Is there an equivalent for firefox for that AdamOne extension?

Not that I know of. I keep a copy of Chrome just to run that extension.

Post screenshots of all your DHCP and DNS related settings on your router plus make/model ?
If that IPv6 address from ipconfig /all isn’t Pi-hole, DNS queries get bypassed somehow.

EDIT: ow and check if your ISP supports IPv6 upstream:

https://test-ipv6.com/

Mine doesn’t:

image

OK here you go. And thanks for helping. Netgear c7800 firmware 3.01.38




You’ve got IPv6 support upstream and the router is configured to auto assign a bunch on the clients via IPv6 auto discovery (IPv6 address, IPv6 gateway, IPv6 DNS server(s) etc).
Am not proficient enough with IPv6 to give you a good configure advice … wait for someone who does.
And have a read here as well:

OK thanks anyways. Hopefully someone has some knowledge of what i need to adjust.

I personally have IPV6 support disabled. One less thing to care about and set-up.

I do believe that the issue is the router’s firmware that even if it allows you to put internal (private) IP as the DNS, it will not route and allow that.

Unfortunately this seem that (and only due to) the firmware is the culprit here.

As I see it, there are 2 options here.

Either go the cascading route where you add another router AFTER the Netgear (and use that as your network node) or replace it for a standalone Modem and a Router …

I don’t know if there is a DDWRT or OpenWRT out there for your model, but that might be worth looking into as THAT firmware would give you the much needed freedom to make it work.

1 Like

I don’t even know where to turn off the IPv6. The only place i see that word in the router has a couple options for it and they are all already unchecked. In my windows settings the IPv6 has always been turned off.

ipv6

You mentioned cascading route… is that difficult? I actually have the old modem/router from Century link i bought flat out instead of leasing from them where i used to live. It’s just sitting on a shelf. It is an ActionTec C1000A. Would that be something i can use?

That would be both from the device and the router.

On you Windows Computer see if you have an IPV6 IP either by running ipconfig /all via cmd or by looking at your network properties under Settings.

Not at all.

The only problem is that it’s adding an additional possible point of failure within the whole network.topology as in “another thing that can fail”.

Nope.
Not this one as this is an ADSL modem (old school, phone line dependent).

You would need another router that has a WAN port (where you would connect a LAN port from the Modem/Router combo).

It does take a bit of configuration though as you would have to disable the wireless in your Netgear too (or leave it on with different name and password - but if you can disable it, disable it as it will be less noise on the 2.4 and 5 ghz ).

You next cascaded device would become the primary device to serve all the network.

BUT !

With a $300 device using it as a bridge … you’d be better off selling it or returning it and using the combo i was talking about here …

I might look into getting the SB8200. It is on the Cox certified to work list. My only concern, and it is because it is my friends concern ( i know nothing about this stuff), is that it isn’t my current netgear that is the problem but that it is my ISP (CoX) causing the problem. When deHakkelaar said above

“You’ve got IPv6 support upstream and the router is configured to auto assign a bunch on the clients via IPv6 auto discovery (IPv6 address, IPv6 gateway, IPv6 DNS server(s) etc).”

He said the router is configured to auto assign stuff. I’m assuming that is the firmware doing this. And if i got a different router whatever firmware CoX puts on it will do the same thing. Inside ipconfig /all there is a line that says

Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2600:8801:2288:a000:e12b:

My friend from what i can tell thinks i can’t change any of that and that i might be able to configure the Pi around it. He said he is pretty sure there is a way to get Pi to work with IPv6 its just that everyone i run into has no knowledge of configuring IPv6. He works for an IP in Sweden and said they don’t even use IPv6.

I don’t think IPV6 is relevant here at all once disabled. As I said, I don’t use IPV6 and I don’t worry about it.

While, in a Windows environment IPV6 is preferred over IPV4, if the IPV6 DNS is set automatically by the router (as self IPV6 DNS - the router IPV6 that is) then yes, everything that is queried via the IPV6 NON Pi-hole DNS, will let ads through.

It works out of the box, you just need to make sure it retains the same IPV6 IP and it’s properly set-up in the Pi-hole settings.

Also if you chose to use IPV6, you need to set that IPV6 IP of Pi-hole as your IPV6 IP on the Router.

Tangled …