Why do I see ads in Chome but not other browsers?


#1

It has been reported that Pi-hole is not blocking some Google ads when using Chrome but not other browsers. This is the result of Google using the QUIC protocol to deliver the advertisements. The QUIC protocol is actually quite useful and can make your browsing experience faster.

If you see this behavior and want to block these ads again:

  1. navigate to chrome://flags/ in the address bar
  2. search for QUIC
  3. disable it


Still seeing youtube ads?
PiHole handles requests but doesn't block anything
Boston.com
Slow performance on Android
#2

The easy way to find this flag is

1 navigate to chrome://flags/#enable-quic in the address bar
2 disable it

The annoying step is no longer needed.

In the pick you posted you can see the easy shortcut to the flag you want, in this case it’s #enable-quic.

All Chrome flags have this, I think anyway maybe some don’t.