Website Blocked "Not found on any Blacklist" (

Recently our PiHole is acting random when visiting It gives the reason "Not found on any blacklist" as why it is flagged...

I've tried whitelisting and, both via the web interface and using the pihole -w command (after removing them from the web interface whitelist and rebooting), but it keeps popping up... Sometimes, not every time.
After whitelisting the pages via pihole -w the error page does state "This site has been whitelisted, please flush your DNS cache and/or restart your browser". i've done all these things but the PiHole keeps giving the same messages. However, sometimes it just redirects you to, but it looks almost random...I've also whitelisted but since it states on the pihole page that or have been blocked, I don't think that will make any difference.

Any ideas? I've noticed the FTLDNS message on top of the page but the PiHole is currently running in our office environment and I'm not really inclined to start beta testing it here. There's about 200 users active at any time so downtime is pretty costly...

What version are you running?

You may be seeing this:

Otherwise, please send us the token generated by

pihole -d

or do it through the Web interface:

Have this today, as well. Its a very confusing message, to say the list. Debug uploaded:


* The debug log can be uploaded to for sharing with developers only.
* For more information, see:
* If available, we'll use openssl to upload the log, otherwise it will fall back to netcat.

[✓] Your debug token is: 0jey904fjx

Did you recently whitelist a domain, and did you flush the DNS cache?

I disable Windows DNS caching.

While I have added a few items to the whitelist (in my troubleshooting), it’s been quite some time (perhaps 30 minutes). I’ve even restarted DNSmasq from the web menu.

Still no joy.

Some browsers (Chrome included) cache DNS queries, so you should clear their cache as well.
What is the output of nslookup on both the Pi-hole and Windows machine?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.