Webseite ist Kaputt

Hey,
irgendwie ist die Pihole Homepage bei mir lokal kaputt. Die Blockseite sieht so aus: https://imgur.com/a/Im7ZUJW

Und die Adminweboberfläche sieht so aus: https://imgur.com/a/myeqDrh

Einen Debugtoken habe ich auch mal gemacht: https://tricorder.pi-hole.net/dkad8xyvh6

Hallo,

verwendest du im Browser eventuell einen Adblocker oder etwas wie NoScript?
Falls dies der Fall sein sollte, definiere für die Webseite von Pi-hole eine Ausnahme im entsprechenden Addon.

Hey,

selbst in dem komplett neu aufgesetzten Chromium und Opera siehts genauso aus bzw ich bekomme einfach nur den Quelltext angezeigt. Wenn ich die IP aufrufe bekomme ich die Ordnerstruktur angezeigt.

Die Anzeige ist auf unterschiedlichen Clients (z.B. Desktop und Smartphone) & unterschiedlichen Browsern (z.B. Firefox, Chrome, Safari) fehlerhaft?

Korrekt. Selbst ein “pihole -r” sowie reboot sind ohne Erfolg. :frowning:

pihole -r -> repair wäre jetzt auch mein Vorschlag gewesen. Entweder liegt ein Problem in der Konfiguration des Webservers vor oder die Installation ist nicht korrekt/vollständig verlaufen.

Vielleicht hilft die Holzhammermethode

cd /var/www/html/admin
sudo git reset --hard HEAD
sudo git checkout master
sudo git pull

Danach pihole -r -> repair

Please send us the token generated by

pihole -d

or do it through the Web interface:

Hey,

i allready did this, but here is another one: https://tricorder.pi-hole.net/iz9pay1u15

Hilft leider auch nicht… Ich glaube es wird wohl eine neuinstallation werden… :frowning:

My apologies. I missed that on my mobile device.

No Problem. :slight_smile: Now you have 2 things so read ^^ :slight_smile:

From your debug log, it shows you have Apache2 running as a web server and this is interfering with lighttpd (the Pi-Hole web server) on port 80. You will need to either stop Apache2 or move it or lighttpd to an alternate port if you want them to run together.

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is failed
[✓] pihole-FTL daemon is active

*** [ DIAGNOSING ]: Dashboard and block page
[✗] Block page X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Mon, 09 Sep 2019 15:24:20 GMT
Server: Apache/2.4.25 (Raspbian)
Content-Type: text/html;charset=UTF-8


[✗] Web interface X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Mon, 09 Sep 2019 15:24:20 GMT
Server: Apache/2.4.25 (Raspbian)
Last-Modified: Mon, 25 Feb 2019 13:14:11 GMT
ETag: "2a3b-582b7b765ffd0"
Accept-Ranges: bytes
Content-Length: 10811

Well, this was something i forgot… it got installed with some Script wich i thought it would work… But since i now purged ap2 it works now. :slight_smile: Thank you. :slight_smile: