Web interface showing no stats


#22

Can you run through the debugging steps


#23

Yes, here is the new debug token: grp7eds4zu


#24

Apache active ?

sudo netstat -nltup | grep 'Proto\|:53 \|:80 \|:67 \|:4711 '


#25

Here’s the netstat output:

root@beaglebone:/home/ken# sudo netstat -nltup | grep 'Proto|:53 |:80 |:67 |:4711 ’
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 4417/pihole-FTL
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2079/lighttpd
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 1337/dnsmasq
tcp6 0 0 ::1:4711 :::* LISTEN 4417/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 2079/lighttpd
tcp6 0 0 :::53 :::* LISTEN 1337/dnsmasq
udp 0 0 0.0.0.0:53 0.0.0.0:* 1337/dnsmasq
udp6 0 0 :::53 :::* 1337/dnsmasq


#26

Sorry I meant the FTL debugging process, not pihole -d.


#27

Ok, here’s my FTL debug info. When I typed gdb pihole-FTL, it couldn’t find it, saying “/home/ken/pihole-FTL”: not in executable format: File format not recognized. I changed the command to gdb /usr/bin/pihole-FTL and it worked. Let me know if you need further. Thank you for your help!

ken@beaglebone:~$ gdb pihole-FTL
GNU gdb (Debian 7.7.1+dfsg-5) 7.7.1
Copyright © 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “arm-linux-gnueabihf”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type “help”.
Type “apropos word” to search for commands related to “word”…
“/home/ken/pihole-FTL”: not in executable format: File format not recognized
(gdb)
[1]+ Stopped gdb pihole-FTL

ken@beaglebone:~$ gdb /usr/bin/pihole-FTL
GNU gdb (Debian 7.7.1+dfsg-5) 7.7.1
Copyright © 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “arm-linux-gnueabihf”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type “help”.
Type “apropos word” to search for commands related to “word”…
Reading symbols from /usr/bin/pihole-FTL…done.

(gdb) handle SIGHUP nostop SIGPIPE nostop
Signal Stop Print Pass to program Description
SIGHUP No Yes Yes Hangup
SIGPIPE No Yes Yes Broken pipe

(gdb) run debug

Starting program: /usr/bin/pihole-FTL debug
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/arm-linux-gnueabihf/libthread_db.so.1”.
[2018-04-20 14:56:05.782] ########## FTL started! ##########
[2018-04-20 14:56:05.785] FTL branch: v3.0
[2018-04-20 14:56:05.786] FTL version: v3.0
[2018-04-20 14:56:05.788] FTL commit: a1b2fa03f8f3e3713b57a26a4e9a062fec0573d7
[2018-04-20 14:56:05.789] FTL date: 2018-02-14 12:45:47 -0800
[2018-04-20 14:56:05.792] FTL user: ken
[2018-04-20 14:56:05.793] Notice: Found no readable FTL config file
[2018-04-20 14:56:05.795] Using default settings
[2018-04-20 14:56:05.796] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2018-04-20 14:56:05.798] SOCKET_LISTENING: only local
[2018-04-20 14:56:05.800] QUERY_DISPLAY: Show queries
[2018-04-20 14:56:05.801] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2018-04-20 14:56:05.802] MAXDBDAYS: max age for stored queries is 365 days
[2018-04-20 14:56:05.804] RESOLVE_IPV6: Resolve IPv6 addresses
[2018-04-20 14:56:05.806] RESOLVE_IPV4: Resolve IPv4 addresses
[2018-04-20 14:56:05.808] DBINTERVAL: saving to DB file every minute
[2018-04-20 14:56:05.809] DBFILE: Using /etc/pihole/pihole-FTL.db
[2018-04-20 14:56:05.811] MAXLOGAGE: Importing up to 24.0 hours of log data
[2018-04-20 14:56:05.813] Finished config file parsing
[2018-04-20 14:56:05.814] PID of FTL process: 3164
[2018-04-20 14:56:06.190] Gravity list entries: 121066
[2018-04-20 14:56:06.192] No blacklist present
[2018-04-20 14:56:06.194] No wildcard blocking list present
[2018-04-20 14:56:06.197] Database initialized
[2018-04-20 14:56:06.199] SELECT * FROM queries WHERE timestamp >= 1524146460
[2018-04-20 14:56:06.202] read_data_from_DB() - SQL error prepare (1): no such table: queries
[2018-04-20 14:56:06.204] Starting initial log file parsing
[2018-04-20 14:56:06.206] Reading from /var/log/pihole.log (rw-r–r--)
[2018-04-20 14:56:06.209] Detected restart of dnsmasq, increasing loggeneration to 1
[2018-04-20 14:56:06.211] Detected restart of dnsmasq, increasing loggeneration to 2
[2018-04-20 14:56:06.213] Finished initial log file parsing
[2018-04-20 14:56:06.215] -> Total DNS queries: 0
[2018-04-20 14:56:06.217] -> Cached DNS queries: 0
[2018-04-20 14:56:06.218] -> Forwarded DNS queries: 0
[2018-04-20 14:56:06.220] -> Exactly blocked DNS queries: 0
[2018-04-20 14:56:06.221] -> Wildcard blocked DNS queries: 0
[2018-04-20 14:56:06.223] -> Unknown DNS queries: 0
[2018-04-20 14:56:06.224] -> Unique domains: 0
[2018-04-20 14:56:06.226] -> Unique clients: 0
[2018-04-20 14:56:06.228] -> Known forward destinations: 0
[2018-04-20 14:56:06.229] Successfully accessed setupVars.conf
[New Thread 0xb6e4d460 (LWP 3165)]
[2018-04-20 14:56:06.240] Listening on port 4711 for incoming IPv4 telnet connections
[2018-04-20 14:56:06.242] Found 7 IPv4 and 4 IPv6 capable interfaces
[2018-04-20 14:56:06.244] Listening on port 4711 for incoming IPv6 telnet connections
[2018-04-20 14:56:06.246] Error on binding on Unix socket /var/run/pihole/FTL.sock: No such file or directory (2)
[Thread 0xb6e4d460 (LWP 3165) exited]
[Inferior 1 (process 3164) exited with code 01]


#28

So I guess we give up on this one. No idea what the problem is but I suppose we must just move on. Thanks for the help!


#29

Sorry, I somehow entirely missed your previous reply!

It is essential that you start FTL using the system commands and then attach the debugger only later (see simplified debugging instructions).

I’m happy to walk you through in case you some more assistance.


#30

Thanks! I just tried to start it via “sudo service pihole-FTL start”. I get no errors, but when I run sudo pihole-FTL running it returns that the program is not running. The only way I can get it to start is running it manually instead of through the service command.


#31

What’s the output of sudo service pihole-FTL status ?
What are the last lines in /var/log/pihole-FTL.log?


#32

Sorry for the delayed reply.
The output of sudo service pihole-FTL status:

ken@beaglebone:~$ sudo service pihole-FTL status
● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

The last lines of /var/log/pihole-FTL.log:

[2018-05-04 01:34:50.357] ########## FTL started! ##########
[2018-05-04 01:34:50.358] FTL branch: v3.0
[2018-05-04 01:34:50.358] FTL version: v3.0
[2018-05-04 01:34:50.358] FTL commit: a1b2fa03f8f3e3713b57a26a4e9a062fec0573d7
[2018-05-04 01:34:50.358] FTL date: 2018-02-14 12:45:47 -0800
[2018-05-04 01:34:50.359] FTL user: root
[2018-05-04 01:34:50.359] Warning: Starting pihole-FTL directly is not recommended.
[2018-05-04 01:34:50.359] Instead, use system commands for starting pihole-FTL as service (systemctl / service).
[2018-05-04 01:34:50.360] Notice: Found no readable FTL config file
[2018-05-04 01:34:50.360] Using default settings
[2018-05-04 01:34:50.360] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2018-05-04 01:34:50.360] SOCKET_LISTENING: only local
[2018-05-04 01:34:50.360] QUERY_DISPLAY: Show queries
[2018-05-04 01:34:50.361] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2018-05-04 01:34:50.361] MAXDBDAYS: max age for stored queries is 365 days
[2018-05-04 01:34:50.361] RESOLVE_IPV6: Resolve IPv6 addresses
[2018-05-04 01:34:50.361] RESOLVE_IPV4: Resolve IPv4 addresses
[2018-05-04 01:34:50.361] DBINTERVAL: saving to DB file every minute
[2018-05-04 01:34:50.362] DBFILE: Using /etc/pihole/pihole-FTL.db
[2018-05-04 01:34:50.362] MAXLOGAGE: Importing up to 24.0 hours of log data
[2018-05-04 01:34:50.362] Finished config file parsing


#33

Bumping this post.


#34

and then no termination comment in the log file screams for that pihole-FTL was killed (SIGKILL) externally. I’m not sure what could be causing this.

since the log snippet you showed says

I conclude that you didn’t attempt to start if via the service command. Could you try this again, please?


#35

Sorry for the mess up on my part. Here’s the output of sudo service pihole-FTL status after starting FTL via the command sudo service pihole-FTL start:

ken@beaglebone:~$ sudo service pihole-FTL start
ken@beaglebone:~$ sudo service pihole-FTL status
● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
Active: active (exited) since Sun 2018-05-13 21:21:20 UTC; 2s ago
Docs: man:systemd-sysv-generator(8)
Process: 2285 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SU

May 13 21:21:19 beaglebone systemd[1]: Starting LSB: pihole-FTL daemon…
May 13 21:21:19 beaglebone pihole-FTL[2285]: Not running
May 13 21:21:19 beaglebone pihole-FTL[2285]: rm: cannot remove ‘/var/run/pihole/
May 13 21:21:19 beaglebone su[2301]: Successful su for pihole by root
May 13 21:21:19 beaglebone su[2301]: + ??? root:pihole
May 13 21:21:19 beaglebone su[2301]: pam_unix(su:session): session opened for us
May 13 21:21:20 beaglebone pihole-FTL[2285]: FTL started!
May 13 21:21:20 beaglebone systemd[1]: Started LSB: pihole-FTL daemon.


#36

Does the web interface show the statistics now?


#37

No, it still just shows zeroes. I ran sudo service pihole-FTL status again just now and got this:

May 13 21:21:19 beaglebone systemd[1]: Starting LSB: pihole-FTL daemon…
May 13 21:21:19 beaglebone pihole-FTL[2285]: Not running
May 13 21:21:19 beaglebone pihole-FTL[2285]: rm: cannot remove ‘/var/run/pihole/
May 13 21:21:19 beaglebone su[2301]: Successful su for pihole by root
May 13 21:21:19 beaglebone su[2301]: + ??? root:pihole
May 13 21:21:19 beaglebone su[2301]: pam_unix(su:session): session opened for us
May 13 21:21:20 beaglebone pihole-FTL[2285]: FTL started!
May 13 21:21:20 beaglebone systemd[1]: Started LSB: pihole-FTL daemon.


#38
  • Which operating system are you on?
  • How does your /etc/dnsmasq.d/01-pihole.conf look like?
  • What is the output of dnsmasq -v?
  • What are the last lines in /var/log/pihole.log?

#39
**ken@beaglebone:~$ lsb_release -a**
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.10 (jessie)
Release:        8.10
Codename:       jessie
**root@beaglebone:/home/ken# cat /etc/dnsmasq.d/01-pihole.conf**
# Pi-hole: A black hole for Internet advertisements
# (c) 2015, 2016 by Jacob Salmela
# Network-wide ad blocking via your Raspberry Pi
# http://pi-hole.net
# dnsmasq config for Pi-hole
#
# Pi-hole is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.

###############################################################################
#      FILE AUTOMATICALLY POPULATED BY PI-HOLE INSTALL/UPDATE PROCEDURE.      #
# ANY CHANGES MADE TO THIS FILE AFTER INSTALL WILL BE LOST ON THE NEXT UPDATE #
#                                                                             #
#        IF YOU WISH TO CHANGE THE UPSTREAM SERVERS, CHANGE THEM IN:          #
#                      /etc/pihole/setupVars.conf                             #
#                                                                             #
#        ANY OTHER CHANGES SHOULD BE MADE IN A SEPERATE CONFIG FILE           #
#                        OR IN /etc/dnsmasq.conf                              #
###############################################################################

addn-hosts=/etc/pihole/gravity.list
addn-hosts=/etc/pihole/black.list
addn-hosts=/etc/pihole/local.list


localise-queries


no-resolv



cache-size=10000

# log-queries=extra
log-facility=/var/log/pihole.log

local-ttl=2

log-async
server=1.1.1.1
server=1.0.0.1
interface=eth0
root@beaglebone:/home/ken# dnsmasq -v
Dnsmasq version 2.72  Copyright (c) 2000-2014 Simon Kelley
Compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect
**root@beaglebone:/home/ken# tail /var/log/pihole.log**
May  5 04:15:38 dnsmasq[971]: exiting on receipt of SIGTERM
May  5 04:15:39 dnsmasq[1347]: started, version 2.72 cachesize 10000
May  5 04:15:39 dnsmasq[1347]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect
May  5 04:15:39 dnsmasq[1347]: warning: interface eth0 does not currently exist
May  5 04:15:39 dnsmasq[1347]: using nameserver 1.0.0.1#53
May  5 04:15:39 dnsmasq[1347]: using nameserver 1.1.1.1#53
May  5 04:15:39 dnsmasq[1347]: read /etc/hosts - 5 addresses
May  5 04:15:39 dnsmasq[1347]: read /etc/pihole/local.list - 2 addresses
May  5 04:15:39 dnsmasq[1347]: failed to load names from /etc/pihole/black.list: No such file or directory
May  5 04:15:46 dnsmasq[1347]: read /etc/pihole/gravity.list - 121667 addresses

#40

Aha!

did you remove this yourself? After doing so, FTL cannot read the logs anymore

The most recent version of Pi-hole is not supported on Jessie:

You have a few options:

Install fresh or update to Strech and then re-install Pi-hole

or reinstall Pi-hole on a more modern operating system such as Debain/Raspbian Stretch.


#41

Wow, just figures I caused this haha. Yes, I did that because I had tried to troubleshoot why nothing was working and Googled for an answer. I found where someone had commented that line out to get things working, but the page I read either failed to note or I failed to see that the result would be what I wound up with. I’ll see about upgrading and starting over. Thank you so much for your help! I truly appreciate the time spent assisting me.