Virtual Machine bypassing pihole

I set up pihole today with dnsmasq (option #2 here).

My desktop and phone appear to be using the pihole as expected, however my windows 10 VM (running on the desktop) does not. I can still reach blocked domains from the VM browser.

I would like to have the benefit of adblocking inside the VM. Any advice on making that happen? Thanks in advance.

Here is the result of running nslookup in the VM:

PS C:\Users\XXX> nslookup pi.hole
Server:  UnKnown

Name:    pi.hole
Addresses:  fe80::130c:6e63:cc3:9f9a

pihole's IP address looks correct.

Expected Behaviour:

browsers running in the virtual machine should not be able to access domains blocked by pihole.

Actual Behaviour:

browsers running in the VM still load ads, access blocked domains, etc.
Browsers running on my native desktop install and mobile phone have adblocking as normal.

Debug Token:

Any browser may by-pass Pi-hole via DNS-over-HTTPS (DoH).
You'd have to make sure that DoH is disabled in your VM browser.

Also, as your network has link-local IPv6 connectivity, Pi-hole may be by-passed via IPv6. Even if your debug log shows that your Pi-hole machine is not aware of such an alternative IPv6 DNS server, you should verify that your router is not advertising its own IPv6 link-local address as DNS server.

IPv6 is marked disabled in DDWRT, so I'm not sure how anything has IPv6 connections. I also tried disabling secure DNS in brave-browser, but that didn't seem to make any difference either.

I wound up nuking the VM and starting over for tangentially-related reasons, and the new VM install appears to be using the pihole as expected. weird.

Thanks anyway, I appreciate the advice.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.