Very new user


#5

The Dns was set on my router. On query log in pi-hole webui, doesn’t appear to query googleadservices.com,but still in my browser it appears.
I can provide more details upon request


#6

what is the output of a ping on flurry.com ?

From the pihole and from the computer?


#7

computer:

64 bytes from w2.src3.vip.bf1.yahoo.com (74.6.136.153): icmp_seq=1 ttl=250 time=121 ms
64 bytes from w2.src3.vip.bf1.yahoo.com (74.6.136.153): icmp_seq=2 ttl=250 time=121 ms
64 bytes from w2.src3.vip.bf1.yahoo.com (74.6.136.153): icmp_seq=3 ttl=250 time=121 ms
64 bytes from w2.src3.vip.bf1.yahoo.com (74.6.136.153): icmp_seq=4 ttl=250 time=121 ms

PiHole:

64 bytes from osmc (192.168.1.101): icmp_seq=1 ttl=64 time=0.137 ms
64 bytes from osmc (192.168.1.101): icmp_seq=2 ttl=64 time=0.186 ms
64 bytes from osmc (192.168.1.101): icmp_seq=3 ttl=64 time=0.229 ms
64 bytes from osmc (192.168.1.101): icmp_seq=4 ttl=64 time=0.133 ms

#8

i’m assuming your pihole is 192.168.1.101.

From the output it looks like your computer is not running the DNS queries through pi-hole.

Make sure your DNS settings on the PC use the 192.168.1.101 as your DNS.


#9

Then i’ve got all wrong.
My router uses pi-hole (192.168.1.101) as a dns. 192.168.1.101 is my raspberry pi ip’s…


#10

That would be fine also.

However you need to point the DNS setting on your computer to use your router as your DNS (192.168.1.1 i’m assuming).

Depending on how good your router is, it might have the ability to push that DNS IP when assigning DHCP IPs to your local clients.
However, if your router does not have that feature, you’d need to set-up your DNS settings at provider level, where you get the IP from your ISP.

It should allow you to manually specify the DNS (and hence override what your ISP is assigning you).

Keep in mind though one thing:

If you set-up your DNS within the router to have a secondary DNS also, say google under your secondary IP, your router might (and will) at some point run queries through the second DNS and thus missing the ad-blocking.

You always have the option to run the pi-hole as the DHCP server and that will fix your issue without any more hassle.

It would push the setting automatically to all your devices and on top of that you’ll see the Query log broken down per device, and not just queries coming from your router.


#11

These may be of assistance in this thread:


#12

So, my laptop has properly get my pi-hole dns
MbFD.png
But doesn’t block ads…


So i logged into pi-hole admin…
To check, but I see that it doesn’t show block-age…

So i’ve turned on my uBlockOrigin extension… and it’s all done
MbFr.png
What is going on?


#13

YouTube ad blocking is hit or miss until someone solves it.


#14

Ok, maybe i have chosen a bad example.
But these king of stuff happends on other sites also…


#15

If you have another example, we can take a look. Have you tried any of the pages here:


#16

Ok, then take a look here…
Pi-hole album with ads testing


#17

query your pi-hole adlist (Tools/Query adlists) doubleclick.net

It should be there already.

You can see if the domain is blocked by running a ping on that domain from the console of you pi.

It should return your pi-hole IP.

Run the same ping from the computer also and see what that resolves to.

As a last resort, you can check the logs from ublock origin and see exactly what it blocks and compare those entries within the pi-hole (if they are not there already).

(Pe ce website nu merge?)


#18

Indeed, it is!

But still, it seems like it’s playing jokes on me!
@ramset - pe stirileprotv.ro am încercat, și pe olx… oriunde încerc, dă greș


#19

ping doubleclick.net from the PC.

Does it resolve to the IP of the pi-hole?


#20

https://paste.ofcode.org/wNm9zwJUx2rMv6kdBYLNga
Wierd… ?It does not!


#21

That means that your DNS query is NOT going through Pi-Hole.

Double check and make sure you have the pi-hole DNS under your network properties.

Also if you might have a secondary DNS there (that’s not a backup pi-hole), that might be the culprit also.


#22


I’ve highlighted te pi-hole ip!
maybe it’s the ipv6?
This is what i’ve set up in my router;


#23

Could be. Try disabling IPV6 AND/OR run pihole -r and make sure block ads over IPV6 is selected.


#24

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.