Using Local Pihole as DNS doesn't work

Please follow the below template, it will help us to help you!

Expected Behaviour:

Following method #3 from How do I configure my devices to use Pi-hole as their DNS server? (Just want to use pihole for my one local machine), I modify my windows machine to point to my local pihole instance (that is in a docker container). I expect for my browsers and other applications to work as expected.

Actual Behaviour:

My browsers + other applications cannot connect to the internet.

Debug Token:

[✓] Your debug token is: https://tricorder.pi-hole.net/ld7t6wjrww

NS lookup works fine and as expected

image

You have a configuration error. The assigned IP does not match the configured IP in Pi-Hole and the IP of the DNS SERVER that replied to the nslookup is neither of those; it is not working as expected.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
   172.17.0.2/16 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

*** [ DIAGNOSING ]: Setup variables
    IPV4_ADDRESS=192.168.0.104
    PIHOLE_INTERFACE=eth0

I modified my setup script to be -e ServerIP="192.168.99.100" so now the nslookup server matches what I see in pihole -d

*** [ DIAGNOSING ]: Setup variables
    DNSMASQ_LISTENING=all
    DNS_FQDN_REQUIRED=false
    DNS_BOGUS_PRIV=false
    DNSSEC=false
    CONDITIONAL_FORWARDING=false
    IPV4_ADDRESS=192.168.99.100
    IPV6_ADDRESS=
    PIHOLE_DNS_1=8.8.8.8
    PIHOLE_DNS_2=8.8.4.4
    PIHOLE_INTERFACE=eth0

Not too sure what to do about the following configuration error however

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
   172.17.0.2/16 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

You can ignore this since you’re running Pi-Hole in a Docker container.

From a connected client, what is the output of nslookup pi.hole

You can ignore this since you’re running Pi-Hole in a Docker container.

Gotcha :smile:

C:\Users\kwojc>nslookup pi.hole
Server:  ead6060555e2
Address:  192.168.99.100

Name:    pi.hole
Address:  192.168.99.100

And in my pihole docker container logs I can see the request being logged

dnsmasq: 329 192.168.99.1/55782 query[PTR] 100.99.168.192.in-addr.arpa from 192.168.99.1
dnsmasq: 329 192.168.99.1/55782 /etc/pihole/local.list 192.168.99.100 is ead6060555e2
dnsmasq: 330 192.168.99.1/55783 query[A] pi.hole from 192.168.99.1
dnsmasq: 330 192.168.99.1/55783 /etc/pihole/local.list pi.hole is 192.168.99.100
dnsmasq: 331 192.168.99.1/55784 query[AAAA] pi.hole from 192.168.99.1
dnsmasq: 331 192.168.99.1/55784 cached pi.hole is NODATA-IPv6

But when I refresh the DNS settings in chrome chrome://net-internals/#dns and restart my browser still nothing works. I also don’t see any query requests in my docker logs when I try to navigate to a page in chrome (the same applies for other applications: discord, IE, etc).

The browser apparently is using a DNS other than Pi-Hole. The OS (Windows) is using Pi-Hole DNS.

When I try to use curl in the command line I get an error as well

 curl -vvv www.google.ca
* Rebuilt URL to: www.google.ca/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Could not resolve host: www.google.ca
* Closing connection 0
curl: (6) Could not resolve host: www.google.ca

When I try to use the windows “diagnose this connection” it says
image

My docker machine is running in a vm (as I am using windows). The vm is using a bridged adapter for the networking which I believe is the correct setting.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.