Unsupported OS error: Lubuntu 16.04 on Raspberry Pi 3

The issue I am facing:
tbh i'm confused

I got "[✗] Unsupported OS detected: Ubuntu 16.04" during a pihole update today

Yet I note on the web interface (admin page) that two of the 3 pihole components (all three had previously reported an update being available) appear to have been updated.

I 'tnink' i was on pihole 5.10

now on 5.11.4 and web 5.13

Only outstanding item is the FTL, which is still reporting 5.15 and requiring an update

I don't know if the FTL has been prevented from updating because of the OS unsupported error?

Details about my system:
hardware = Rasberry Pi 3

Returned by hostnamectl:

"Operating System: Ubuntu 16.04.7 LTS
Kernel: Linux 4.4.38-v7+"

What I have changed since installing Pi-hole:
i now use pihole for DHCP provision but aside from that it's pretty out-of-the-box

regards,

Gary

Please generate a debug log, upload it when prompted and post the token URL here.

thanks @jfb

https://tricorder.pi-hole.net/SH8tUyDb/

@jfb hi.

Is there any update on this?

regards,

Gary

Apologies I missed this. The debug token has expired - please generate a new log and post the new token.

no worries - tbh you're pretty good and it seems like you pick up all the forum stuff (so that's a lot to track).

https://tricorder.pi-hole.net/zip9OquN/

to recap, basically pihole and the web UI updated but FTL didn't, reporting unsupported OS.

This reason seems a little odd, given some components were ok (but maybe there's a good technical reason for this).

Capture

From your debug log:

*** [ DIAGNOSING ]: Operating system
[i] dig return code:  0
[i] dig response:  "Raspbian=10,11 Ubuntu=18,20,21,22 Debian=10,11 Fedora=34 CentOS=7,8 Rocky=8"
[✓] Distro:  Ubuntu
[✗] Version: 16.04
[✗] Error: Ubuntu is supported but version 16.04 is currently unsupported (https://docs.pi-hole.net/main/prerequisites/)

thanks @jfb

i understand.

I saw the the error message while pihole was updating.

This doesn't IMO explain why 2 of the 3 pihole components updated but FTL didn't

Regards,

Gary

What is the complete output of pihole -up

I'm not sure how to produce this

All i can say (without further guidance) is as per my earlier screenshot (current update status of components) and my opening post:

  • all 3 components were reported in the web UI as due for updating

  • 2 of the 3 updated (pihole and the web UI)

  • FTL is still reporting as due for updating (and i've tried to update again and it won't)

regards,

Gary

Copy the output of the command and paste it into a reply.

[✓] Root user check

    .;;,.
    .ccccc:,.
     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
         .;cll.;;looo:.
             .. ','.
            .',,,,,,'.
          .',,,,,,,,,,.
        .',,,,,,,,,,,,....
      ....''',,,,,,,'.......
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........
      ........,,,,,,,'......
        ....',,,,,,,,,,,,.
           .',,,,,,,,,'.
            .',,,,,,'.
              ..'''.

[i] SELinux not detected
[✓] Update local cache of available packages
[i] Existing PHP installation detected : PHP version 7.0.33-0ubuntu0.16.04.16

[✓] Checking apt-get for upgraded packages... up to date!

[i] Checking for / installing Required dependencies for OS Check...
[✓] Checking for grep
[✓] Checking for dnsutils

[✗] Unsupported OS detected: Ubuntu 16.04
If you are seeing this message and you do have a supported OS, please contact support.

  https://docs.pi-hole.net/main/prerequisites/#supported-operating-systems

  If you wish to attempt to continue anyway, you can try one of the following commands to skip this check:

  e.g: If you are seeing this message on a fresh install, you can run:
         curl -sSL https://install.pi-hole.net | sudo PIHOLE_SKIP_OS_CHECK=true bash

       If you are seeing this message after having run pihole -up:
         sudo PIHOLE_SKIP_OS_CHECK=true pihole -r
       (In this case, your previous run of pihole -up will have already updated the local repository)

  It is possible that the installation will still fail at this stage due to an unsupported configuration.
  If that is the case, you can feel free to ask the community on Discourse with the Community Help category:
  https://discourse.pi-hole.net/c/bugs-problems-issues/community-help/

Have you run this command?

No i hadn't - IIRC i was supposed to check in with support.

Also, i clearly don't have a supported OS, so didn't want screw my installation up forcing the install through

EDIT: @jfb

  1. can you confirm it's safe for me to run " sudo PIHOLE_SKIP_OS_CHECK=true pihole -r" on my installation?

  2. Do we know why pihole and the web UI updated without incident but FTL triggered the OS error?

Thanks.