Unable to set DNS with pfsense router on 2.3.2-RELEASE-p1


#1

i tried the preferred method but its not working. I have a pfsense router on 2.3.2-RELEASE-p1


How do I configure my devices to use Pi-hole as their DNS server?
#2

i am still having issues


#3

I don’t know that anyone on the team has the same hardware to replicate any issues. How are you setting the DNS?


#4

setting the DNS under DNS Server Settings


#5

You should be setting the DNS server under DHCP Setting as these are the settings that your clients will get. Could you also provide some more information as your OP was a bit vague.


#6

There may be a conflict, If i remember correctly, pfsense also uses dnsmasq. Try looking for an option to turn off dnsmasq.

Good luck


#7

ok I got it to work.

Enable DNS forwarder and then set up your DNS server in System >
General Setup (To the Pi IP). That will set the DNS server for the
Pfsense box and it will hand it out to all DHCP clients too.


#8

Glad it worked!

What box are you using for pfsense? Did you build it yourself?


#9

hi

i would be happy if you could post some screenshots from your settings (Services ->DNS-Forwarder and System->general setup)

so far i did just put the ip of my pi-hole into the field DNS-Sever (services->DHCP-Server, for the LAN interface ). But then i only have 2 Sorts of statistics: local or the fix-ip of my pfsense.