Unable to access pihole admin interface

#1

Please follow the below template, it will help us to help you!

I had every configured and working correctly. unrelated I enabled some interfaces on the pi and had to reboot. After reboot I noticed connection issues for dns so went to check /admin in browser and it did not connect.

I have since added a secondary dns server so i can continue doing other things.

Expected Behaviour:

Home screen and dashboard for pihole admin

Actual Behaviour:

This site cannot be reached.

Debug Token:

https://tricorder.pi-hole.net/b9fh99s5jf!

0 Likes

#2

Your debug log shows that you don’t have an IP address assigned to the Pi. Pi-Hole is configured to listen at IP 9 on ethernet, but there is no IP on that interface. Pi-Hole can talk to itself on the assigned IP, but it does not appear that others can reach the Pi.

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 192.168.1.1
   * Pinging 192.168.1.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

*** [ DIAGNOSING ]: Setup variables
    PIHOLE_INTERFACE=eth0
    IPV4_ADDRESS=192.168.1.9/24

Check the assigned IP on the router and the network configuration on the Pi. If necessary, reconfigure Pi-Hole for whatever IP you assign from the router to the Pi.

ip addr

0 Likes

#3

I had already made sure that the ip is reserved on the router. I am using ssh from my pc on the lan to get to the pi. accessing the pi is not an issue. Its accessing the admin console that is a problem. I did see that ping message and later tried pinging the router from the pi with no issues.

i just rebooted and still getting pinging gateway failing. right after i ran pihole -d, i did the following:

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=1.50 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=6.84 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=5.18 ms

as you can see no issues.

Maybe there is a problem because i am connecting over wifi? here is my ifconfig output

eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:1e:46:68 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 397 bytes 50827 (49.6 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 397 bytes 50827 (49.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.9 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::ad12:731d:8217:79af prefixlen 64 scopeid 0x20
ether b8:27:eb:4b:13:3d txqueuelen 1000 (Ethernet)
RX packets 1379 bytes 985013 (961.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1395 bytes 302409 (295.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Also new token, https://tricorder.pi-hole.net/wpqfn01c9r!

Message from browser:

This site can’t be reached 192.168.1.9 took too long to respond.

On the pi I do the following.

curl -I 192.168.1.9/admin
HTTP/1.1 301 Moved Permanently
Location: http://192.168.1.9/admin/
Date: Sat, 23 Mar 2019 21:21:36 GMT
Server: lighttpd/1.4.45

curl -I 192.168.1.9/admin/
HTTP/1.1 200 OK
X-Pi-hole: The Pi-hole Web interface is working!
X-Frame-Options: DENY
Set-Cookie: PHPSESSID=hgpn2ctpb4fbao09v9drefbsu3; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-type: text/html; charset=UTF-8
Date: Sat, 23 Mar 2019 21:22:24 GMT
Server: lighttpd/1.4.45

thanks.

0 Likes

#4

I decided to reinstall and it is working now. I think when i configured it before i told it to look at eth0. It also grabbed the ip. I have not rebooted the pi since the installation last week so I think when i rebooted it today it checked eth0 for the ip but couldn’t find it. I chose wlan0 this time and after running debug it looks good.
https://tricorder.pi-hole.net/ixir2nd0cu

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the wlan0 interface:
192.168.1.9/24 matches the IP found in /etc/pihole/setupVars.conf

[✓] IPv6 address(es) bound to the wlan0 interface:
fe80::ad12:731d:8217:79af does not match the IP found in /etc/pihole/setupVars.conf (Use IPv6 ULA addresses for Pi-hole)

^ Please note that you may have more than one IP address listed.
As long as one of them is green, and it matches what is in /etc/pihole/setupVars.conf, there is no need for concern.

The link to the FAQ is for an issue that sometimes occurs when the IPv6 address changes, which is why we check for it.

[i] Default IPv4 gateway: 192.168.1.1

  • Pinging 192.168.1.1…
    [✓] Gateway responded.

thx

0 Likes

closed #5

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes