Temporary failure in name resolution for localhost querries


#1

I noticed over night there have been over 60,000 requests to 0.debian.pool.ntp.org, 1.debian.pool.ntp.org, 2.debian.pool.ntp.org, 3.debian.pool.ntp.org

piCapture

For some reason the Pihole its self can not get DNS resolution so it is constantly trying to set the time.

pi@pihole:~ $ ping 0.debian.pool.ntp.org
ping: 0.debian.pool.ntp.org: Temporary failure in name resolution
pi@pihole:~ $


What Really Happens On Your Network? Part Eight
#2

Sometimes competing DHCP servers can cause this message. Has anything changed recently in that regard?


#3

I did change something before this started I unchecked these two boxes

Advanced DNS settings
X Never forward non-FQDNs
X Never forward reverse lookups for private IP ranges

Note that enabling these two options may increase your privacy slightly, but may also prevent you from being able to access local hostnames if the Pi-hole is not used as DHCP server

Re enabling those two option fixed it.

Does that mean there is another DHCP server besides my router?

The Pi-Hole DHCP server is not enabled.


#4

A rogue DHCP could be possible, and those two options don’t have anything to do with this issue. They just ensure local hostnames aren’t resolved upstream.

What’s in your /etc/resolv.conf?


#5

Well they had something to do with it as you can see the massive DNS queries stopped and localhost queries work.

pi@pihole:~ $ ping 0.debian.pool.ntp.org
PING 0.debian.pool.ntp.org (173.230.144.109) 56(84) bytes of data.
64 bytes from palpatine.steven-mcdonald.id.au (173.230.144.109): icmp_seq=1 ttl=53 time=36.9 ms
64 bytes from palpatine.steven-mcdonald.id.au (173.230.144.109): icmp_seq=2 ttl=53 time=39.7 ms
64 bytes from palpatine.steven-mcdonald.id.au (173.230.144.109): icmp_seq=3 ttl=53 time=38.1 ms
^C

I will figure out exactly what one of the two options it is and report back

Oh I forgot my resolv.conf

Generated by resolvconf

nameserver 127.0.0.1


#6

Intersting. I’m curious to know. Thanks


#7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.