Synology reverse proxy setup help

docker

#1

Hi all. I’ve got the pihole image installed and am able to access the web interface on :8181 (ezpz), but I suspect that since this is on a Synology which is hoarding port 80, I need to perform an extra step to actually get queries to register.

I spent the last 2 hours reading a bunch of posts with varying methods, dates and levels of success and there doesn’t seem to be a consensus on how to make this work, at least that I saw. Is this as simple as putting a few entries in the Synology Reverse Proxy tab? Please forgive a nooblord; I’ve never worked with proxies, so I’m fairly lost on this part.

Current docker settings (which obviously can be changed):


#2

#3

The DNS port is getting forwarded to 32782, which is not the standard port for DNS queries. Try remapping it to 53.


#4

I’ve never had a Synology to play with settings things up but I linked one of the more elegant solutions I’ve seen to avoid port 80 conflicting with synology’s web interface : Alternative Synology installation method

Remember every time you re-create the container you’re getting new random ports.


#5

Thanks, guys! Forcing both the TCP and UDP ports to 53 seems to have worked.