Surfen wird langsam

Hallo zusammen,

ich bin leider ein totaler Anfänger und habe es gerade so geschafft Pi-hole zu installieren. Das lief zu Beginn auch sehr gut, aber seit einiger Zeit ist das surfen sehr langsam geworden. Bei einigen Seiten braucht es über 1 Minute. Wenn ich mich auf dem Pi-hole einlogge, sehe ich einerseits das die Anzahl an gleichzeitigen Anfragen das eingestellte Limit von 150 überschreitet.

Wenn ich auf Pi-hole diagnosis gehe, erscheint also:

Maximum number of concurrent DNS queries reached (max: 150)

Ein paar Daten:
FritzBox 7490
In den DNS-Rebind-Schutz habe ich bereits die IP-Adresse vom Pi angegeben - wie hier vorgeschlagen:

Das hat aber nicht zu einer Verbesserung geführt.

Debug Token:

https://tricorder.pi-hole.net/ebNg15nb/

Dein FritzBox-Router verteilt seine eigene IPv4-Adresse als DNS-Server:

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   
   * Received 548 bytes from eth0:192.168.178.1
     Offered IP address: 192.168.178.71
     DHCP options:
      Message type: DHCPOFFER (2)
      router: 192.168.178.1
      dns-server: 192.168.178.1

Gleichzeitig hast Du Pi-holes Conditional Forwarding aktiviert.
Damit hast Du eine partielle DNS-Endlosschleife konfiguriert, welche dann bei tatsächlicher Nutzung die 'Maximum...concurrent...'-Warnung provoziert.

In dieser Konfiguration solltest DU CF deaktivieren.

Alternativ konfigurierst Du die FB so, dass sie Pi-hole als lokalen DNS-Server verteilt.
Für weiterführende Anregungen wirf mal einen Blick auf Fritz!Box (DE) - Pi-hole documentation .