Set adlist to ignore ssl certs

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

Hardware Pi 4 & Pi VM & Pi 3b+
download a adlist from gitlab server ignore ssl self signed cert

Actual Behaviour:

--- Issue when setting up a local gitlab server i am not using ssl within my own network when i set pihoe to pull an adlist from it nothing happens im assuming it is due to a self signed cert error.

Debug Token:

Why not make this a file, and skip the whole http process?

Hello jfb,
This is working as a workaround when i tried to use gitlab with this URL - it would just give an error due to ssl. I have not found a way to turn ssl off on gitlab. currently the .31 is running a .bat file on widows to pull down the file from gitlab and make it available via its iis service. was trying to remove the middle man.
if it is not possible this will continue to work. i know with wget you can run it like 'wget –no-check-certificate'

I like that option. I may just try this out setting up a local git repo local and see how it goes - thank you for the suggestion.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.