Router / Pihole IPv6 adresses

Hello all,

since beginning to use pihole I think having a little problem:

My router is DHCP server and IPv6 ULA is enabled.
The router shows me an v6 address for my raspberry with pihole.
I copied that address into the pihole setupVars.conf file.

My router and raspberry are offline overnight, so restarts are daily.
When I check the IPv6 in the pihole admin console, it shows me exactly the copied address from the router.
IPv6 addresses in router and admin console are equal.

Now, when I check via Putty the IPv6 address...

IPV6_ADDRESS=$(ip -6 a | grep 'fc\|fd' | awk -F " " '{gsub("/[0-9]*",""); print $2}')
echo ${IPV6_ADDRESS} gives back a different address.

Is something wrong with what I am doing,
or how can I resolve this?

Thanks in advance!

(Raspberry 2b, Raspbian Jessie or Stretch, Pihole 3.3 or earlier)

Please send us the token generated by

pihole -d

or do it through the Web interface:

Jacob, thanks for reply
[✓] Your debug token is: 0scaylzurv

What I noticed
*** [ DIAGNOSING ]: Networking

[✓] IPv6 address(es) bound to the eth0 interface:
does not match the IP found in /etc/pihole/setupVars.conf

The address ending with df85 is shown in my router for IPv6 ULA as well as in the pihole admin console.
The address ending with b6b5 is shown via Putty.

The picture below shows information given by my router.

Many thanks looking into that.

Forgot to say:
the b6b5 address was the original IPv6 in setupVars.conf after fresh install of raspbian and pihole.

There seems to be a bug in the debugger, which I need to fix; could you help with the output of a few commands so I can resolve it:

ip -6 a

In terms of your installation, it should be working fine. So long as your ULA is in gravity.list (which it is), and your device actually has that IP (which it does), Pi-hole should work. But I do see this in your log:

[✗] Failed to resolve via Pi-hole (::df85)

Do you have any firewalls or routing rules in place that might prevent this traffic from flowing?

-Just sent reply by mail-

I have not received anything yet.

I replied to the email notification directly by mail.
Tried again via another email account. Hope that worked,

The emails from this forum is a no-reply email and is just a robot. Click on my user icon and send me a private message that way.

Just send a PM, sorry